Condividi:        

Cerca un valore ed i suoi corrispondenti

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca un valore ed i suoi corrispondenti

Postdi Paolo67 » 03/10/23 21:56

Buonasera,
in una tabella ho 3 colonne con circa 50 righe.
Vorrei cercare un valore specifico nella prima colonna ed avere i corrispondenti valori nelle altre 2 colonne.
Mi spiego meglio:
A B C
1000 4 12
992 60 9
925 330 6
872 812 -2
..........
.........

Vorrei poter cercare ad esempio il valore 925 nella colonna A ed ottenere i valori corrispondenti nelle 2 celle di fianco (330 e 6)
Se può servire:
i valori della prima colonna (A) decrescono sempre
i valori della seconda colonna (B) aumentano sempre
i valori della terza colonna (C) possono essere sia positivi che negativi

Grazie per eventuali risposte
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Sponsor
 

Re: Cerca un valore ed i suoi corrispondenti

Postdi Anthony47 » 03/10/23 22:24

Ad esempio, con i dati in A2:C20
Codice: Seleziona tutto
=INDICE(C2:D20;CONFRONTA(925;A2:A20;0);0)
La formula va introdotta come "formula a matrice" in 2 celle affiancate, es E2:F2; quindi
-selezioni E2:F2
-copi la formula nella barra della formula
-confermi con Contr-Maiusc-Enter, non il solo Enter

Ho messo "925" dell'esempio direttamente nella formula, ma immagino che tu vorrai mettere il valore da cercare in una cella separata (es D2) e poi mettere l'indirizzo di cella invece che quel 925; quindi
Codice: Seleziona tutto
=INDICE(C2:D20;CONFRONTA(D2;A2:A20;0);0)


Prova...

PS: Indica sempre la versione Office che usi, magari inserendola nella firma, vedi viewtopic.php?f=26&t=97449
Avatar utente
Anthony47
Moderatore
 
Post: 19211
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca un valore ed i suoi corrispondenti

Postdi Paolo67 » 04/10/23 20:30

Ciao Anthony,scusa ma nellatua prima formula il valore D20 sei sicuro sia corretto?Mi da errore
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Re: Cerca un valore ed i suoi corrispondenti

Postdi Paolo67 » 04/10/23 20:52

Ti riporto parte del mio foglio:
Le colonne sono:

BM BN BO

1023 11 24,6
1007 149 21,8
1000 210 21,2
955 605 17,9
948 669 17,4
941 732 17,8
931 823 17,6
925 878 17,4
850 1596 11,8
814 1957 9,0
793 2173 7,9
769 2427 6,6

Così vedi praticamente.
Le celle ove visualizzo i 3 valori (925 878 17,4) sono rispettivamente in:BZ18,CA18,CB18
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Re: Cerca un valore ed i suoi corrispondenti

Postdi Anthony47 » 04/10/23 21:36

Avevo fatto prove usando altre colonne, trascrivendo ho cappellato.
Se i dati sono in BZ-CA-CB, la prima formula:
Codice: Seleziona tutto
 =INDICE(CA2:CB20;CONFRONTA(925;BZ2:BZ20;0);0)

Analoga modifica va fatta alla seconda formula

PS: Ma i dati sono in BZ-CA-CB o in BM-BN-BO
Avatar utente
Anthony47
Moderatore
 
Post: 19211
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca un valore ed i suoi corrispondenti

Postdi Paolo67 » 04/10/23 21:44

I dati in input sono nelle colonne BM-BN-BO mentre ove vorrei visualizzare i 3 risultati BZ-CA-CB
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Re: Cerca un valore ed i suoi corrispondenti

Postdi Anthony47 » 04/10/23 22:08

Quindi la formula sara'
Codice: Seleziona tutto
=INDICE(BN2:BO20;CONFRONTA(BZ2;BM2:BM20;0);0)
Avatar utente
Anthony47
Moderatore
 
Post: 19211
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca un valore ed i suoi corrispondenti

Postdi Paolo67 » 08/10/23 06:07

Grazie Anthony
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Re: Cerca un valore ed i suoi corrispondenti

Postdi Paolo67 » 08/10/23 06:55

E se io ho 2 colonne con questi valori:

BN BO
178 22,1
209 21,4
252 20,0
348 19,2
357 19,1
450 18,3
512 17,2
... ...

E volessi conoscere il valore,ovviamente stimato, corrispondente al 366 (che in realtà manca nella colonna BN)?
Non so se sono stato chiaro,mi spiego meglio.
Nella colonna BN ci sono valori man mano sempre decrescenti e nella colonna di fianco BO valori anche essi quasi sempre decrescenti.
Avrei bisogno di conoscere al valore ad esempio 366 (che non compare nella colonna BN) il suo corrispondente stimato nella colonna BO.
:roll:
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Re: Cerca un valore ed i suoi corrispondenti

Postdi Paolo67 » 08/10/23 09:09

Allorappliicando le formule dai post precedenti son riuscito a trovare il valore più piccolo vicino a 366 e quello immediatamente più grande con i valori corrispondenti.
Ho cioè trovato:
357 19,1
450 18,3

Come faccio a stimare adesso il valore tra 19,1 e 18,3 corrispondente a 366?
Bisogna utilizzare la funzione PREVISIONE?
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Re: Cerca un valore ed i suoi corrispondenti

Postdi Paolo67 » 08/10/23 09:30

Mi rispondo da solo...SI
Risolto
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35


Torna a Applicazioni Office Windows


Topic correlati a "Cerca un valore ed i suoi corrispondenti":

BTp Valore
Autore: MarioLombardi
Forum: Forum off-topic
Risposte: 2

Chi c’è in linea

Visitano il forum: Anthony47, systemcrack e 26 ospiti