Condividi:        

Calcolo Giorni Settimana mancanti

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Calcolo Giorni Settimana mancanti

Postdi Ricky0185 » 21/11/22 08:57

Buongiorno,
Sto cercando la formula che qualunque sia la data di OGGI() mi dia come risultato 2 per ogni settimana intera fino a fine mese e mi dia 1 se OGGI() è compreso tra Dom-Merc o tra Gio-Sab, sempre per ogni settimana fino a fine mese. Il risultato mi deve dare un numero intero che poi moltiplicherò.
Ho provato
=ARROTONDA.PER.ECC(((FINE.MESE(OGGI();0)-OGGI()+1)/7);1)*40
E per oggi 21 Nov è corretto, ma se provo dall’1 sbalina.
Saluti
R

PS Improvvisamente da qualche giorno i caratteri della Vs pagina sono diventati piccolissimi
Immagine
Ricky0185
Utente Senior
 
Post: 252
Iscritto il: 10/12/19 20:38

Sponsor
 

Re: Formula Arrotonda

Postdi Dylan666 » 21/11/22 09:13

Ricky0185 ha scritto:PS Improvvisamente da qualche giorno i caratteri della Vs pagina sono diventati piccolissimi
Immagine

I caratteri sono sempre uguali, premi Ctrl+0 per fare un reset dello zoom del browser ;)
Avatar utente
Dylan666
Moderatore
 
Post: 39977
Iscritto il: 18/11/03 16:46

Re: Formula Arrotonda

Postdi Anthony47 » 21/11/22 10:01

Mi rifiuto di prendere in considerazione il quesito se prima non chiarisci che cosa tu intenda per Settimana, quando comincia, come allocare le settimane a cavallo tra i mesi.
Poi nelle convenzioni che uso io TUTTI i giorni della settimana sono compresi negli intervalli "Dom-Merc" o "Gio-Sab"; tu invece come la interpreti?

Poi, chiariti i preliminari, quando dici "2 per ogni settimana intera" intendi che vengano contate le settimane intere mancanti al fine mese e si moltiplichi per 2; vero?

Il tuo Excel ha la funzione NUM.SETTIMANA? E (chiedo sapendo la risposta) la funzione NUM.SETTIMANA.ISO?
Avatar utente
Anthony47
Moderatore
 
Post: 19168
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Arrotonda

Postdi Ricky0185 » 21/11/22 12:52

Forse chiarendo l’obbiettivo della mia richiesta si capisce meglio. Tutti i Martedì e Venerdì di ogni settimana del mese (di ogni mese) ho una spesa di 20 euro. Mi interessa sapere, in qualunque giorno del mese = OGGI() ed in tempo reale, quanto dovrò spendere fino a fine mese. Esempio da oggi 21 Novembre dovrò spendere 40 (questa settimana) + 20 (la prossima). Dall’1 Novembre 40+40+40+40+20.
Immagine

Purtroppo Ctrl+0 (zero) non funziona
Immagine
XP+Office2003
Che Scemo, solo nella compilazione del messaggio restano i caratteri piccolissimi
Ricky0185
Utente Senior
 
Post: 252
Iscritto il: 10/12/19 20:38

Re: Calcolo Giorni Settimana mancanti

Postdi Anthony47 » 21/11/22 14:17

Forse chiarendo l’obbiettivo della mia richiesta si capisce meglio. Tutti i Martedì e Venerdì di ogni settimana del mese (di ogni mese) ho una spesa di 20 euro. Mi interessa sapere, in qualunque giorno del mese = OGGI() ed in tempo reale, quanto dovrò spendere fino a fine mese
Si, così diventa chiaro...
Questa formula ti dice quanti Ma e Ve ci sono da oggi alla fine del mese (compresi oggi e fine mese)
Codice: Seleziona tutto
=SOMMA(--(RESTO(GIORNO.SETTIMANA(RIF.RIGA(INDIRETTO(OGGI()&":"&FINE.MESE(OGGI();0)));1);3)=0))

Devi usare Contr-Maiusc-Enter

Se vuoi fare il calcolo da una data qualsiasi alla fine di quel mese qualsiasi, sostituisci quei 2 OGGI() con una cella che contiene quella data qualsiasi; es
Codice: Seleziona tutto
=SOMMA(--(RESTO(GIORNO.SETTIMANA(RIF.RIGA(INDIRETTO(A2&":"&FINE.MESE(A2;0)));1);3)=0))

(data in A2)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 19168
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Calcolo Giorni Settimana mancanti

Postdi Ricky0185 » 21/11/22 17:49

Perfetto, grazie.
R
Ricky0185
Utente Senior
 
Post: 252
Iscritto il: 10/12/19 20:38


Torna a Applicazioni Office Windows


Topic correlati a "Calcolo Giorni Settimana mancanti":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti