Condividi:        

Calcolo di scadenze regolari

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Calcolo di scadenze regolari

Postdi wallace&gromit » 13/10/22 13:58

Ciao a tutti!
Questa è difficile (almeno penso)!
Avrei bisogno di creare liste variabili di date.
Le date di inizio e di fine sono conosciute:
iniziano sempre con il primo di un mese e finiscono con un altro primo di un mese.
la distanza tra le due è di al minimo un anno fino a vari anni.
In mezzo vorrei avere un tot di date, sempre al primo del mese.
E qui arriva il bello, possono variare da un minimo di 11 al massimo di 23.

Esempio semplice date limite:
1.1.2021 / 1.1.2022 -> facile (è un anno), in mezzo ci sono 11 date
1.1.2020 / 1.1.2022 -> qui sono due anni, in mezzo ci sono 23 date e tutto fila liscio
1.1.2019 / 1.1.2022 -> tre anni, non posso rappresentare tutti i mesi, salterà ogni due mesi a partire da marzo 2019: 17 date rappresentate.

Volendo, se il ritmo dei mesi lo impone, la data finale può essere posticipata leggermente

Qualche idea?
Office2016 + 2019 su win11
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2174
Iscritto il: 16/01/12 14:21

Sponsor
 

Re: Calcolo di scadenze regolari

Postdi Anthony47 » 13/10/22 14:50

Piu' che altro difficile da capire...
La difficolta' che vedi quale è far stare in 23 caselle 36 date, o che cosa?

Dove si trovano le date di Inizio e Fine e dove vanno create le relative max 23 date? Quando bisogna comprimere (es 36 date in 23 caselle) c'e' una regola da rispettare per scrivere le 23 possibili o la inventiamo, tipo dopo un tot di date si va di 2 mesi per stare nelle 23?

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 19225
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Calcolo di scadenze regolari

Postdi wallace&gromit » 13/10/22 16:03

La data di partenza e quella arrivo si trovano in due celle distinte.

Il numero di date intermedie è variabile, ma il passo deve sempre essere costante, se si parte con un mese deve essere sempre un mese, non so se il file allegato chiarisce di più.


https://filedropper.com/d/s/897MPCOZIW5UGjMiFHnTrwBQ8uwgLD
Office2016 + 2019 su win11
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2174
Iscritto il: 16/01/12 14:21

Re: Calcolo di scadenze regolari

Postdi Anthony47 » 13/10/22 16:34

Ad esempio, sul tuo schema:
-in E2 metti =A2
-in E3 metti
Codice: Seleziona tutto
=SE(E2<$B$2;FINE.MESE(E2;SE(DATA.DIFF($A$2;$B$2;"m")>23;1;0))+1;"")

Copi poi verso il basso fino ad avere risultato "vuoto"

Purtroppo per E19 la formula va modificata a mano, cambiando i riferimenti da $A$2 a $A$18 e da $B$2 a $B$18

Immagine

Prova...
Avatar utente
Anthony47
Moderatore
 
Post: 19225
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Calcolo di scadenze regolari

Postdi wallace&gromit » 13/10/22 16:53

Il secondo elenco era solo esplicativo, mi serve un elenco alla volta, che partirà sempre dall'alto.

Mi stavo divertendo a vedere vari casi e sembra che per un po' di anni va bene, se esagero tornando indietro nel tempo (tipo 2016) non funziona, nel senso che crea troppe date, il limite deve rimanere entro le 23 date (ancora più estremo, nel caso del 1998, ma non mi spingo fino a lì, dovrebbe farmi un valore all'anno).
Office2016 + 2019 su win11
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2174
Iscritto il: 16/01/12 14:21

Re: Calcolo di scadenze regolari

Postdi Anthony47 » 13/10/22 20:08

Se vuoi poter esagerare con l'intervallo di date, allora la formula di E3 puo' diventare
Codice: Seleziona tutto
=SE(E2<$B$2;FINE.MESE(E2;ARROTONDA(DATA.DIFF($A$2;$B$2;"M")/23;0))+1;"")
Cioe' incremento il delta tra le date in funzione di quanti mesi vanno coperti

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 19225
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Calcolo di scadenze regolari

Postdi wallace&gromit » 14/10/22 07:43

Sembra perfetto, oggi non posso provarla, ti dirò lunedì.
Office2016 + 2019 su win11
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2174
Iscritto il: 16/01/12 14:21

Re: Calcolo di scadenze regolari

Postdi wallace&gromit » 17/10/22 08:30

Così è perfetta!
Office2016 + 2019 su win11
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2174
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "Calcolo di scadenze regolari":


Chi c’è in linea

Visitano il forum: Nessuno e 64 ospiti

cron