Condividi:        

somma fino all'ultimo valore

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

somma fino all'ultimo valore

Postdi marcoc » 17/04/24 10:25

ciao a tutti,
esiste un modo per scrivere (es. in cella A1) la somma dei valori sottostanti, senza mettere il riferimento all'ultima cella in basso?

In pratica una cosa simile a "=SOMMA(A2:Axx)", dove Axx è una variabile che si determina da sola in base all'ultimo valore che trova in basso.

Non va bene un semplice "=SOMMA(A:A)" proprio perché la formula la devo scrivere in A1.

che dite?
grazie
marco
Avatar utente
marcoc
Utente Senior
 
Post: 320
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: somma fino all'ultimo valore

Postdi Anthony47 » 17/04/24 12:35

Ad esempio
Codice: Seleziona tutto
=Somma(A2:A100000)
E se 100mila non ti basta, fai pure 200000 o quello che serve a stare tranquillo
Avatar utente
Anthony47
Moderatore
 
Post: 19244
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: somma fino all'ultimo valore

Postdi marcoc » 19/04/24 20:44

ci ho pensato, ma se faccio un intervallo molto lungo, non rischio di aumentare le dimensioni del file "per niente", o non rischio lunghi tempi di ricalcolo in alcuni casi?

ci vorrebbe una roba con un simbolo, tipo "=SOMMA(A2:A#)" dove il cancelletto significa "fino all'ultima cella compilata che trovi"
Avatar utente
marcoc
Utente Senior
 
Post: 320
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: somma fino all'ultimo valore

Postdi Anthony47 » 19/04/24 21:56

Credimi, "costa" meno fare la somma di un intervallo inutilmente lungo che calcolare il valore di ## (che, detto per inciso, andrebbe fatto traguardando un intervallo inutilmente lungo). D'altra parte un intervallo inutilmente lungo non influisce sulla dimensione del file (che dipende principalmente da quante celle sono usate nel foglio)
Avatar utente
Anthony47
Moderatore
 
Post: 19244
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: somma fino all'ultimo valore

Postdi marcoc » 20/04/24 18:56

perfetto, grazie mille Anthony
Avatar utente
marcoc
Utente Senior
 
Post: 320
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "somma fino all'ultimo valore":

BTp Valore
Autore: MarioLombardi
Forum: Forum off-topic
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 49 ospiti

cron