Condividi:        

Excel 2016 - Funzione SCARTO + INDIRETTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel 2016 - Funzione SCARTO + INDIRETTO

Postdi pl1957 » 16/02/24 13:06

Buongiorno a tutti.
Ho il problema di dover eseguire la funzione SCARTO rispetto ad un punto di partenza variabile.

Facendo riferimento al foglio allegato (https://we.tl/t-MCpZIVoIK1 - scadenza link 23/02/2024) ho bisogno che, in coda al valore risultante dalla formula nella colonna ETICHETTA nel foglio Proto, appaia il corrispondente codice della voce VARIE estrapolato dal foglio Dati1.
Nel caso dell'esempio nel campo ETICHETTA della prima riga dovrebbe leggersi 2024E0001A15.

Poiché, però, il valore A15 fa riferimento alla voce "Estratto Conto" presente in M2 avrei bisogno che, al variare del dato in M2, A15 diventasse B15, C15, ecc.

Un tentativo (fallito) di formula è stato INDICE(SCARTO(INDIRETTO(M2);0;1);CONFRONTA(M3;INDIRETTO(M2)))

Si accettano idee.

Grazie in anticipo.

IMPORTANTE: Allo stato attuale solo la prima riga del foglio PROTO è stata compilata. Le formule non sono state copiate nelle righe sottostanti.
Avatar utente
pl1957
Utente Junior
 
Post: 31
Iscritto il: 29/09/12 08:14
Località: Marche

Sponsor
 

Re: Excel 2016 - Funzione SCARTO + INDIRETTO

Postdi Anthony47 » 16/02/24 17:44

Prova in N2:
Codice: Seleziona tutto
=SE(C4="";"";ANNO(C4)&B2&TESTO(A2;"0000"))&INDICE(Dati1!$A$1:$M$24;CONFRONTA("VARIE";INDICE(Dati1!$A$1:$M$24;0;CONFRONTA(M2;Dati1!$A$1:$M$1;0));0);CONFRONTA(M2;Dati1!$A$1:$M$1;0)+1)

E' la tua formula piu' una seconda parte che serve ad accodare l'informazione aggiuntiva
Se tu avessi Office 365 oppure 2021 la formula potrebbe essere semplificata
In assenza di altre informazioni sulla struttura della tabella in foglio Dati1 ho ignorato che "VARIE" e' in tutti i casi sempre su riga 17

Prova...
Avatar utente
Anthony47
Moderatore
 
Post: 19225
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel 2016 - Funzione SCARTO + INDIRETTO

Postdi pl1957 » 16/02/24 19:59

Grazie, Anthony. Funziona perfettamente.
Ho solo sostituito la costante "VARIE" che tu avevi inserito nella formula con il riferimento alla cella M3.
Per il resto non fa una grinza.

In realtà, la tabella in Dati1 verrà popolata con i vari "oggetti" (esempio, per "Estratto conto", "Gestione titoli", "Bonifici", e via dicendo). A chiudere la lista per la tendina, il "VARIE"di cui sopra.

Vero: restano dei vuoti in mezzo, ma come eliminarli me lo avevate già insegnato in passato :lol:
Avatar utente
pl1957
Utente Junior
 
Post: 31
Iscritto il: 29/09/12 08:14
Località: Marche


Torna a Applicazioni Office Windows


Topic correlati a "Excel 2016 - Funzione SCARTO + INDIRETTO":


Chi c’è in linea

Visitano il forum: Nessuno e 112 ospiti