Condividi:        

Formula Excel copia righe e colonne

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula Excel copia righe e colonne

Postdi Francesco6918 » 29/09/23 20:36

Buonasera a tutti voi non riesco a risolvere un problema con la formula che copia righe e colonne con condizione, mi spiego se in AG8 inserisco i valori da 1,2,3 mi trova tale valore nella colonna $AG$26:$AG$70 ,e mi copia in AG10 trascinandola da destra e in giù 10 righe e 6 colonne, questa formula funziona solo se inserisco il numero 1 in AG8, se inserisco il numero 2, 3 in AG8 mi salta tutto questa e la formula in AG10 : =SE.ERRORE(SCARTO($AG$27;CONFRONTA($AG$8;$AG$26:$AG$70;0)+RIGHE($1:1)-1;COLONNE($A:A)-1);0) allego il file esempio.

Grazie

https://we.tl/t-BgHc0tLkVQ
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20

Sponsor
 

Re: Formula Excel copia righe e colonne

Postdi Anthony47 » 29/09/23 23:05

Cancella tutte le formule che hai inserito e prova in AG10
Codice: Seleziona tutto
=SCARTO($AG$27;1+CONFRONTA(AG8&AH8;AG27:AG600&AH27:AH600;0);0;10;6)

Da confermare con Contr-Maiusc-Enter, non il solo Enter

Se pensi che l'elenco in cui cercare vada oltre riga 600 allora modifica coerentemente quei due "600"

Fai sapere...
Avatar utente
Anthony47
Moderatore
 
Post: 19261
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Excel copia righe e colonne

Postdi Francesco6918 » 30/09/23 08:16

Ciao Anthony47 grazie perfetto.
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20


Torna a Applicazioni Office Windows


Topic correlati a "Formula Excel copia righe e colonne":


Chi c’è in linea

Visitano il forum: Nessuno e 47 ospiti