Condividi:        

Aiuto per formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Aiuto per formula

Postdi marte1503 » 24/12/22 18:35

Ciao a tutti, torno con un nuovo problema e con l'occasione auguro Buone Feste a tutti.

Il mio foglio è basato su 2 colonne e 1Cella.

Il titolo di Colonna A è optional;
quello della colonna B Montato,
nella cella C1 ci sono un elenco di accessori separati da trattini. Es. --vernice metallizzata--cambio automatico--sedili in pelle--

Da A2 a A10 vengono elencati una serie di accessori che possono cambiare perché restituiti da una formula cerca orizzontale.

Mi servirebbe una formula da copiare nelle celle da B2 a B10 che controllasse il testo delle celle da A2 a A10 e se l'accessorio fosse presente all'interno della Cella C1 mi restituisse una "X" in Colonna B (montato) , se non ci fosse le celle devono rimanere vuote

es.

cella C1 --vernice metallizzata--cambio automatico--sedili in pelle--

cella A2 Sedili in pelle (esiste in C1 sedili in pelle ? (sì)) cella B2 X
cella A3 Cerchi da 17" (esiste in C1 cerchi da 17" ? (no)) cella B3
cella A4 Vernice metallizzata (esiste in C1 vernice metallizzata? (sì)) cella B4 X


Ringrazio
marte1503
Utente Senior
 
Post: 232
Iscritto il: 08/01/10 20:43
Località: Como

Sponsor
 

Re: Aiuto per formula

Postdi Anthony47 » 24/12/22 19:13

Prova in B2:
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA(MAIUSC("--"&A2&"--");MAIUSC(C$1)));"";"X")

Poi copia verso il basso q.b.
Avatar utente
Anthony47
Moderatore
 
Post: 19263
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Aiuto per formula

Postdi marte1503 » 24/12/22 23:08

Perfetta!
:) TNX :)
marte1503
Utente Senior
 
Post: 232
Iscritto il: 08/01/10 20:43
Località: Como


Torna a Applicazioni Office Windows


Topic correlati a "Aiuto per formula":


Chi c’è in linea

Visitano il forum: systemcrack e 59 ospiti