Condividi:        

Formula Scarto E Cocatena

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula Scarto E Cocatena

Postdi Francesco6918 » 13/01/22 19:38

Buona sera a tutti vorrei modificare la formula scarto e concatena , nel mio post precedente Formula Concatena Numeri grazie a Anthony47 con questa formula =SE(E(X7=81;CONTA.SE(SCARTO(X7;1-V7;0;9;1);80)>0);"80-81";"") in AA7 concatena tutti i numeri della colonna X7 fino X38 la formula funziona benissimo, la mia modifica riguardo con più colonne l intervallo X7:AB7 dove si possono trovare i numeri 80 e 81 da concatenare nella colonna AE7, allego il file precede con la formula di Anthony47 (Prova Concatena) e il file attuale (Prova Concatena 01) spero di essermi spiegato ma i due file danno più chiarezza.

Grazie

https://we.tl/t-rePNtF8E83

https://we.tl/t-SIwFuvXlbz
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20

Sponsor
 

Re: Formula Scarto E Cocatena

Postdi Anthony47 » 13/01/22 21:17

Mah, modificare una formula senza sapere cosa si vorrebbe ottenere e' come rispondere a una domanda non ancora posta...

Comunque non escludo che questa possa dare il risultato che si vuole:
In AE7
Codice: Seleziona tutto
=SE(E(CONTA.SE(X7:AB7;81)>0;CONTA.SE(SCARTO(X7;1-V7;0;9;1);80)>0);"80-81";"")
poi copiare verso il basso.

E se invece "stranamente" non funzionasse allora spiega quale logica la formula deve realizzare

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 19245
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Scarto E Cocatena

Postdi Francesco6918 » 13/01/22 22:31

Ciao Anthony47 lo scarto funziona solo sulla colonna X7 non su tutte le colonne X7:AB7 dunque se i numeri sono presenti in tutta la tabella la formula non funziona questo e il problema lo scarto deve funzionare dal intervallo X7:AB7.

Grazie
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20

Re: Formula Scarto E Cocatena

Postdi Anthony47 » 13/01/22 23:50

Hai detto la meta' di quel che aspettavo di leggere...
Codice: Seleziona tutto
=SE.ERRORE(SE(CONTA.SE(SCARTO(X7;1-V7;CONFRONTA(81;X7:AB7;0)-1;9;1);80)>0;"80-81";"");"")
:?:
Avatar utente
Anthony47
Moderatore
 
Post: 19245
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Scarto E Cocatena

Postdi Francesco6918 » 14/01/22 00:28

Ciao Ciao Anthony47 la formula é giusta ma funziona solo se i due numeri sono nella stessa colonna , esempio il numero 80 cella AA20 e il numero 81 cella AB21 non funziona allego il file o colorato di rosso le 2 celle in sono presenti il numero 80 e 81 cui la formula non concatena i risultati.

Grazie

https://we.tl/t-0NoPrASRWg
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20

Re: Formula Scarto E Cocatena

Postdi Anthony47 » 14/01/22 09:36

Non lasciarmi tirare a indovinare: cosa dovrebbe fare la formula che cerchi?
Avatar utente
Anthony47
Moderatore
 
Post: 19245
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Scarto E Cocatena

Postdi Francesco6918 » 14/01/22 10:54

Ciao Anthony riporto un semplice esempio vorrei concatenare il valore della cella AA7 con il valore della cella Y9 come risultato nella colonna AC9, allego il file.

Grazie

https://we.tl/t-le7mkSaWvs
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20

Re: Formula Scarto E Cocatena

Postdi Anthony47 » 14/01/22 15:33

Non ne usciamo...
Perché, per quale regola, in AC9 c'è quel risultato e invece nelle altre no?
Sto cercando la regola generale che la formula deve realizzare.
Avatar utente
Anthony47
Moderatore
 
Post: 19245
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Scarto E Cocatena

Postdi Francesco6918 » 14/01/22 17:13

Ciao Ciao Anthony va bene anche AC7 l importante trovare la formula che concatena i valori.
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20

Re: Formula Scarto E Cocatena

Postdi Anthony47 » 14/01/22 19:18

Non posso scrivere una formula che concatena il valore A con il valore B se non so dove devo cercare A, dove devo cercare B, quale condizione deve essere verificata per restituire il concatenamento invece che la stringa "nulla".
E' su questo che chiedo lumi, altrimenti "non ne usciamo"!
Avatar utente
Anthony47
Moderatore
 
Post: 19245
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Scarto E Cocatena

Postdi Francesco6918 » 14/01/22 19:40

Ciao Anthony o fatto una prova non so se e giusta comunque con la tua formula : =SE(E(CONTA.SE(X7:AB7;81)>0;CONTA.SE(SCARTO(X7;1-V7;0;9;1);80)>0);"80-81";"") eliminando tutti i numeri della colonna X7:X38 non concatena , modificando V7;0;9;1 con V7;0;9;5 , o modificato 1 con il 5 e inserito la formula in AG7 o notato che concatena dunque il problema riguardo lo scarto, allego il file.



https://we.tl/t-HSMAnEqpHZ
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20

Re: Formula Scarto E Cocatena

Postdi Anthony47 » 14/01/22 23:40

MI DEVI CREDERE: non ho capito che cosa vuoi che la formula faccia. E non e' con formule che quella cosa misteriosa non la fanno che io riusciro' a capire qual'e' la cosa misteriosa.

O mi spieghi quale e' la regola che la formula deve realizzare o non ne veniamo fuori
Avatar utente
Anthony47
Moderatore
 
Post: 19245
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula Scarto E Cocatena

Postdi Francesco6918 » 15/01/22 00:43

Ciao Anthony rinuncio non sono questi i problemi comunque ti ringrazio alla prossima formula.

Saluti
Francesco6918
Utente Senior
 
Post: 267
Iscritto il: 04/03/11 11:20


Torna a Applicazioni Office Windows


Topic correlati a "Formula Scarto E Cocatena":


Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti

cron