Condividi:        

Formula per estrarre Stringa di testo da cella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula per estrarre Stringa di testo da cella

Postdi Omocaig » 30/10/23 10:33

Ciao a tutti,
puntualmente estraggo in un file excel il contenuto di una mail che è formattata sempre allo stesso modo.
Sto cercando di ricreare una formula per estrarre dalla cella in cui salvo il body della mail il testo contenuto tra i seguenti valori
Il testo ha una lunghezza variabile ed è contenuto ovviamente sempre tra questi valori:

Codice: Seleziona tutto
"Descrizione:</td><td style=""font-family:verdana,geneva; font-size:10pt; color:#000000; width:90%; vertical-align:middle; background-color:#ffe6e6; height:15px""


e

Codice: Seleziona tutto
"</td></tr></tbody></table></td></tr></tbody></table><p>&nbsp;</p><br><br><a id=""snc_notification_unsubscribe"" href=""mailto:sparkeurope@sky.eu?subject=Unsubscribe from &quot;Case Assigned to a Group&quot;&amp;body="""


Riuscireste a darmi una mano?

Grazie,
Giacomo
Xp + Office 2016 Ita
Omocaig
Utente Junior
 
Post: 93
Iscritto il: 11/05/15 15:08

Sponsor
 

Re: Formula per estrarre Stringa di testo da cella

Postdi Anthony47 » 30/10/23 13:02

Allora, metti la prima stringa in L1 (o altra cella libera) e la seconda in L2 (idem)
Poi, se il "sorgente" della mail e' in A2, prova con la formula
Codice: Seleziona tutto
=SE((SE.ERRORE(TROVA(MAIUSC(L1);MAIUSC(A2));0))*(SE.ERRORE(TROVA(MAIUSC(L2);MAIUSC(A2));0))>0;STRINGA.ESTRAI(A2;SE.ERRORE(TROVA(MAIUSC(L1);MAIUSC(A2));0)+LUNGHEZZA(L1);LUNGHEZZA(A2)-LUNGHEZZA(L1)-LUNGHEZZA(L2));"XX")

Se nel sorgente non vengono trovati i due marker la formula restituisce XX

Prova... ma secondo me deve esserci un metodo piu' "scientifico": prova ad allegare il sorgente completo di una mail in cui il "testo utile" sia stato sostituito com la stringa "<QUESTO E' IL TESTO>" e vedremo
Avatar utente
Anthony47
Moderatore
 
Post: 19245
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Formula per estrarre Stringa di testo da cella":


Chi c’è in linea

Visitano il forum: Nessuno e 29 ospiti

cron