Condividi:        

Trovare 2 valori prossimi allo zero

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Trovare 2 valori prossimi allo zero

Postdi Paolo67 » 02/10/23 19:47

Ciao a tutti,
avrei un quesito che non riesco a risolvere:

Ho 2 colonne nelle quali ci sono numeri.
Dovrei trovare all'interno di queste 2 colonne
A-i 2 valori più vicini (sia negativo che positivo) allo zero
B-i 2 valori nelle rispettive celle di fianco

Esempio

A1 A2
11 4,1
130 2,1
256 0,7
312 -1,1
445 -3,5

Dovrei trovare nella colonna A2 il valore positivo più vicino allo 0 (che sarebbe 0,7)
Dovrei trovare nella colonna A2 il valore negativo più vicino allo 0 (che sarebbe -1,1)
Il corrispondente valore di fianco al valore 0,7 (che sarebbe 256)
il corrispondente valore di fianco al valore -1,1 (che sarebbe 312)

Ringrazio anticipatamente chi mi può aiutare
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Sponsor
 

Re: Trovare 2 valori prossimi allo zero

Postdi Anthony47 » 02/10/23 23:22

Ad esempio, per cercare lo 0.7: in E2
Codice: Seleziona tutto
=MIN(SE((B1:B100>=0)*(B1:B100<>"");(B1:B100);9999))
Da confermare con Contr-Maiusc-Enter, non il solo Enter

Per cercare il -1.1, in E3:
Codice: Seleziona tutto
=MAX(SE((B1:B100<=0)*(B1:B100<>"");(B1:B100);-9999))
Stessa modalita' Contr-Maiusc-Enter

A questo punto, in D2:
Codice: Seleziona tutto
=INDICE($A$1:$A$10;CONFRONTA(E2;$B$1:$B$10;0))

copia quindi D2 in D3

Se hai versioni recenti di Office, tipo 2021 o 365, le formule potrebbero essere piu' semplici
Avatar utente
Anthony47
Moderatore
 
Post: 19299
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Trovare 2 valori prossimi allo zero

Postdi Paolo67 » 03/10/23 06:11

In primis grazie per la risposta Anthony.
Dunque utilizzando la tua formula per cercare 0,7 la cosa funziona.
ma se utilizzo la seconda formula per cercare -1,1 mi viene restituito -9999
Se può servire ho Excel 2003
Mi confermi che Contr-Maiusc-Enter viene ottenuto premendo CTRL-SHIFT-(o CAPS LOCK)-ENTER?
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35

Re: Trovare 2 valori prossimi allo zero

Postdi Anthony47 » 03/10/23 07:39

[...]ma se utilizzo la seconda formula per cercare -1,1 mi viene restituito -9999
O non ci sono numeri negativi, o "sembrano numeri ma sono stringhe" (prova a formattare con piu' decimali e controlla se cambia la visualizzazione), o hai sbagliato a copiare la formula. 1, x, 2?
Avatar utente
Anthony47
Moderatore
 
Post: 19299
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Trovare 2 valori prossimi allo zero

Postdi Paolo67 » 03/10/23 11:03

Probabilmente avevo sbagliato a digitare la formula.
A scanso di equivoci ho fatto il copia incolla direttamente da quella digitata da te e dopo aver cambiato le celle ha funzionato!
Grazie Anthony
:)
OFFICE 2003 - OFFICE 2007
Paolo67
Utente Senior
 
Post: 121
Iscritto il: 20/04/21 20:35


Torna a Applicazioni Office Windows


Topic correlati a "Trovare 2 valori prossimi allo zero":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti