Condividi:        

Excel Cerca verticale su fogli

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 00:09

Ciao a tutti,
con una formula,dovrei fare un cerca.verticale a condizione tra 10 fogli
esempio
se la cella A1 = 1 cerca.vert. foglio 1. valore. range
se la cella A1=2 cerca.vert .foglio2. valore. range
e cosi via,
posso farlo con una macro tipo copia e incolla,
in questo caso vorrei farlo con una formula.
grazie
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Sponsor
 

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 00:46

Per evitare un nuovo topic,posto quì la domanda.

Volendo incrementare il range della formula,
conta.se(C1:G1;1) in base al valore di una cella.A1
esempio
A1=5
Conta.se(C1:G5;1)
A1= 15
Conta.Se(C1:G15;1)
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Anthony47 » 13/02/10 01:47

In ambedue i casi userai Indiretto; es
Codice: Seleziona tutto
=CERCA.VERT(2;INDIRETTO("Foglio"&A1&"!A1:E20");3;0)
=Conta.se(Indiretto("C1:G"&A1);1)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 11340
Iscritto il: 21/03/06 17:03
Località: Ivrea

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 10:32

Ciao Anthony47,
ho un problema con la prima formula,come sempre è colpa mia ,
in quanto davo per scontato che la formula postata potevo adattarla al mio scopo.
Allora. la formula va bene se effettivamente ho foglio1,foglio2,foglio3 etc.
se invece i fogli hanno un nome,
esempio Bari,Cagliari,Genova etc.?
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 13:51

Ciao Anthony47,
ho un problema anche con la seconda formula,
la formula la devo applicare a più di un range,
esempio
facendo il conta.se di un range quando la copio e trascino in giù.
conta.se(B1:C5;1)
conta.se(B2:C6;1)
Conta.se(B3:C7;1)
quello che voglio fare e che mettendo un numero in A1=5 le formule cambiano così
conta.se(B1:C10;1)
conta.se(B2:C11;1)
Conta.se(B3:C12;1)
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Flash30005 » 13/02/10 18:27

Statix ha scritto:...
se invece i fogli hanno un nome,
esempio Bari,Cagliari,Genova etc.?

Prova così
Codice: Seleziona tutto
=CERCA.VERT(2;INDIRETTO(""&A1&"!A1:E20");3;0)

In A1, chiaramente, deve esserci il nome della ruota (Bari, Cagliari etc)

Ciao
Flash
Win7 + excel 2003/2010, access/word 2010 Ita
"Fotografica" al servizio dell'immagine

Ho smesso di fumare dal 17/03/2013 per sapere il risparmio in € usate questa formula
=(OGGI()-DATA(2013;3;16))*10
Fumatori, pensateci! :-)
Avatar utente
Flash30005
Moderatore
 
Post: 7940
Iscritto il: 27/09/07 12:44
Località: Roma +o-

Re: Excel Cerca verticale su fogli

Postdi Flash30005 » 13/02/10 18:50

Statix ha scritto:quello che voglio fare e che mettendo un numero in A1=5 le formule cambiano così
conta.se(B1:C10;1)
conta.se(B2:C11;1)
Conta.se(B3:C12;1)


Se la formula la inserisci nella prima riga puoi usare
Codice: Seleziona tutto
=CONTA.SE(INDIRETTO("C"&RIF.RIGA()&":G"&A$1*2+RIF.RIGA()-1);1)

dove -1 del codice
Codice: Seleziona tutto
+RIF.RIGA()-1;

corrisponde al numero riga iniziale poi trascini verso il basso
ciao
Flash
Win7 + excel 2003/2010, access/word 2010 Ita
"Fotografica" al servizio dell'immagine

Ho smesso di fumare dal 17/03/2013 per sapere il risparmio in € usate questa formula
=(OGGI()-DATA(2013;3;16))*10
Fumatori, pensateci! :-)
Avatar utente
Flash30005
Moderatore
 
Post: 7940
Iscritto il: 27/09/07 12:44
Località: Roma +o-

Re: Excel Cerca verticale su fogli

Postdi Anthony47 » 13/02/10 19:39

Per il Cerca.vert, se A1 contiene un numero e non direttamente il nome foglio (nel qual caso puoi usare la formula di Flash, vedi sopra), allora ti farai una tabellina con le corrispondenze tra Numero e NomeFoglio e poi userai Cerca.vert per associare numero e nome foglio; tipo
Codice: Seleziona tutto
=CERCA.VERT(2;INDIRETTO(Cerca.vert(A1;TabellaConv;2;0)&"!A1:E20");3;0)

Nel caso del Conta.Se, potrebbe essere piu' intuitivo l' uso della funzione Scarto, es
Codice: Seleziona tutto
=CONTA.SE(SCARTO(B1;0;0;$A$1+5;2);1)
$A$1+5 imposta un' area alta quanto il valore di A1+5; 2 imposta (nella formula data) un' area che comprende B e C; ergo B1:C(A1+5). Copiando la formula verso il basso cambia il riferimento di Scarto, e quindi cambia l' area individuata da Scarto.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 11340
Iscritto il: 21/03/06 17:03
Località: Ivrea

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 19:42

Ciao Flash30005,ciao Anthony47,
ho provato le formule,
sembra tutto ok per la seconda formula anche se è un pò complicata da controllare,
per la prima funziona,ma devo fare anche questa che si possa copiare e tirare giù.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 19:43

scusa Anthony47,
abbiamo postato nello stesso tempo,provo le formule che hai postato ok.
grazie
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 20:02

Ho fatto una prova con la formula di Anthony47,ma c'è qualcosa che non torna,
allego foto di esempio,la colonna in blu è il risultato della formula,invece se in a1=1 dovrebbe darmi la colonna in arancio se A1=2 la colonna successiva.
Immagine
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Anthony47 » 13/02/10 20:22

Come detto nel messaggio, la formula "conta.se" in un range che parte da B1, per una altezza di A1+5 righe e una larghezza di 2 colonne; quindi "quella" formula Conta in I1 gli 1 nel range B1:C6, e cosi' shiftando verso il basso.
A quale range invece e' associato il 2 di L1 e il 3 di N1?

Affinche'' la si copi adeguando gli indirizzi dovrebbe andare bene questa:
Codice: Seleziona tutto
=CERCA.VERT(5;INDIRETTO($A$1&"!"&INDIRIZZO(RIF.RIGA(A7);RIF.COLONNA(A7))&":"&INDIRIZZO(RIF.RIGA(B12);RIF.COLONNA(B12)));2;0)

A7 e B12 sono, nell' esempio, gli estremi del range in cui cercare; A1 contiene il nome foglio (se contiene un numero usare la versione con Cerca.vert($A$1;TabellaConv;2;0)


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 11340
Iscritto il: 21/03/06 17:03
Località: Ivrea

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 20:33

Ciao Anthony47,
La formula che hai postato prima per i fogli va benissimo,
Codice: Seleziona tutto
=CERCA.VERT(2;INDIRETTO(Cerca.vert(A1;TabellaConv;2;0)&"!A1:E20");3;0)


mentre per la seconda del conta.se non va,
la foto che ho allegata il conta.se si riferisce al range B1:F1
Codice: Seleziona tutto
=Conta.Se(B1:F1;1)

mettendo in A1=1 i risultati devono essere come la colonna in L
se invece metto in A1=2 come la colonna N
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 20:40

Se in A1= 1 il range conta.se(B1:F1;1)
se in A1=2 il range conta.se(B1:F2;1)
se in A1=3 il range conta.se(B1:F3;1)
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 20:49

Anthony,
la formula di Flash30005,
Codice: Seleziona tutto
=CONTA.SE(INDIRETTO("B"&RIF.RIGA()&":G"&A$1*1+RIF.RIGA()-1);1)

funziona benissimo ho solo il dubbio che spostando i range trovi della difficoltà.
grazie ad entrambi
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta

Re: Excel Cerca verticale su fogli

Postdi Anthony47 » 13/02/10 21:23

Prima avevi parlato di B1:C5 che, con 5 in A1, si estendeva fino a C10.
Per i nuovi range, B1:F1, la formula andra' cambiata in
Codice: Seleziona tutto
=CONTA.SE(SCARTO(B1;0;0;$A$1;5);1)

Nella formula $A$1 definisce l' altezza del range ritornato da Scarto, e 5 la larghezza. Cambierai questi due parametri per far riferimento ad aree diverse.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 11340
Iscritto il: 21/03/06 17:03
Località: Ivrea

Re: Excel Cerca verticale su fogli

Postdi Statix » 13/02/10 21:28

Ciao Anthony47
tutto ok, grazie di tutto,
ringrazio anche Flash30005
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1063
Iscritto il: 12/05/06 22:55
Località: Provincia di Caserta


Torna a Applicazioni Office Windows


Topic correlati a "Excel Cerca verticale su fogli":


Chi c’è in linea

Visitano il forum: alfrimpa, gaelory e 19 ospiti