Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel: conta.se ... complicato

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel: conta.se ... complicato

Postdi karug64 » 18/05/20 23:00

Salve a tutti.

Nel mio foglio (prodotto in automatico da una procedura) ho le celle in colonna "A" che contengono un testo così strutturato:

DES:mela,pera,kiwi;IMP:fragola,ananas;DOC:fragola,ananas;
IMP:mela,fragola;DOC:mela,fragola;
DES:melone,anguria,fichi;IMP:-;DOC:-;

la struttura è così composta
DES:
può esserci o no. Se è presente i campi che seguono i due punti sono divisi da virgola
IMP:
c'è sempre. I campi sono separati da virgola e se non ci sono vengono sostituiti da "-"
DOC:
c'è sempre. I campi sono separati da virgola e se non ci sono vengono sostituiti da "-"

IMP e DOC se presenti generalmente coincidono nel contenuto dei campi (ma potrebbero anche essere differenti).

in colonna B ho i possibili valori (anche quelli non utilizzati) che possono essere presenti dopo DES: IMP: DOC: quindi
mela
pera
kiwi
fragola
ananas
melone
anguria
fichi
banane
albicocche

Il quesito: avrei bisogno di una formula che contasse per tutti i valori presenti nella stringa la tipologia trovata senza ripetizioni.

Nell'esempio proposto, in colonna C, accanto a
- mela avrei 2 (la seconda riga contiene 2 volte mela e quindi va conteggiata una sola volta)
- pera 1
- kiwi 1
- fragola 2
- ananas, melone, anguria, fichi 1

Secondo voi è possibile o devo andare di Vba ?

Grazie
Office 2010
karug64
Utente Senior
 
Post: 741
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel: conta.se ... complicato

Postdi Anthony47 » 19/05/20 00:34

Non sono certo di aver capito, ma prova in C2:
=SOMMA(--(LUNGHEZZA($A$2:$A$20)>LUNGHEZZA(SOSTITUISCI($A$2:$A$20;B2;""))))
Da confermare con Contr-Maiusc-Enter, non il solo Enter, e poi copiare verso il basso.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16958
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel: conta.se ... complicato

Postdi karug64 » 19/05/20 21:40

Ciao Anthony, a me la soluzione proposta non funziona. Non so cosa sbaglio.

Allego un piccolo file di esempio

http://www.filedropper.com/cartel1_2

Grazie
Office 2010
karug64
Utente Senior
 
Post: 741
Iscritto il: 20/11/11 21:22

Re: excel: conta.se ... complicato

Postdi Anthony47 » 19/05/20 22:40

Avevi detto che l'elenco dei nomi era in colonna B e i testi compositi erano in colonna A; ma in questo file li trovo invertiti...
Inoltre avevo immaginato che i dati cominciassero da riga 2, e la riga 1 fosse occupata da intestazioni.

Col layout che hai allegato, in C1
Codice: Seleziona tutto
=SOMMA(--(LUNGHEZZA($B$1:$B$10)>LUNGHEZZA(SOSTITUISCI($B$1:$B$10;A1;""))))


Sempre contr-maiusc-enter e poi copiare verso il basso

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16958
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel: conta.se ... complicato

Postdi karug64 » 19/05/20 22:43

Perfetto !!

Grazie
Office 2010
karug64
Utente Senior
 
Post: 741
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "excel: conta.se ... complicato":

Excel VUOTO
Autore: papiriof
Forum: Applicazioni Office Windows
Risposte: 4

Chi c’è in linea

Visitano il forum: Anthony47, Marius44 e 24 ospiti