Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] unire valori righe se uguali

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] unire valori righe se uguali

Postdi Helio » 11/01/19 20:10

salve a tutti,

avendo un file di esempio tipo quello riportato sotto, mi interesserebbe unire i valori delle righe quando le prime due colonne hanno lo stesso dato. cioè se mi venisse riportato sulle righe bianche, quelle vuote, i dati riportati nelle righe rosse, se ovviamente ci sono nomi e cognomi uguali.

http://www.filedropper.com/esempio_1

spero di essermi spiegato...

grazie a tutti!
Helio
Newbie
 
Post: 8
Iscritto il: 20/10/17 17:20

Sponsor
 

Re: [excel] unire valori righe se uguali

Postdi Anthony47 » 12/01/19 16:45

Il sistema piu' semplice che hai a disposizione e' di elaborare i risultati che cerchi in due nuove colonne.
Esempio:
In E1 inserisci la formula
Codice: Seleziona tutto
=C1
Poi copi su F1

In E2 inserisci
Codice: Seleziona tutto
=SE(C2<>"";C2;SE(E($A2=$A1;$B2=$B1;C1<>"");C1;""))
Poi copi su F2

Infine copi E2:F2 verso il basso; le colonne E:F dovrebbero contenere quanto richiesto.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 16046
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] unire valori righe se uguali

Postdi Helio » 14/01/19 00:45

Anthony47 ha scritto:Il sistema piu' semplice che hai a disposizione e' di elaborare i risultati che cerchi in due nuove colonne.
Esempio:
In E1 inserisci la formula
Codice: Seleziona tutto
=C1
Poi copi su F1

In E2 inserisci
Codice: Seleziona tutto
=SE(C2<>"";C2;SE(E($A2=$A1;$B2=$B1;C1<>"");C1;""))
Poi copi su F2

Infine copi E2:F2 verso il basso; le colonne E:F dovrebbero contenere quanto richiesto.

Ciao

grazie mille...la formula sembra funzionare correttamente...

visto che spesso mi capitano situazioni simili, potresti spiegarmi la sequenza brevemente, in modo da capirla, e poterla adattare alla situazione? grazie

tipo hai scritto: se c2 <>""? che significa? se non ti va di spiegarmi grazie lo stesso
Helio
Newbie
 
Post: 8
Iscritto il: 20/10/17 17:20

Re: [excel] unire valori righe se uguali

Postdi alfrimpa » 14/01/19 11:14

Significa se la cella C2 non è vuota.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 1165
Iscritto il: 30/12/13 17:01
Località: Napoli


Torna a Applicazioni Office Windows


Topic correlati a "[excel] unire valori righe se uguali":


Chi c’è in linea

Visitano il forum: Nessuno e 30 ospiti

cron