Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Funzione CONTA.SE celle con data

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Funzione CONTA.SE celle con data

Postdi libraio » 30/01/21 15:35

So Windows7Pro + Office 2003

Ciao a tutti,
in un foglio excel 2003 vorrei contare in ogni riga celle con dati misti (testo, numero, data) le celle contenenti una data.
Esempio:
|01|aaa|01/02/2021|02|aaa|01/02/2021|03|aaa|10/01/2021|
Ho provato con la seguente funzione:
=CONTA.SE(A1:Z1;"&DATA")
ma ottengo solo la segnalazione di errore. Dove sbaglio?
Grazie a chi mi vorrà aiutare
libraio
Utente Senior
 
Post: 305
Iscritto il: 04/01/10 20:31

Sponsor
 

Re: Funzione CONTA.SE celle con data

Postdi Marius44 » 30/01/21 17:12

Ciao
Visto che le date sono tutte uguali prova con =CONTA.PIÙ.SE(A1:Z1;"01/02/2021")
Se non fossero tutte uguali usa una cella d'appoggio dove indichi la data che ti interessa, per esempio:
in AA1 01/02/2021 e come formula =CONTA.PIÙ.SE(A1:Z1;AA1)

Ciao,
Mario
Marius44
Utente Senior
 
Post: 542
Iscritto il: 07/09/15 22:00

Re: Funzione CONTA.SE celle con data

Postdi libraio » 30/01/21 17:27

Grazie per la risposta, Mario,
putroppo le date non sono uguali e non non ho una data precisa da appoggio.
Semplicemente (si fa per dire...) mi interesserebbe ottenere il conteggio di quante celle della riga selezionata contengono date.
Saluti
libraio
Utente Senior
 
Post: 305
Iscritto il: 04/01/10 20:31

Re: Funzione CONTA.SE celle con data

Postdi Anthony47 » 30/01/21 19:45

Ma almeno sai in quali colonne potrebbero essere queste date?

Comunque prova con questa formula:
Codice: Seleziona tutto
=CONTA.SE(A2:Z2;">42005")-CONTA.SE(A2:Z2;">45658")


Questa "dovrebbe" contare le celle che sono date comprese tra il 2015 e il 2024, che ho immaginato potrebbero essere ragionevoli per il tuo lavoro
Ma la formula sara' fallace se i tuoi dati comprendono numeri compresi tra 42005 e 45658.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17513
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Funzione CONTA.SE celle con data

Postdi libraio » 03/02/21 21:29

Ciao Anthony,
mi scuso subito per il ritardo con cui riscontro la tua tempestiva soluzione.
Ad una prima prova la funzione dà il risultato che cercavo (e non avevo dubbi...)
Porrò attenzione ai tuoi suggerimenti, modificando il codice secondo le esigenze contingenti.
Grazie
libraio
Utente Senior
 
Post: 305
Iscritto il: 04/01/10 20:31


Torna a Applicazioni Office Windows


Topic correlati a "Funzione CONTA.SE celle con data":


Chi c’è in linea

Visitano il forum: Marius44 e 52 ospiti