Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL: cella per controllo valori negativi in una colonna

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL: cella per controllo valori negativi in una colonna

Postdi valle1975 » 09/07/20 16:21

Buongiorno, avrei questa necessità:
ho una tabella con diverse migliaia di righe, vorrei poter controllare tramite una cella in alto (Es. Z1) la presenza di uno o piu' valori negativi in una specifica colonna Es. "Z",e magari poter ottenere anche i numeri di riga dove ci sono valori negativi.
Con la funzione "se", posso controllare la singola cella della colonna, ma non so come poter avere l'esito del controllo di tutte le righe in una sola cella.
Grazie a tutti.
Valerio
---------------------------------
Windows 10 Professional + MS Office 2016 STD Ita
valle1975
Utente Senior
 
Post: 207
Iscritto il: 27/09/10 16:33

Sponsor
 

Re: EXCEL: cella per controllo valori negativi in una colonn

Postdi wallace&gromit » 09/07/20 16:57

Ciao,
questa formula ti dice quanti valori negativi ci sono in colonna Z:
Codice: Seleziona tutto
=CONTA.SE(Z:Z;"<0")

Questa invece ti dice in quale riga si trovano i valori, premesso che nella cella AA1 inserisci un valore progressivo (se scrivi 1 la formula ti darà la riga in cui si trova il primo numero negativo dall'alto, 2 il secondo e così via).
È una formula matriciale, una volta scritta devi confermare con Ctrl + Maiusc + Enter, non solo Enter:
Codice: Seleziona tutto
=PICCOLO(SE(Z:Z<0;RIF.RIGA(Z:Z));AA1)
Office2016 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2015
Iscritto il: 16/01/12 14:21

Re: EXCEL: cella per controllo valori negativi in una colonn

Postdi valle1975 » 10/07/20 09:20

Grazie mille, funziona benissimo.
Valerio
---------------------------------
Windows 10 Professional + MS Office 2016 STD Ita
valle1975
Utente Senior
 
Post: 207
Iscritto il: 27/09/10 16:33


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL: cella per controllo valori negativi in una colonna":


Chi c’è in linea

Visitano il forum: Nessuno e 22 ospiti