Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

date <1/1/1900

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

date <1/1/1900

Postdi marcoc » 24/01/20 09:16

Buongiorno a tutti,
ho la formula:

=SE(DATA.DIFF(A1;OGGI();"y")>0;DATA.DIFF(A1;OGGI();"y") & " Anni ";"") & SE(DATA.DIFF(A1;OGGI();"ym")>0;DATA.DIFF(A1;OGGI
();"ym") & " Mesi ";"") & DATA.DIFF(A1;OGGI();"md") & " Giorni"

che, inserendo in A1 ad esempio 4/9/2011, mi restituisce "8 Anni 4 Mesi 20 Giorni", ovvero il tempo trascorso fino ad oggi 24/1/2020.

Il punto è che in A1 mi serve inserire una data antecedente il 1/1/1900, non riconosciuta dall'excel come data…

é possibile ovviare al problema secondo voi?
Avatar utente
marcoc
Utente Senior
 
Post: 278
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: date <1/1/1900

Postdi Anthony47 » 24/01/20 13:46

La mia proposta e' che scrivi la data come Giorno /Mese /Anno in 3 celle diverse; es A1, B1 e C1.
Poi la tua formula diventerebbe
Codice: Seleziona tutto
=SE(DATA.DIFF(DATA(C1+100;B1;A1);OGGI()+36525;"y")>0;DATA.DIFF(DATA(C1+100;B1;A1);OGGI()+36525;"y") & " Anni ";"")&SE(DATA.DIFF(DATA(C1+100;B1;A1);OGGI();"ym")>0;DATA.DIFF(DATA(C1+100;B1;A1);OGGI()+36525;"ym") & " Mesi ";"") & DATA.DIFF(DATA(C1+100;B1;A1);OGGI()+36525;"md") & " Giorni"


Questo ti consente di arrivare fino al 1-gen-1800

Se hai bisogno di passato piu' remoto, puoi lavorare su quel 100 (anni) e quel 36525 (giorni) e raddoppiarli, o triplicarli; ma la precisione potrebbe risentirne

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17218
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: date <1/1/1900

Postdi marcoc » 25/01/20 01:03

grazie Anthony, ma se anziché a oggi avessi bisogno di mettere un'altra data, ad esempio 1/1/2020 nella cella D1?
Avatar utente
marcoc
Utente Senior
 
Post: 278
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: date <1/1/1900

Postdi Anthony47 » 27/01/20 01:50

Ti bastera' sostituire nella formula OGGI() con D1
Se pensi che anche questa seconda data possa essere inferiore al 1900 allora dovrai scriverla scomposta, gg, mm e aa, ad esempio rispettivamente in A2, B2 e C2, e poi usare, al posto di OGGI()+36525, DATA(C2+100;B2;A2)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17218
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: date <1/1/1900

Postdi marcoc » 27/01/20 22:44

ottimo grazie, ho capito il meccanismo; hai solo omesso un "+36525" dopo il terzo "oggi()"
Avatar utente
marcoc
Utente Senior
 
Post: 278
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "date <1/1/1900":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti