Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Sommare i Sabato e Domeniche su una colonna con varie date

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Sommare i Sabato e Domeniche su una colonna con varie date

Postdi ricky53 » 26/10/16 12:48

Ciao,
ho diverse colonne contenenti delle date la mia esigenza è sapere in ogni colonne quanti sono i sabati e quante le domeniche.

Esempio:
in colonna "A" dalla cella A2 ho diverse date (ordinate in modo crescente)
con delle formule, in due celle distinte, devo ottenere:
in "B2" quanti sono i sabati
in "C2" quante sono le domeniche
presenti nell'intervallo A2:A36.

Per il momento ho risolto con una macro ma il file deve essere senza macro e per questo motivo mi occorrono le formule.

Ho provato con MATR.SOMMA.PRODOTTO, CONTA.SE, ecc. ma non ho trovato come risolvere ed eccomi qui a chiedervi una soluzione al mio quesito.

Grazie a tutti
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4526
Iscritto il: 11/04/09 19:29
Località: Italia

Sponsor
 

Re: Sommare i Sabato e Domeniche su una colonna con varie da

Postdi CANAPONE » 26/10/16 13:11

Ciao Riccardo

se tutte le celle in A2:A36 ospitano una data, puoi contare:

i sabati con

=MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(A2:A36)=7))

le domeniche

=MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(A2:A36)=1))

Se l'intervallo A2:A36 può contenere celle vuote, la prima formula va corretta

=MATR.SOMMA.PRODOTTO((GIORNO.SETTIMANA(A2:A36)=7)*(A2:A36>0))

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 430
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Sommare i Sabato e Domeniche su una colonna con varie da

Postdi ricky53 » 26/10/16 14:38

Ciao Canapone,
avevo utilizzato proprio le due funzioni che mi hai indicato tu ma ... i doppi segni meno !!!!!!

Che CASPITA!!!
Non li avevo messi ed ottenevo sempre zero.


Si, il problema delle celle vuote che vengono viste, dalla funzione "giorno.settimana" come sabato lo conoscevo.


Grazie infinite.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4526
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Sommare i Sabato e Domeniche su una colonna con varie da

Postdi CANAPONE » 27/10/16 10:15

Ciao RIccardo,

grazie del riscontro.

Saluti da Firenze
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 430
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "Sommare i Sabato e Domeniche su una colonna con varie date":


Chi c’è in linea

Visitano il forum: Gattuccio0 e 20 ospiti