Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Alsamixer non funziona più [RISOLTO]

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Alsamixer non funziona più [RISOLTO]

Postdi Kondor » 02/07/09 05:37

Salve a tutti.
Da qualche giorno non riesco più ad accedere al pannello di Alsamixer, dopo averlo lanciato dal terminale.
L'errore è il seguente: "function snd_ctl_open failed for default: No such device". Come posso risolverlo per poter accedere ancora alla console alsamixer tramite terminale?
Grazie in anticipo.
« Nessuno vi può dare la libertà. Nessuno vi può dare l'uguaglianza o la giustizia. Se siete uomini, prendetevele »
Avatar utente
Kondor
Utente Junior
 
Post: 69
Iscritto il: 31/07/07 22:59

Sponsor
 

Re: Alsamixer non funziona più.

Postdi gunter » 02/07/09 09:47

Mi viene in mente di usare:
Codice: Seleziona tutto
sudo alsaconf

Codice: Seleziona tutto
sudo asoundconf set-default-card
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Re: Alsamixer non funziona più.

Postdi Kondor » 02/07/09 21:12

Ho provato a digitare i comandi che mi hai postato, ma non è accaduto niente, mi compare lo stesso errore per quanto riguarda Alsamixer.
Inoltre a seguito del primo comando la password del mio account si è resa visibile nel terminale, come mai? :eeh: :!:
« Nessuno vi può dare la libertà. Nessuno vi può dare l'uguaglianza o la giustizia. Se siete uomini, prendetevele »
Avatar utente
Kondor
Utente Junior
 
Post: 69
Iscritto il: 31/07/07 22:59

Re: Alsamixer non funziona più.

Postdi akela » 06/07/09 17:56

ciao,
hai fatto qualche aggiornamento di recente su alsamixer o alsaconf?

Per quanto riguarda la pass che si vede, temo che il comando che ti ha dato gunter non sia il colpevole di questo smascheramento, ma forse è imputabile ad altro, comunque non è normale.

hai fatto un controllo con l'antivirus e con rkhunter?
akela
Utente Junior
 
Post: 45
Iscritto il: 31/08/08 08:30

Re: Alsamixer non funziona più.

Postdi ivo » 08/07/09 08:56

stai usando un kernel Real Time ????
magari hai aggiornato il sistema e avvii con un kernel non RT ...
Per poterti aiutare di più mi servirebbe sapere quale distrò usi (ubuntu, debian, ecc.)
e quale kernel stai avviando ...
magari controllare se tra i moduli in avvio del tuo kernel c'è anche quello che serve per far girare alsa....
Immagine
Avatar utente
ivo
Utente Senior
 
Post: 1134
Iscritto il: 20/08/01 01:00
Località: Treviso

Re: Alsamixer non funziona più.

Postdi Kondor » 09/07/09 20:54

Utilizzo l'ultima distribuzione Ubuntu 9.04.
« Nessuno vi può dare la libertà. Nessuno vi può dare l'uguaglianza o la giustizia. Se siete uomini, prendetevele »
Avatar utente
Kondor
Utente Junior
 
Post: 69
Iscritto il: 31/07/07 22:59

Re: Alsamixer non funziona più.

Postdi ivo » 10/07/09 07:24

se usi la Ubuntu 9.04 devi vedere su synaptic se hai installato il kernel real time (RT)
installarlo e controllare che all'avvio venga utilizzato quel kernel.
Di solito la ubuntu senza RT non fa parti jack e altri programmi simili ... magari anche alsamixer ????
Immagine
Avatar utente
ivo
Utente Senior
 
Post: 1134
Iscritto il: 20/08/01 01:00
Località: Treviso

Risolto Alsamixer non funziona più.

Postdi Kondor » 12/07/09 14:52

Avevi ragione tu, controllando su Synaptic non avevo installato il kernel real time (RT).Una volta fatto e riavviato il
sistema, l'audio è tornato a funzionare perfettamente.
Grazie mille a te, e a tutti! :D :D
« Nessuno vi può dare la libertà. Nessuno vi può dare l'uguaglianza o la giustizia. Se siete uomini, prendetevele »
Avatar utente
Kondor
Utente Junior
 
Post: 69
Iscritto il: 31/07/07 22:59


Torna a Software Linux


Topic correlati a "Alsamixer non funziona più [RISOLTO]":


Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite