Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

amarok e gtkpod vedono brani ipod ma ipod nada

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 20/03/09 11:56

Non riesco a capire perche' da quando ho provato a salvare nuove canzoni e rimuovere quelle vecchie non mi vede piu' niente il mio ipod,ossia ci sono effettivamente ma se provo ad ascoltarle non mi appare piu' la pplaylist del mio ipod mentre da pc vede che effettivamente i brani ci sono.
Qualcuno di voi conosce un metodo per almeno rivedere i miei brani oppure ridevo formattare l'ipod e copiarle una ad una di nuovo da capo?.
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Sponsor
 

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi gunter » 20/03/09 13:44

Hai impostato in amarok la tipologia dell'ipod prima di fare il trasferimento? Che modello è?
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 20/03/09 14:51

si' e lo riconosce gli ho detto cche e' un ipod e lui vede tutte le canzoni al suo interno ma da quando ho modificato i brani ossia cancelandone un paio da gtkipod l'ipod quando lo provo ad ascoltare senza pc non mi permette di ascoltare piu' i brani perche' e come se non ci fossero piu' ma al suo nterno sono ancora presenti.
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi gunter » 20/03/09 15:12

A me è capitata una cosa simile. La morosa possiede un ipod nano (l'ultima generazione credo sia la 4°) e mi succedeva che lo spazio era effettivamente occupato, ma l'ipod non le vedeva. Le soluzioni che ho trovato al mio problema sono due:
1. Usare Floola
2. Aggiornare libgpod alla versione 0.7.0 (o cvs), in questa maniera ho ottenuto il supporto a questa ultima generazione di dispositivi

p.s.: nel tab dispositivi di amarok, c'è un menu a tendina nella barra dove c'è anche la voce "connetti" per capirci, dove devi selezionare il modello preciso preciso, altrimenti ha questo tipo di comportamento. Scusa se insisto, ma è piuttosto importante.
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi archimede » 20/03/09 16:00

gunter ha scritto:1. Usare Floola
Sei riuscito a installarlo su una distro di Linux a 64bit che non sia Ubuntu?

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi gunter » 20/03/09 17:41

Sì gentoo, mandriva e bluewhite64... Non mi ha dato particolari problemi, bisogna fare un po' di attenzione con java se non ricordo male... Ad ogni modo la soluzione più semplice ed efficiente è sicuramente quella di aggiornare libgpod...
Stai avendo qualche problema?
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi archimede » 20/03/09 18:03

gunter ha scritto:Stai avendo qualche problema?
Codice: Seleziona tutto
[alex@archimedex ~]$ uname -a
Linux archimedex 2.6.27.19-170.2.35.fc10.x86_64 #1 SMP Mon Feb 23 13:00:23 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

[alex@archimedex ~]$ yum list libgpod
Installed Packages
libgpod.x86_64                                                                        0.6.0-9.fc10                                                                         installed
Available Packages
libgpod.i386                                                                          0.6.0-9.fc10                                                                         updates 

[alex@archimedex ~]$ . /home/alex/Floola-linux/Floola
bash: ELF: command not found
Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi gunter » 20/03/09 18:15

non so se è un errore di battitura/copia ma c'è uno spazio dopo il punto nell'ultimo comando che non dovrebbe esserci...

p.s.: per fc10 non riesco a trovare il pacchetto libgpod 0.7.0, mentre è incluso nella 11...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi archimede » 20/03/09 19:27

gunter ha scritto:c'è uno spazio dopo il punto nell'ultimo comando che non dovrebbe esserci...
Mmmh... :-?
Codice: Seleziona tutto
[alex@archimedex ~]$ ./home/alex/Floola-linux/Floola
bash: ./home/alex/Floola-linux/Floola: No such file or directory
Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi gunter » 20/03/09 20:50

A me funziona, il problema è il "punto" ...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 21/03/09 11:36

Andro' subito a provare anche se non sono sicuro del mio modello visto che mi è stato regalato.
E silver ed e' 4gb e l'unica voce che ha queste caratteristiche dovrebbe essere ipod nano 2d gen 4 gb silver(visto che è l'unica voce che sembra corrispondere).Provero' anche ad installare floola ed aggiornare le librerie, pero' ora secondo voi devo formattare tutto oppure si riesce a rivedere l'ipod facendo queste operazioni?.
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi gunter » 21/03/09 11:51

Il modo più semplice per capire di quale modello si tratta. è la forma, questi sono la 4 gen (libgpod 0.7.0 necessaria), questi sono la 3 gen.
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 21/03/09 11:58

Ho provato a riparare con floola il database e' ovviamente non ha funzionato anche se ho notato che appena prova mi butta fuori dal programma e' questo se non ricordo male succedeva anche con gtkipod.
Ora sto provando ad installare le ultime librerie da sorgenti visto che l'rpm non sono riuscito a trovarlo.
Mi dice che gli mancano due file appena finisce configure che spero siano quelli giusti quelli che sto installando.
Mi chiede glib-2.0 e gobject-2.0.
Le uniche voci che ho trovato simili su synaptic sono libpyglib2.0_0(per quanto rigurarda gobject) e per glib-2.0 glib-sharp2(quest ultimo non ne ono molto sicuro).
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 21/03/09 11:59

Pare che li ho azzeccati adesso mi dice che gli manca libxml ma credo di esserci .
Se riesco a farlo funzionare vi aggiornero' il piu' presto possibile.
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 21/03/09 12:07

Un piccolo dubbio appena faccio ./configure make e make install ovviamente se tutto andra' a buon fine mi installera' questa libreria, pero' .... pero'.... se rimuovo la libreira vecchia immagino che mi dira' che ha delle dipendenze e' il nuovo pacchetto compilato dalle sorgenti riuscira' a ripristinare le vecchie dipendenze?.
Ah credo tra le altre cose che non sia andato a buon fine vedro'.....
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 21/03/09 12:13

Di nuovo lo stesso scherzo, appena prova a riparare il database e a riscriverlo il programma crasha e mi butta fuori. :x :x :x :x :x
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 21/03/09 12:30

Nada non c'e' verso riprovo a ricostruire il database ma niente da fare i file musicali i programmi li vedono ma l'ipod non ne vuole sapere.Mi verebbe se non fosse perche' e' un regalo e costa di prenderlo a martellate non e' possibile che facciano le cose belle fighe e poi diventi scemo a farle funzionare non è possibile scusate lo sfogo ma non e' la prima volta che mi ci picchio con questo aggeggio. :cry: :cry:
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi gunter » 21/03/09 13:54

Sono con le spalle al muro...non mi è mai successo quindi non saprei come aiutarti... ;)
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi serdux » 21/03/09 14:15

Io vi ringrazio a tutti per i vostri consigli ma ho dovuto ripristinare con itunes perchè non c'è stato verso di farlo andare, ho provato anche oltre che a ripristinare a copiare i brani con gtkpod e floola ma ninete da fare sembra che digerisca solo itunes.
Peccato avrei preferito usare i tools di linux ma non ne posso fare una colpa visto che immagino che essendo copyright ci siano delle restrizioni e quindi puoi fino ad un certo punto con software copyleft. :( :( :(
serdux
Utente Senior
 
Post: 171
Iscritto il: 23/09/07 06:38

Re: amarok e gtkpod vedono brani ipod ma ipod nada

Postdi archimede » 29/03/09 21:37

gunter ha scritto:A me funziona, il problema è il "punto" ...
Scusa il ritardo.

La sintassi con . seguito da spazio non ricordo dove l'ho vista ma di certo non me la sono inventanta (tant'è vero che senza spazio mi dà proprio errore di sintassi).

A parte questo, se mi metto nella cartella che contiene l'eseguibile questo succede:
Codice: Seleziona tutto
[alex@archimedex Floola-linux]$ ./Floola

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

(Floola:26138): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Cannot find libgstreamer
Cannot find libxine
Segmentation fault
Il programma si apre per due o tre secondi e si richiude senza interazione da parte mia.

A questo punto ho installato la vesione a 32bit di bug-buddy e rilanciando il programma ottengo un bug report che proverò a sottoporre allo sviluppatore (ma non sono molto ottimista).

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Prossimo

Torna a Software Linux


Topic correlati a "amarok e gtkpod vedono brani ipod ma ipod nada":

Ipod Shuffle
Autore: Utente Paolo
Forum: Discussioni
Risposte: 0

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti