Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

webcam

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

webcam

Postdi luigi76 » 12/12/08 14:31

ciao ragazzi, scusate se apro un nuovo topic :oops: , ma ho fatto una ricerca sul sito e non ho trovato nulla.
nel caso spostate il mio messaggio.
comunque io ho una webcam trust 1400T, quando avevo windows non ho avuoto problemi perchè avevo il cd dei driver :P , "guarda caso non lo fanno per linux" :evil: .
volevo sapere che procedura seguire per installarla.
ho ubuntu 8.10.
grazie
luigi76
Utente Junior
 
Post: 80
Iscritto il: 06/11/08 14:24

Sponsor
 

Re: webcam

Postdi ivo » 05/01/09 15:06

beh per prima cosa devi collegare la webcam USB e da console digitare lsusb
ci posti l'output così vediamo se il sistema riconosce la webcam
dopo, se in lsusb trovi la periferica, potresti provare ad installare camorama per testare la webcam e dirci se funziona
poi vedremo il resto ...
Immagine
Avatar utente
ivo
Utente Senior
 
Post: 1134
Iscritto il: 20/08/01 01:00
Località: Treviso

Re: webcam

Postdi luigi76 » 07/01/09 21:32

ciao, ecco l'output al comando che mi hai detto.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 093a:2468 Pixart Imaging, Inc. Cammaestro 2.5DU/X-EYE/Orite SC-120/ICGear TravelCam/Easy Snap Snake Eye WebCam
Bus 001 Device 002: ID 0e8f:1022 GreenAsia Inc.
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
quando apro camoramo mi esce una finestra di errore con scritto "unable capture image." e lla chiusura della finestra di errore si chiude anche camorama.
luigi76
Utente Junior
 
Post: 80
Iscritto il: 06/11/08 14:24

Re: webcam

Postdi ivo » 08/01/09 08:38

penso che il kernel abbia rilevato la webcam
TravelCam/Easy Snap Snake Eye WebCam

ma ti mancano altri pacchetti per la parte grafica
tipo video4linux o altre cose simili
non mi ricordo neanche dove l'ho trovato ma comunque prova così
per installare webcam su linux
provare questi comandi
sudo apt-get update && sudo apt-get install module-assistant && sudo apt-get install ov51x-jpeg
sudo module-assistant a-i ov51x-jpeg
sudo modprobe ov51x-jpeg

e ci fai sapere (non vorrei essere il solo che prova a risolvere questo problema) se hai avuto errori e se qualcosa funziona
Immagine
Avatar utente
ivo
Utente Senior
 
Post: 1134
Iscritto il: 20/08/01 01:00
Località: Treviso

Re: webcam

Postdi luigi76 » 08/01/09 14:42

ciao ecco il risultato dei comandi eseguiti da consol
luigi@luigi-desktop:~$ sudo apt-get update && sudo apt-get install module-assistant && sudo apt-get install ov51x-jpeg
[sudo] password for luigi:
Hit http://security.ubuntu.com intrepid-security Release.gpg
Ign http://security.ubuntu.com intrepid-security/main Translation-it
Ign http://security.ubuntu.com intrepid-security/restricted Translation-it
Hit http://it.archive.ubuntu.com intrepid Release.gpg
Ign http://security.ubuntu.com intrepid-security/universe Translation-it
Ign http://security.ubuntu.com intrepid-security/multiverse Translation-it
Hit http://security.ubuntu.com intrepid-security Release
Hit http://it.archive.ubuntu.com intrepid/main Translation-it
Hit http://security.ubuntu.com intrepid-security/main Packages
Hit http://it.archive.ubuntu.com intrepid/restricted Translation-it
Hit http://security.ubuntu.com intrepid-security/restricted Packages
Hit http://security.ubuntu.com intrepid-security/main Sources
Hit http://security.ubuntu.com intrepid-security/restricted Sources
Hit http://security.ubuntu.com intrepid-security/universe Packages
Hit http://it.archive.ubuntu.com intrepid/universe Translation-it
Hit http://security.ubuntu.com intrepid-security/universe Sources
Hit http://security.ubuntu.com intrepid-security/multiverse Packages
Hit http://security.ubuntu.com intrepid-security/multiverse Sources
Hit http://it.archive.ubuntu.com intrepid/multiverse Translation-it
Hit http://it.archive.ubuntu.com intrepid-updates Release.gpg
Hit http://it.archive.ubuntu.com intrepid-updates/main Translation-it
Hit http://it.archive.ubuntu.com intrepid-updates/restricted Translation-it
Hit http://it.archive.ubuntu.com intrepid-updates/universe Translation-it
Hit http://it.archive.ubuntu.com intrepid-updates/multiverse Translation-it
Hit http://it.archive.ubuntu.com intrepid Release
Hit http://it.archive.ubuntu.com intrepid-updates Release
Hit http://it.archive.ubuntu.com intrepid/main Packages
Hit http://it.archive.ubuntu.com intrepid/restricted Packages
Hit http://it.archive.ubuntu.com intrepid/main Sources
Hit http://it.archive.ubuntu.com intrepid/restricted Sources
Hit http://it.archive.ubuntu.com intrepid/universe Packages
Hit http://it.archive.ubuntu.com intrepid/universe Sources
Hit http://it.archive.ubuntu.com intrepid/multiverse Packages
Hit http://it.archive.ubuntu.com intrepid/multiverse Sources
Hit http://it.archive.ubuntu.com intrepid-updates/main Packages
Hit http://it.archive.ubuntu.com intrepid-updates/restricted Packages
Hit http://it.archive.ubuntu.com intrepid-updates/main Sources
Hit http://it.archive.ubuntu.com intrepid-updates/restricted Sources
Hit http://it.archive.ubuntu.com intrepid-updates/universe Packages
Hit http://it.archive.ubuntu.com intrepid-updates/universe Sources
Hit http://it.archive.ubuntu.com intrepid-updates/multiverse Packages
Hit http://it.archive.ubuntu.com intrepid-updates/multiverse Sources
Lettura della lista dei pacchetti in corso... Fatto
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Lettura informazioni sullo stato... Fatto
module-assistant è già alla versione più recente.
I seguenti pacchetti erano stati automaticamente installati e non sono più richiesti:
python-gnome2 python-gnomecanvas tcl8.5
Usare 'apt-get autoremove' per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare ov51x-jpeg
luigi@luigi-desktop:~$ sudo module-assistant a-i ov51x-jpeg

Updated infos about 1 packages
Getting source for kernel version: 2.6.27-9-generic
Kernel headers available in /usr/src/linux
Creating symlink...
Couldn't create the /usr/src/linux symlink!
apt-get install build-essential
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Lettura informazioni sullo stato... Fatto
build-essential è già alla versione più recente.
I seguenti pacchetti erano stati automaticamente installati e non sono più richiesti:
python-gnome2 python-gnomecanvas tcl8.5
Usare 'apt-get autoremove' per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

Done!
unpack
Extracting the package tarball, /usr/src/ov51x-jpeg.tar.bz2, please wait...
"/usr/share/modass/packages/default.sh" build KVERS=2.6.27-9-generic KSRC=/usr/src/linux-headers-2.6.27-9-generic KDREV=2.6.27-9.19 kdist_image
luigi@luigi-desktop:~$ sudo modprobe ov51x-jpeg
FATAL: Module ov51x_jpeg not found.
luigi@luigi-desktop:~$
il risultato non è cambiato, comunque il pacchetto ov51x-jpeg-source da synaptic risulta installato l'ho anche reinstallato e riprovato ma non cambia niente
luigi76
Utente Junior
 
Post: 80
Iscritto il: 06/11/08 14:24

Re: webcam

Postdi luigi76 » 08/01/09 22:23

non so se può essere utile però ho scoperto che con cheese la webcam funziona, scatta anche foto e salva filmati. :D
mentre con camorama mi da questo errore "unable capture image." :(
mentre con amsn quando la vado a configuare al posto dell'immagine vedo un riguadro nero. :aaah
luigi76
Utente Junior
 
Post: 80
Iscritto il: 06/11/08 14:24

Re: webcam

Postdi ivo » 09/01/09 09:05

CHEESE non lo conosco ma ti assicuro che anche a me la webcam si comporta come da te: niente su amsn e nero su camorama. Pensavo che almeno da te potesse funzionare ...
Proverò a girare il questi, questa sera, sul forum ufficiale di Ubuntu Italia e vediamo cosa ci dicono.
P.D.
Se qualche altra persona ha idee, si faccia avanti!
Immagine
Avatar utente
ivo
Utente Senior
 
Post: 1134
Iscritto il: 20/08/01 01:00
Località: Treviso

Re: webcam

Postdi luigi76 » 18/04/09 14:09

risolto, se così posso dire.
con l'avanzamento alla versione 9.04 la webcam funziona benissimo.
ciao
luigi76
Utente Junior
 
Post: 80
Iscritto il: 06/11/08 14:24


Torna a Software Linux


Topic correlati a "webcam":

Webcam pc
Autore: giovivirgi
Forum: Software Windows
Risposte: 1
Webcam
Autore: makulat
Forum: Software Windows
Risposte: 3

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti