Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

kaffeine non trova le xine-lib

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

kaffeine non trova le xine-lib

Postdi Teto » 20/03/08 16:02

Ho provato a installare kaffeine-0.8.6 sulla mia Slackware 11 (kernel 2.6.17.13), ma quando lancio ./configure, a un certo punto mi dice che non trova le xine-lib.
Ho interpellato kpakage, il quale mi dice che nel mio pc è installato il seguente pacchetto: xine-lib-1.1.5-i686.1sl.
Forse kaffeine-0.8.6 ne richede una versione più aggiornata?
Mistero...
Immagine
Teto
Utente Junior
 
Post: 66
Iscritto il: 18/12/02 17:06

Sponsor
 

Re: kaffeine non trova le xine-lib

Postdi gunter » 21/03/08 09:14

Codice: Seleziona tutto
#!/bin/sh
# Heavily based on the Slackware 12.0 SlackBuild
# http://kaffeine.sourceforge.net/
# Packager Vincenzi Loris - slacky@slacky.it

CWD=`pwd`
TMP=${TMP:-/tmp/tgz}
PKG=$TMP/package
NAME=kaffeine
VERSION=0.8.6
PLUGVERSION=0.2
CHOST=i486
ARCH=${ARCH:-i486}
BUILD=1sl

if [ "$ARCH" = "i386" ]; then
  SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
elif [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2"
elif [ "$ARCH" = "s390" ]; then
  SLKCFLAGS="-O2"
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2"
fi

if [ ! -d $TMP ]; then
 mkdir -p $TMP
fi
if [ ! -d $PKG ]; then
 mkdir -p $PKG
fi

cd $TMP
tar xjvf $CWD/$NAME-$VERSION.tar.bz2
cd $NAME-$VERSION
find . \( -perm 777 -o -perm 775 -o -perm 711 \) -exec chmod 755 {} \;
find . \( -perm 700 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \;
find . \( -perm 666 -o -perm 664 -o -perm 600 \) -exec chmod 644 {} \;
find . \( -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
chown -R root:root .
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure --prefix=/usr \
--without-gstreamer \
--disable-debug  \
--program-prefix= \
--program-suffix= \
--build=$CHOST-slackware-linux
make
make install DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$NAME-$VERSION/plugins
cp -a AUTHORS ChangeLog COPYING INSTALL README TODO $PKG/usr/doc/$NAME-$VERSION
cd $TMP
tar xjvf $CWD/$NAME-mozilla-$PLUGVERSION.tar.bz2
cd $NAME-mozilla-$PLUGVERSION
find . \( -perm 777 -o -perm 775 -o -perm 711 \) -exec chmod 755 {} \;
find . \( -perm 700 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \;
find . \( -perm 666 -o -perm 664 -o -perm 600 \) -exec chmod 644 {} \;
find . \( -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
chown -R root:root .
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure --prefix=/usr/lib/mozilla \
--program-prefix= \
--program-suffix= \
--build=$CHOST-slackware-linux
make
make install DESTDIR=$PKG
cp -a AUTHORS COPYING ChangeLog INSTALL README $PKG/usr/doc/$NAME-$VERSION/plugins
cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/slack-desc > $PKG/usr/doc/$NAME-$VERSION/slack-desc
cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
requiredbuilder -v -y -s $CWD $PKG
makepkg -l y -c n $CWD/$NAME-$VERSION-$ARCH-$BUILD.tgz

if [ "$1" = "--cleanup" ]; then
  rm -rf $TMP
fi

Questo è lo slackbuild della versione 0.8.6 trovato su slacky.eu per slack 12.
Ti basterà sostituire:
Codice: Seleziona tutto
./configure --prefix=/usr \

con:
Codice: Seleziona tutto
./configure --prefix=/opt/kde \

salvare ed eseguirlo.
Ovviamente nella stessa cartella devi mettere i sorgenti, slack-desc, slack-required che comunque puoi trovare sempre su slacky.eu cercando la versione 0.8.6 ... ;)

Ala stessa maniera vale la pena modificare lo slackbuild di xine-lib aggiornado all'ultima versione uscita. ;)
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)


Torna a Software Linux


Topic correlati a "kaffeine non trova le xine-lib":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti