Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Installare A-mule [RISOLTO]

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Installare A-mule [RISOLTO]

Postdi skid » 27/03/07 10:09

Proprio non mi riescde di capire come.
Mi serve una guida passo passo peggio che per un neonato...
Ho scaricato il tar.gz, e scompattato.
Ora la nebbia ed il mistero avvolge il prosequio della faccenda... :D
Per migrare a linux, devo passare attraverso alcune pietre miliari: ed A-mule/E-mule è una di queste!
Poi aprirò un nuovo post per skype...una cosa alla volta, senza fretta! :lol:
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Sponsor
 

Postdi numberinn » 27/03/07 12:59

Knowledge.... THAT IS POWER!!!
Avatar utente
numberinn
Download Admin
 
Post: 435
Iscritto il: 04/03/03 15:28
Località: 127.0.0.1 (aka BS)

Postdi gunter » 27/03/07 13:19

Se hai mandriva(mi sembrava che usassi questa distro) hai provato a controllare nell'elenco di software installabili in centro di controllo? perchè ti conviene usare i pacchetti in formato .rpm già disponibili ti eviti di compilarlo a mano e potrai facilitare un futuro upgrade del pacchetto...

p.s.: forse mandriva non supporta il file sharing perciò qua trovi una lista di rpm per un po' tutte le distribuzioni che ne fanno uso...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi zendune » 27/03/07 18:23

Mandriva supporta bittorrent. Per avere AMule devi inserire nuove fonti .rpm.
Vai su http://easyurpmi.zarb.org/ e segui le istruzioni passo passo. Tra le varie scelte, attiva pure i pacchetti provenienti da PLF; non attivare quelli con l'indicazione _backports.

Una volta aggiornate le fonti, nel Centro di Controllo -> Aggiungi software, cerca amule ed installalo.
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi skid » 27/03/07 18:55

Ho provato a fare il download come suggerito da Gunter.
Non ho traovato versioni per AMD.
Porvando a installarne ina per Intel, il messaggio di errore è:

Some requested packages cannot be installed
amule2.1.3-2plf.2007.0.src (perche non soddisfatto curl-
level)

Qualche idea?
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Postdi gunter » 27/03/07 20:48

Mi dispiace non ho controllato bene l'elenco che ti ho linkato mannaggia, la soluzione di zendune è sicuramente la più correta ed indolore che ti permette di risolvere il problema delle dipendenze (librerie varie) causa del messaggio di errore... ;)
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi zendune » 27/03/07 20:51

Sì, ti manca curl-devel.
RPM installa i pacchetti .rpm SE le dipendenze sono soddisfatte. Nel tuo caso non lo sono; peraltro stai cercando di installare un sorgente che poi va compilato mediante rpm.

Il comando urpmi permette invece di installare il pacchetto richiesto unitamente alle dipendenze necessarie. Fa tutto in automatico.
Se segui le indicazioni che ti ho dato precedentemente, estendi le fonti dei pacchetti, tra cui vi è pure amule. Potrai poi gestire i nuovi pacchetti dal Centro di Controllo.

Se non riuscirai ad aggiungere le nuove fonti, ti passerò i link diretti, ma prima devi provare ;)

Una volta installato amule, il prossimo passaggio sarà configurare il firewall..... ma quella è un'altra storia.
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi skid » 30/03/07 19:13

Ho provato ad aggiornare le fonti: risulatto come sotto:

[root@192 ~]# urpmi.addmedia main ftp://mirrors.usc.edu/pub/linux/distributions/
mandrakelinus/official/2007.0/x86_64/media/main/release with media_info/hdlist.c
z
supporto main aggiunto
scrivi il file di configurazione [/etc/urpmi/urpmi.cfg]
esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.contrib_updates.cz]
recupero il file hdlist (o synthesis) di "main"...
ftp://mirrors.usc.edu/pub/linux/distrib ... al/2007.0/
x86_64/media/main/release/media_info/hdlist.cz

...recupero fallito: curl: (9) Server denied you to change to the given director y
recupero del file hdlist (o synthesis) fallito
non trovo il file hdlist per il supporto "main"
esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.main.cz]
problema nel leggere il file synthesis del supporto "main"
0 intestazioni trovate in cache
sto rimuovendo 0 intestazioni obsolete in cache
scrivi il file di configurazione [/etc/urpmi/urpmi.cfg]
non riesco ad aggiornare il supporto "main"
[root@192 ~]#
[root@192 ~]#

Quest'altor....

[root@192 ~]# urpmi.addmedia --update main_updates ftp://bo.mirror.garr.it/mirrors/Mandrak ... in/updates with media_info/hdlist.cz
supporto main_updates aggiunto
scrivi il file di configurazione [/etc/urpmi/urpmi.cfg]
esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.contrib_updates.cz]
recupero il file hdlist (o synthesis) di "main_updates"...
ftp://bo.mirror.garr.it/mirrors/Mandrak ... /hdlist.cz

...recupero fallito: curl: (9) Server denied you to change to the given directory
recupero del file hdlist (o synthesis) fallito
non trovo il file hdlist per il supporto "main_updates"
esamino il file synthesis [/var/lib/urpmi/synthesis.hdlist.main_updates.cz]
problema nel leggere il file synthesis del supporto "main_updates"
0 intestazioni trovate in cache
sto rimuovendo 0 intestazioni obsolete in cache
scrivi il file di configurazione [/etc/urpmi/urpmi.cfg]
non riesco ad aggiornare il supporto "main_updates"
[root@192 ~]#

Sempre più in quella alta...... ;)
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Postdi gunter » 30/03/07 22:19

Oddio adesso come adesso l'unica cosa che mi viene in mente è non utilizzare le librerie curl ma usare wget...devi solo aggiungere l'opzione --wget e poi il comando è uguale cioè:
Codice: Seleziona tutto
urpmi.addmedia --wget main...

...riporta eventuali errori come hai fatto precedentemente...
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi zendune » 30/03/07 22:27

Prova con questo
Codice: Seleziona tutto
urpmi.addmedia contrib http://ftp.club-internet.fr/pub/unix/linux/Mandrakelinux/official/2007.0/x86_64/media/contrib/release with media_info/hdlist.cz

Naturalmente devi eseguire il comando da root.
Facci sapere se parte...

PS I link non sono attivi, basta inserirli in un normale browser.
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi skid » 21/04/07 22:41

Eccomi di nuovo qui a romperer con A-mule.
Mi sono scaricato il tar.bz dal link del sito di Pc-facile.
Ho estratto l'archivio, e digitato ./configure

Ecco il risultato:
configure: error:
wxWidgets must be installed on your system but wx-config
script couldn't be found. Please check that wx-config is
in path or specified by --with-wx-config=path flag, the
directory where wxWidgets libraries are installed (returned
by 'wx-config --libs' command) is in LD_LIBRARY_PATH or
equivalent variable and wxWidgets version is 2.6.0 or above.


Dove lo vedo se wxWidgets è già installato?

Confermo cmq che nei pacchetti dal centro di controllo Mandriva non ho A-mule, anche dopo aver impostato le fonti RPM (ho usato un mirror di Bologna).

Come mi devo muovere? :aaah
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Postdi gunter » 22/04/07 08:54

Per vedere il software installato devi andare in centro di controllo di mandriva e dovresti trovare la voce che fa al caso tuo. Comunque sono ritornato su easyurpmi e ho notato che i mirror sono ritornati attivi. credo che amule sia nei PLF.
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi skid » 22/04/07 21:57

Ok ragazzi.
Sono finalmente riuscito ad aggiornare le fonti come suggeritomi.
Adesso mi trovo Amule, ho installato i pacchetti richiesti e sono riuscito a connettermi.

Mi devo sbattere un pò con l'interfaccia grafica diversa.

Volevo capire anche come lavorare in Kad. E-mule faceva la connessione in automatico con i pallin i che cambiavano colore a seconda dello stato dei nodi a cui ero connesso.

Amule mi chiede un indirizzo dal quale eseguire il bootstrap della rete kad. Ho porvato ad aggiornare i nodi scaricando il file .nod, ma non succede nulla.

Avete qualche suggerimento? Apro un altro 3d?

Cmq comincia a girare Linuz....le pietre miliari sono a posto! Mi manca solo di far funzionare CITRIX poi sono a cavallo!
skid
Utente Senior
 
Post: 178
Iscritto il: 23/09/02 08:16

Postdi gunter » 23/04/07 21:34

Per Amule se vuoi apri un topic nella sezione P2P visto che è multipiattaforma e che la tua domanda va oltre il collegamento con il sistema operativo... ;)
Avatar utente
gunter
Moderatore
 
Post: 3629
Iscritto il: 07/06/06 18:28
Località: Rovereto (tn)

Postdi JoeyKramer » 29/04/07 09:06

Ciao!

Io sono l'ennesimo zuccone di Linux ma vediamo se ho capito:

io ho seguito le tue istruzioni per configurare easyurpmi, avevo già seguito la procedura ma senza i PLF :-)

poi basta fare da root:

urpmi amule

giusto?
JoeyKramer
Newbie
 
Post: 1
Iscritto il: 29/04/07 08:59

Postdi zendune » 29/04/07 17:09

sì, esatto.

PS La prossima volta, apri pure un nuovo topic in quanto questo è marcato come [RISOLTO] e rischi che nessuno lo segua ;)
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia


Torna a Software Linux


Topic correlati a "Installare A-mule [RISOLTO]":


Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite