Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Slack] Scheda audio non va'

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

[Slack] Scheda audio non va'

Postdi Shinobi » 15/10/05 19:27

Un saluta a tutti quanti.
Da poco ho installato la slackware, ho settato le cose base, ho messo i driver nvidia... però non riesco proprio a far funzionare la scheda audio integrata :-( Oltre a questa scheda audio ho anche una sound blaster 128 che uso su win solo perché ha la porta videogiochi :-P

Ho scaricato ed installato i driver ALSA seguendo questa guida http://www.alsa-project.org/alsa-doc/do ... e=intel8x0

Il risultato non cambia purtroppo :-( Riesco a sentire solamente il mio microfono quando abilito l'audio di quest'ultimo.

Ringrazio tutti quelli che mi possono dare una mano
Shinobi - The Shadow

Sito: http://www.dragonlegacy.net
Shinobi
Utente Junior
 
Post: 23
Iscritto il: 15/10/01 01:00
Località: Roma

Sponsor
 

Postdi zendune » 15/10/05 20:29

Ma il comando lspci che da ?
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi Shinobi » 16/10/05 11:35

Codice: Seleziona tutto
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 735 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
00:0b.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
00:0b.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 61)
00:0b.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 63)
00:0f.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)
00:11.0 Ethernet controller: MYSON Technology Inc SURECOM EP-320X-S 100/10M Ethernet PCI Adapter
00:13.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:13.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:13.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
01:00.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3 Ti 200] (rev a3)
Shinobi - The Shadow

Sito: http://www.dragonlegacy.net
Shinobi
Utente Junior
 
Post: 23
Iscritto il: 15/10/01 01:00
Località: Roma

Postdi zendune » 17/10/05 08:00

Codice: Seleziona tutto
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
.....
00:0f.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)

Io disattiverei l'audio integrato da BIOS in modo da eliminare conflitti e proverei il sistema.
Se necessiti di riconfigurare la scheda audio ed hai installato corrattamente ALSA, il demone dovrebbe essere attivo. Quindi con il comando service alsa stop lo fermi e con alsaconf configuri la scheda. Poi riattivi il demone con service alsa start.
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi Shinobi » 17/10/05 11:27

Il fatto è che io uso la scheda integrata, la soundblaster la uso in win solo per la porta videogiochi...
Ho fatto partire xmms e selezionando libalsa.so (mi pare sia questa) gli mp3 si sentono... penso il problema sia che non riesco a mettere la scheda audio integrata come predefinita. Ho già usato alsaconf ed l'ho impostata però evidentemente non funziona... cmq proverò con service alsa stop per vedere se cambia qualcosa.[/b]
Shinobi - The Shadow

Sito: http://www.dragonlegacy.net
Shinobi
Utente Junior
 
Post: 23
Iscritto il: 15/10/01 01:00
Località: Roma

Postdi Shinobi » 17/10/05 11:57

Ho scritto service alsa stop e mi dice -bash: service: command not found

perché?
Shinobi - The Shadow

Sito: http://www.dragonlegacy.net
Shinobi
Utente Junior
 
Post: 23
Iscritto il: 15/10/01 01:00
Località: Roma

Postdi Shinobi » 17/10/05 13:29

Girando su internet ho trovato questa guida http://opensrc.org/index.php?page=MultipleCards , ma non essendo esperto di linux sinceramente non so cosa fare. qualcuno può aiutarmi?
Shinobi - The Shadow

Sito: http://www.dragonlegacy.net
Shinobi
Utente Junior
 
Post: 23
Iscritto il: 15/10/01 01:00
Località: Roma

Postdi Shinobi » 19/10/05 12:31

Mi sono aiutato da solo è ho modificato /etc/modules.conf

Codice: Seleziona tutto
#SHINOBI SCRIPT
#ALSA portion
alias char-major-116 snd
options snd snd_major=116 snd_cards_limit=2

options snd-ens1371 snd_index=0 snd_id="SBPCI128"
options snd-intel8x0 snd_index=1 snd_in="integrata"

alias snd-card-0 snd-ens1371
alias snd-card-1 snd-intel8x0


#OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# OSS/Free portion- card #2
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss


Purtroppo però continuo a non sentire nulla a parte il microfono... continuerò a fare ricerche su internet e vi terrò informati della situazione.
Se qualcuno sa aiutarmi si faccia avanti :D
Shinobi - The Shadow

Sito: http://www.dragonlegacy.net
Shinobi
Utente Junior
 
Post: 23
Iscritto il: 15/10/01 01:00
Località: Roma

Postdi Dylan666 » 19/10/05 13:13

[OT] Shinobi lo sai che la mail come firma è la gioia degli spammers? [/OT]
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46


Torna a Software Linux


Topic correlati a "[Slack] Scheda audio non va'":

audio audacity su linux
Autore: beppino
Forum: Software Linux
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti