Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cd audio non vengono letti

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Cd audio non vengono letti

Postdi segugiofan » 11/04/05 16:13

Ciao. La mia distribuzione è mandrake 10.1 official, kernel 2.6.8.1 e ho un problema con i CD audio. Infatti, quando li inserisco nel lettore Samsung oppure nel masterizzatore LG non si avviano automaticamente e non li posso ascoltare. Ho provato anche ad avviare kaffeine e ad entare nella directory /mnt/cdrom, /mnt/cdrom2 ma non riesco ad ascoltare nulla. I video CD invece funzionano regolarmente e riesco a sentire anche l'audio. Giorni fa, ho installato nuovamente guarddog ed alla fine della procedura d'installazione è apparso il seguente messagio d'errore:
Sound server informational message
Error while initializing the sound driver, device /dev/dsp can't opened (Device or resource busy)
The sound server will continue using the null output device

Non so se sia da collegare al problema che vi ho descritto prima. Ho persino formattato, ma di sentire i CD audio non se ne parla proprio. Mi date un consiglio sul da farsi?
segugiofan
Utente Senior
 
Post: 925
Iscritto il: 05/08/03 19:53

Sponsor
 

Postdi kidrock » 11/04/05 19:16

se usi kde dovresti avere l'applicazine ksCD che serve per leggere i CD audio dato che come mi ha detto zeundane tempo fa linux non monta i cd audio. Se non hai ksCD o un programma per leggere CD audio installa ksCd che trovi nei cd della rivista. SE tutto funzione ok altrimenti c'è davvero un problema ma le mie conoscenze si fermano qui :neutral:
kidrock
Utente Senior
 
Post: 164
Iscritto il: 14/01/05 19:43

Postdi segugiofan » 11/04/05 19:58

Ho controllato ed il programma è installato, infatti il CD si è avviato tramite la finestra principale di KsCD però purtroppo non c'è audio, l'ho regolato con Kmix ma niente da fare. In configura il tuo desktop c'è la scheda audio con due test:
Prova suono
Prova midi
Il primo l'ho superato il secondo invece no.
Kmix ha anche una finestra per le informazioni sull'hardware supportato che è OK. :undecided: :undecided:
segugiofan
Utente Senior
 
Post: 925
Iscritto il: 05/08/03 19:53

Postdi zendune » 12/04/05 12:53

1 - Prima è necessario capire se il sistema audio funziona: se esegui un mp3 va ?
2 - Se hai due sistemi audio (integrato + scheda PCI) devi attivarne uno solo (meglio il dedicato come scheda PCI).
3 - Kmix devi attivare TUTTE le voci e metterle quasi al massimo.
Poi vediamo.


PS Anche nel mio caso non funzionavano solo i CD audio. Premesso quanto detto da kidrock (i cd audio NON si montano), ho modificato i valori impostati in fstab da Mandrake. Ora sento tutto ;)
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi segugiofan » 12/04/05 16:09

zendune ha scritto:1 - Prima è necessario capire se il sistema audio funziona: se esegui un mp3 va ?

Si. Gli mp3 vengono eseguiti tramite il pacchetto amarok senza nessun problema d'audio od altro.

zendune ha scritto:2 - Se hai due sistemi audio (integrato + scheda PCI) devi attivarne uno solo (meglio il dedicato come scheda PCI).

La mia scheda audio è integrata alla scheda madre il cui modello è DFICS65-EC.

zendune ha scritto:3 - Kmix devi attivare TUTTE le voci e metterle quasi al massimo.
Poi vediamo.

Ho impostato KMix come mi hai suggerito, ma continuo a non sentire l'audio quando lancio i CD musicali tramite KScd. Veramente, la prima volta che provai ad ascoltare un CD audio dopo aver installato mandrake, questo si avviò in automatico. Adesso addirittura non li sento...mahhh

zendune ha scritto:PS Anche nel mio caso non funzionavano solo i CD audio. Premesso quanto detto da kidrock (i cd audio NON si montano), ho modificato i valori impostati in fstab da Mandrake. Ora sento tutto ;)

Se fosse anche il mio caso, spiegami la procedura :D
segugiofan
Utente Senior
 
Post: 925
Iscritto il: 05/08/03 19:53

Postdi zendune » 12/04/05 17:13

a - da KDE ho disattivato tutte le funzioni automatiche (che avviano cd audio, DVD, ecc...)
b - da fstab sostituisci le strighe riferite ai lettori cd semplificando il tutto:
/dev/hdc /mnt/cdrom auto noauto,noexec,users,ro 0 0 (per lettore CD-DVD su ide1 master)
/dev/hdd /mnt/cdrom2 auto noauto,noexec,users 0 0 (per masterizzatore su ide1 slave).
Riavvia quindi il sistema (così risolve collegamenti con altri file es.mtab).
Fatto questo, a me fuziona tutto (per la musica io preferisco xmms).
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi segugiofan » 12/04/05 17:26

zendune ha scritto:a - da KDE ho disattivato tutte le funzioni automatiche (che avviano cd audio, DVD, ecc...)
b - da fstab sostituisci le strighe riferite ai lettori cd semplificando il tutto:
/dev/hdc /mnt/cdrom auto noauto,noexec,users,ro 0 0 (per lettore CD-DVD su ide1 master)
/dev/hdd /mnt/cdrom2 auto noauto,noexec,users 0 0 (per masterizzatore su ide1 slave).
Riavvia quindi il sistema (così risolve collegamenti con altri file es.mtab).
Fatto questo, a me fuziona tutto (per la musica io preferisco xmms).


Nel mio pc il lettore è slave sull'IDE2 mentre il masterizzatore è master sempre sull'IDE2. Cambia qualcosa per la configurazione di fstab?
segugiofan
Utente Senior
 
Post: 925
Iscritto il: 05/08/03 19:53

Postdi zendune » 12/04/05 23:16

/dev/hdc /mnt/cdrom auto noauto,noexec,users 0 0
/dev/hdd /mnt/cdrom2 auto noauto,noexec,users,ro 0 0
cambia solo "ro" (io considero IDE0 e IDE1).
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi segugiofan » 13/04/05 10:46

Zendune, ho fatto tutte le modifiche ed è partito in automatico KScd quando ho inserito il CD audio nel lettore e sono riuscito ad ascoltare la musica. Per il masterizzatore invece è accaduto diversamente, infatti una volta inserito il CD, si è avviato in automatico KScd, però nella finestra del programma, al posto del brano musicale da riprodurre ho trovato scritto nessun disco. :undecided: :undecided:
segugiofan
Utente Senior
 
Post: 925
Iscritto il: 05/08/03 19:53

Postdi segugiofan » 13/04/05 16:56

zendune ha scritto:a - da KDE ho disattivato tutte le funzioni automatiche (che avviano cd audio, DVD, ecc...)


Zendune, mi puoi dire quali sono queste opzioni che hai disabilitato? Io ne ho trovata solo una, in configura il tuo desktop, scheda CD audio, determina il dispositivo automaticamente.
segugiofan
Utente Senior
 
Post: 925
Iscritto il: 05/08/03 19:53

Postdi zendune » 13/04/05 20:19

Sistema > Configurazione > Hardware > Proprietà del CD : ho disabilità tutto, non mi piacciono le automazioni tipiche di win.
Non exercitus neque thesauri praesidia regni sunt, verum amici, quos neque armis cogere neque auro parare queas: officio et fide pariuntur
Avatar utente
zendune
Moderatore
 
Post: 1633
Iscritto il: 15/03/03 18:34
Località: Brescia

Postdi segugiofan » 13/04/05 22:16

Allora è tutto apposto, ho risolto :) Per poter ascoltare i CD audio con il masterizzatore tramite ksCD sono entrato in configura ksCD ed a "dispositivo CD-rom" ho inserito /dev/hdc/. Se invece voglio ascoltare i CD audio con il lettore devo inserire /dev/hdd.
Grazie :)
segugiofan
Utente Senior
 
Post: 925
Iscritto il: 05/08/03 19:53


Torna a Software Linux


Topic correlati a "Cd audio non vengono letti":

audio audacity su linux
Autore: beppino
Forum: Software Linux
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti