Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

probemi mplayer

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

probemi mplayer

Postdi neoweb » 03/11/03 15:05

Salve a tutti;
ho installato il mplayer ma quando lo eseguo si blocca in questo modo:

[root@neo-redhat root]# MPlayer 1.0pre2-3.2.2 (C) 2000-2003 MPlayer Team

CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino 1385 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compilato per CPU x86 con estensioni: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Disabling DPMS
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No
such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Utilizzo la versione interna predefinita di codecs.conf
font: can't open file: /root/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Sto utilizzando la temporizzazione hardware RTC di Linux (1024Hz)
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin non trovata ( default ).

come posso risolvere il problema??
neoweb
Utente Junior
 
Post: 60
Iscritto il: 26/09/01 01:00

Sponsor
 

Postdi Jonesy » 04/11/03 00:14

Hai scaricato tutti i pacchetti?
Magari ti manca il pacchetto mplayer-skin...
Senza la gui funziona? L'hai compilato tu o hai installato un rpm?
Jonesy
Utente Senior
 
Post: 160
Iscritto il: 17/09/02 01:17

ho seguito le istruzioni....

Postdi neoweb » 04/11/03 03:49

Certo che ho fatto tutto... queste sono le istruzioni che ho seguito...

SONO Corette??

Uno dei problemi che più comunemente l’utente che approda al fantastico mondo di Linux si pone è la presenza o meno di programmi che posanno sostituire egregiamente quelli che usava sotto Windows.
Sicuramente tra essi non fanno eccezione i programmi cosiddetti “multimediali”, che permettano di fruire nel modo migliore di contenuti audio o video.
Se per quanto riguarda l’ascolto della nostra collezione musicale esiste ormai da molto tempo XMMS, solo in tempo recente si sono affacciati dei programmi per la riproduzione di filmati.
In principio vi era xanim, un programma X, molto spartano anche se poco potente e avifile, un programma pensato per potere utilizzare i codec binari disponibili per windows, in modo da leggere filmati AVI, MPEG, ASF e persino DivX.
Il primo passo l’ha fatto KDE, con noatun, player molto gradevole ma dalle funzionalità limitate, e la consacrazione l’ha data Xine, player però orientato solo al mondo DVD che, per essere compatibile con gli altri formati necessita di determinati plugins.
E infine c’è Mplayer… il vero protagonista nel campo della riproduzione video sotto Linux.
E’ tutt’oggi il player più diffuso, anche grazie alle sue innumerveoli funzionalità ed opzioni, ed al supporto nativo praticamente per qualsiasi formato video, eccetto Real Player e Quick Time.
Purtroppo questo programma non è incluso in nessuna distribuzione per via della licenza: nonostante Mplayer in sé sia open source (nonostante fino a poco tempo fa non lo fosse), i codecs video necessari alla riproduzione sono proprietari.
Se la montagna non va da Maometto, Maometto va alla montagna… e così ora vedremo come installare Mplayer e come gustarci finalmente i nostri filmati senza dovere ogni volta riavviare il PC per leggerli su windows!! La prima cosa da fare è, ovviamente, recarci sul sito http://www.mplayerhq.hu/ , entrare nella sezione download e scaricare i file sorgenti di Mplayer.
E’ opportuno non scaricare i file RPM dato che essi non implementano l’interfaccia grafica che noi, utenti desktop, invece desideriamo!!!
Una volta scaricato il pacchetto dei sorgenti rechiamoci nella cartella dove è salvato il file e diamo da shell il comando:

tar xfvj Mplayer....tar.bz2

questo creerà una directory, noi rechiamoci in essa.

cd Mplayer.../

A questo punto è sufficiente eseguire i comandi:

./configure –enable-gui
make
make install

Ora, se tutto è stato eseguito nella maniera corretta, Mplayer dovrebbe essere installato… ora dobbiamo però scaricare il pacchetto “win32 codecs”: ci troveremo di fronte un file dal nome w32codecs….tar.bz2, decomprimiamolo da shell con il comando:

tar xfvj w32codec...tar.bz2

A questo punto dovremo diventare root con il comando:

su

Quindi copiamo i codecs nella cartella /usr/lib/win32

mv w32codecs-x.xx /usr/lib/win32

Ora è necessario installare i caratteri, scarichiamo, sempre dal sito di MPlayer i fonts ISO 8859-1 e scompattiamoli con:

unzip mp-arial-iso-8859-1.zip

Dopodichè entriamo nella directory creatasi e troveremo delle sottodirectory con il nome “arial” suguito dalla dimensione del carattere… a meno di avere il monitor a 10 metri di distanza vi consiglio di optare per quelli a grandezza 14, che verranno inseriti in MPlayer dando da shell:

cd iso8859-1
cd arial-14 (oppure 16, 20 a seconda della preferenza)
cp * /usr/local/share/mplayer/fonts/

Ed ora che i fonts sono installati passiamo allo skin!
Come sapate gli skin non sono altro che una determinata “pelle” che si può apporre ai programmi per cambiarne l’aspetto.
E’ necessario, per usufruire della GUI, scaricarne almeno uno… io ho scelto quello di default, non amo molto gli effetti speciali… voi scegliete pure quello che vi si addice di più (mi raccomando, non scegliete il look di Windows Media Player!!!).
Una volta scaricato lo skin, decomprimiamolo e spostiamone il contenuto nella cartella /usr/local/share/mplayer/Skin/ in questo modo:

tar xfvj skin.tar.bz2
cd skin
cp * /usr/local/share/mplayer/Skin

Perfetto!!! Ora tutto è pronto, per azionare Mplayer scriviamo da shell:

gmplayer &
oppure
mplayer --gui &

A questo punto clicchiamo con il tasto destro, scegliamo “Preferenze” dal menu, e nelle preferenze riguardanti il video scegliamo il driver video adatto alla nostra scheda video, generalmente xv dovrebbe andare bene, se usiamo schede Matrox è opportuno invece usare xvidix.
Ed ora… tutto è pronto!!!
Grazie a MPlayer ora potremo gustarci la visione dei nostri DVD, VCD e dei file video presenti sul nostro PC (avi, divx, mpeg ecc.).
Buio in sala e … buona visione!"
neoweb
Utente Junior
 
Post: 60
Iscritto il: 26/09/01 01:00

Re: probemi mplayer

Postdi berto81 » 04/11/03 11:25

neoweb ha scritto:file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin non trovata ( default ).


hai compilato mplayer con la gui abilitata. quindi lui si aspetta di trovare una skin. scaricatene una dal sito di mplayer e mettila nella dir scritta sopra (con permessi di lettura per tutti gli utenti).

p.s.: puoi comunque usare mplayer specificando da riga di comando il file da aprire, es:
$ mplayer /home/pippo/video.avi
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47

tutto ancora negativo...

Postdi neoweb » 04/11/03 12:02

le istruzioni scritte sopra le ho seguite sino in fondo, quindi lo skin c'è l'ho già installato, ed i permessi in lettura sono abilitati a tutti gli utenti, ma il problema persiste.
Come posso risolverlo?? HELP ME!!!!

Grazie.
neoweb
Utente Junior
 
Post: 60
Iscritto il: 26/09/01 01:00

Re: tutto ancora negativo...

Postdi berto81 » 04/11/03 16:33

prova ad editare il file $TUA_HOME/.mplayer/config e metterci queste righe:

gui=yes
skin=default

tanto per essere sicuri che i permessi siano a posto... non funziona nemmeno da root?
se dovesse andare da root: controlla che tutti i files /usr/local/mplayer/Skin/default abbiano permessi +r per tutti, e che tutte le cartelle del percorso abbiano +rw per tutti.

oh, ovvio che /usr/local/share/mplayer/Skin/default/skin esiste vero?!
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47

nulla ancora...

Postdi neoweb » 05/11/03 22:13

Grazie per il contribbuto che mi hai dato, ma non ho risolto nulla.
Ti chiedo solo un ultima cosa...
come disinstallare il mplyer??

Grazie ancora!
neoweb
Utente Junior
 
Post: 60
Iscritto il: 26/09/01 01:00

Re: nulla ancora...

Postdi berto81 » 06/11/03 15:30

ti arrendi già? :roll:
hai provato come root?
cosa ti dice
$ ls -l /usr/local/share/mplayer/Skin/default/skin
???

cmq per disinstallare fai, dalla cartella dei sorgenti, come root:

$ make uninstall
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47


Torna a Software Linux


Topic correlati a "probemi mplayer":

probemi bios
Autore: enzoap
Forum: Assistenza Hardware
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti