Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Inesperto e quasi allo stremo

Per tutti i tuoi problemi Linux entra qui e risolvili!

Moderatori: gunter, zendune

Inesperto e quasi allo stremo

Postdi sephiroth » 06/10/03 23:38

Salve a tutti, esperti e non di linux.

Ho installato da poco meno la mia prima distribuzione di linux (red-hat 8.0) e dopo averci perso le notti per condividere la partizione ntfs di winsuks installare dcgui (che fatica immane) mi rimane solo un passo verso il mio grade trionfo....ma so già che non ci riusciro maaaaaai.
Devo configurare la mia SoundMAX integrata ma linux me la rivela come vt8233 etc etc ed infatti non mi da nemmeno il minimo segnale di vita... aiutoooooooooooo, perchè la asus da azienda seria non fornisce driver per linux per i prodotti integrati con le sue motherboard??
Tra l'altro ho letto miliardi di post in inglese, tedesco , cecoslovacco... senza arrivare ad una soluzione... :undecided:
sephiroth
Newbie
 
Post: 7
Iscritto il: 06/10/03 23:17

Sponsor
 

Postdi rayden » 07/10/03 12:54

bè, se non danno i driver per linux è solo per interessi commerciali, cmq ricompilando il kernel hai provato a vedere se nella lista dei driver c'è anche quello per la tua scheda?
Le uniche limitazioni che abbiamo sono quelle che ci poniamo da soli...
http://www.lightingandservices.com
http://www.lightingandservices.com/phoenix
rayden
Utente Senior
 
Post: 881
Iscritto il: 07/08/01 01:00

Postdi sephiroth » 07/10/03 17:56

premesso che essendo un emerito ebete su linux non ho mai ricompilato il kernel, cmq se me l'ha riconosciuta forse c'è un modo per farla funzionare con quei file, in fondo me la riconosce come una scheda con tecnologia VIA che è giusto... cmq ho sentito parlare di alsa... che cos'è?
sephiroth
Newbie
 
Post: 7
Iscritto il: 06/10/03 23:17

Postdi rayden » 07/10/03 18:45

il problema è questo se nel kernel non sono compilati i moduli adatti hai voglia di sbattere la testa, non te la riconoscerà mai.

allora come prima cosa vai su kernel.org e scaricati il kernel 2.4.20 in quanto io ho avuto problemi a ricompilare il kernel distribuito con red hat.

dopo il download lo decomprimi nella directory /usr/src/
dopodichè vai alla dir che hai appena creato con la decopmressione e dai i seguenti comandi:

make menuconfig <-- quì ti selezioni tutti i driver da caricare necessari al tuo comp compresi il set di istruzioni necessario al tuo microprocessore;

make dep
make modules
make modules_install
make bzImage

dopodichè alla fine dell'ultima istruzione ti dirà dove ha messo il file bzImage, tu vai su quella dir e dai il comando

cp bzImage /boot/bzImage

dopodichè vai in /etc/lilo.conf lo modifichi a dovere per poter fare andare anche il nuoco kernel, e vai col tango...

8)
Le uniche limitazioni che abbiamo sono quelle che ci poniamo da soli...
http://www.lightingandservices.com
http://www.lightingandservices.com/phoenix
rayden
Utente Senior
 
Post: 881
Iscritto il: 07/08/01 01:00

Postdi berto81 » 07/10/03 19:50

non può essere il volume che è basso? se la scheda viene riconosciuta e il modulo caricato senza errori...
per sicurezza potresti controllare i volumi con un programma di mixer (niente di meglio che alsamixer, fa parte del pacchetto alsa-utils).

mi sembra stano che la redhat non fornisca già il modulo adatto compilato...
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47

Postdi sephiroth » 07/10/03 21:03

allora il mixer che uso (quello già installato con la red-hat) mi dice che il volume è al massimo... cmq precisione la mia scheda audio è una soundMax ad1980 ac '97 integrata in una asus av8x-x...
sephiroth
Newbie
 
Post: 7
Iscritto il: 06/10/03 23:17

Postdi sephiroth » 07/10/03 21:06

ricompilando il kernel che cosa dovrei selezionare?? c'è la ad1840 o qualcosa del genere ma non funge e mi da problemi sui moduli... mentre quella che era selezionata prima non dava questi problemi---- cmq grazie a tutti per il velocissio aiuto :D
sephiroth
Newbie
 
Post: 7
Iscritto il: 06/10/03 23:17

Postdi berto81 » 07/10/03 21:25

scusa, a proposito del mixer ho dimenticato di dire che occorre smanettare non solo con il volume principale, ma anche con gli altri. per questo consigliavo alsamixer, che li mostra tutti, a differenza di altri tipo kmixer.
per il kernel, passo...
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47

Postdi berto81 » 07/10/03 21:31

se proprio non dovesse andare...
http://www.linuxquestions.org/questions/history/81404
ma hai proprio una scheda sfigata!
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47

Postdi sephiroth » 07/10/03 22:00

sono sempre più convinto che il problema sia il mixer però alsamixer non mi parte mi dice alsamixer: function snd_ctl_open failed for default: No such device quindi cmq mi devo installare gli alsa driver??
sephiroth
Newbie
 
Post: 7
Iscritto il: 06/10/03 23:17

Postdi berto81 » 07/10/03 22:47

probabilmente non esiste il device mixer (/dev/mixer). e questo è strano, se i tool della redhat te l'hanno configurata e hanno caricato il modulo senza errori.

prova a riconfigurare la scheda, prima lasciandolgli usare il riconoscimento automatico, e poi, se non andasse, scegliendo a mano un modulo (magari quello consigliato nel forum linkato sopra). dopo ogni volta controlla alsamixer.

i driver alsa dovrebbero esserci già nella rh8.. magari non proprio l'ultima versione... ma se non trovi la tua scheda nell'elenco delle supportate non so quanto sia utile installarsi gli ultimi.
$> man woman
Segmentation fault (core dumped)
berto81
Utente Senior
 
Post: 150
Iscritto il: 24/05/02 21:47

Postdi rayden » 08/10/03 11:05

sephiroth ha scritto:ricompilando il kernel che cosa dovrei selezionare?? c'è la ad1840 o qualcosa del genere ma non funge e mi da problemi sui moduli... mentre quella che era selezionata prima non dava questi problemi---- cmq grazie a tutti per il velocissio aiuto :D


bè il vecchio kernel distribuito con la red hat 8.0 da problemi prima di ricompilare hai scaricato il kernel nuovo?
Le uniche limitazioni che abbiamo sono quelle che ci poniamo da soli...
http://www.lightingandservices.com
http://www.lightingandservices.com/phoenix
rayden
Utente Senior
 
Post: 881
Iscritto il: 07/08/01 01:00

Postdi sephiroth » 08/10/03 19:01

ok mi sono messo un nuovo kernel e lo sto ricompilando... spero vada tutto bene :oops:
sephiroth
Newbie
 
Post: 7
Iscritto il: 06/10/03 23:17

Postdi sephiroth » 09/10/03 00:32

Wow, ci sono riuscito quasi non ci speravo più... cmq mi sa che la red-hat 8.0 almeno la versione che avevo io non aveva già installato i driver alsa perchè li ho dovuti reinstallare poi con alsamixer ho risolto il problema togliendo tutti i mute... :) grazie a tutti anche se credo che diventerò un assiduo frequentatore di questo forum :P
sephiroth
Newbie
 
Post: 7
Iscritto il: 06/10/03 23:17


Torna a Software Linux


Topic correlati a "Inesperto e quasi allo stremo":


Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti