Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Funzione di Compilazione Se

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Funzione di Compilazione Se

Postdi iki » 13/09/13 14:06

Buongiorno,
mi ripresento a distanza di un annetto ! XD
volevo chiedere una funzione che, sicuramente sarà banale, ma da un paio di ore ci smanetto ed il mio cervello fuso non riesce a venirne a capo...
sarà che sono un paio di anni che non smanetto su excel...

comunuqe senza tediare.
mi servirebbe una funzione che riconosca un numero e lo inserisca nella casella giusta.

(scusate, ma non riesco a caricare il file, magari con più calma martedì ci riprovo)

provo a spiegarmi.
ho una serie di colonne, dove nella prima c'è il nome dell'ospite e in seguito una serie di colonne numerate che indicano ciascuna una tipologia di pietanza diversa. per non ricercare in ogni colonna quanto ordinato vorrei avere una formula che vada a riconoscere in una colonna diversa il numero scritto e quindi posizioni il numero nella colonna giusta ad esempio
...nome......piet 1...piet 2....piet 99....scelta dell'ospite
pinco pallini........................................3

avendo scelto il pasto numero 3 vorrei che in automatico sotto la colonna della colonna 3 appaia il numero3 e sotto le altre nulla.
ho provato con il semplice Se, ma non riesco a formularla

scusate, proverò ad imparare a caricare un file :(
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Sponsor
 

Re: Funzione di Compilazione Se

Postdi Anthony47 » 13/09/13 23:57

Se Nome e' in colonna A e le altre indicazioni cominciano da colonna B, e la "Scelta ospite" e' in colonna H, allora metti in B2 la formula
Codice: Seleziona tutto
=SE(RIF.COLONNA()-1=$H2;$H2;"")

Copia poi B2 in C2:G2, e poi l' intera prima riga di formule (B2:G2) verso il basso, per un numero di righe sufficiente a coprire il max numero di Nominativi che pensi di dover gestire.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Funzione di Compilazione Se

Postdi iki » 25/09/13 13:48

ok
non ho capito, in quanto non riescoa farlo funzionare XD
ora cerco di caircare il file
così forse sono più chiaro
grazie comunque intanto . . .
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: Funzione di Compilazione Se

Postdi iki » 25/09/13 14:00

eccoci, vediamo se riesco:

http://rapidshare.com/share/7814C4F1EAE ... DC326F7142


ma quando incollo il link devo accorparlo in qualche dicitura? (URL, Code oppure *)
Ultima modifica di iki su 25/09/13 14:07, modificato 1 volte in totale.
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: Funzione di Compilazione Se

Postdi iki » 25/09/13 14:07

ho corretto, credo che adesso possiate accedervi...
sperem
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: Funzione di Compilazione Se

Postdi Anthony47 » 26/09/13 02:44

Immagine

Uploaded with ImageShack.us
Le scelte sono in colonna BF per i primi, BG per i secondi, etc
Metterai in D6
Codice: Seleziona tutto
=SE(RIF.COLONNA()-3=$BF6;$BF6;"")
da copiare poi verso dx
In Q6 userai
Codice: Seleziona tutto
=SE(RIF.COLONNA()-16=$BG6;$BG6;"")
sempre da copiare verso dx
In queste formule "3" e "16" sono il "numero colonna -1" della cella dove inserisci la prima formula del gruppo. Penso che non avrai difficolta' a continuare per gli altri gruppi (Contorno, Extra, Bevande), ma se hai problemi siamo qua.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Funzione di Compilazione Se

Postdi iki » 27/09/13 07:57

GRAZIE MILLE !!!
Ora applico e vediamo se sono almeno in grado di sistemare il tutto ;P
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56


Torna a Applicazioni Office Windows


Topic correlati a "Funzione di Compilazione Se":


Chi c’è in linea

Visitano il forum: Nessuno e 21 ospiti