Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

SOMMA.PIU.SE eseguito su piu colonne

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

SOMMA.PIU.SE eseguito su piu colonne

Postdi Spartacus85 » 16/08/13 14:25

Ciao a tutti.
Ho un enigma su come usare al meglio la funzione SOMMA.PIU.SE o SOMMA.SE.

La funzione e la seguente:

Codice: Seleziona tutto
=SOMMA.PIÙ.SE(INDIRETTO(""&$A6&"!h:h"),INDIRETTO(""&$A6&"!B:B"),$A$94)


dove A6 e il foglio dove ho i miei valori da sommare e A94 è la parola che pongo come condizione per la mia somma.

Ora quello che vorrei fare è sommare non solo cio che si trova nella colonna h ma anche tutto cio che si trova nelle colonne i,j,k, ecc..

Questo si può fare manalmente sommando tante volte quante sono le colonne interessate, esç

Codice: Seleziona tutto
=SOMMA.PIÙ.SE(INDIRETTO(""&$A6&"!h:h"),INDIRETTO(""&$A6&"!B:B"),$A$94)+SOMMA.PIÙ.SE(INDIRETTO(""&$A6&"!i:i"),INDIRETTO(""&$A6&"!B:B"),$A$94)[/[/


Quello che mi serve è creare una formula dinamica che avendo in ingresso come variabile il numero del mese, mi somma tutte le colonne riferite a mesi precedenti a quello in corso.

Esempio.

Colonna h:gennaio
Colonna i:febbraio
Colonna j:marzo

Se in ingresso ho 1, voglio che mi sommi i valori della colonna h la cui condizione sia uguale a quanto scritto in A94.
Se in ingresso ho 2, voglio che mi sommi i valori delle colonne h e i la cui condizione sia uguale a quanto scritto in A94.
Se in ingresso ho 3,voglio che mi sommi i valori delle colonne h, i e j la cui condizione sia uguale a quanto scritto in A94.

Spero sia riuscito a spiegarmi,

Grazie a tutti per l'aiuto
Spartacus85
Utente Junior
 
Post: 50
Iscritto il: 23/07/13 12:30

Sponsor
 

Re: SOMMA.PIU.SE eseguito su piu colonne

Postdi sasy89 » 16/08/13 16:03

Codice: Seleziona tutto
=SE(A1=1;SOMMA.SE(C2:C16;$B$1);SE(A1=2;SOMMA.SE(C2:C16;$B$1)+SOMMA.SE(D2:D16;$B$1);SE(A1=3;SOMMA.SE(C2:C16;$B$1)+SOMMA.SE(D2:D16;$B$1)+SOMMA.SE(E2:E16;$B$1);SE(A1=4;SOMMA.SE(C2:C16;$B$1)+SOMMA.SE(D2:D16;$B$1)+SOMMA.SE(E2:E16;$B$1)+SOMMA.SE(F2:F16;$B$1);SE(A1=5;SOMMA.SE(C2:C16;$B$1)+SOMMA.SE(D2:D16;$B$1)+SOMMA.SE(E2:E16;$B$1)+SOMMA.SE(F2:F16;$B$1)+SOMMA.SE(G2:G16;$B$1);"-----------")))))


Dove:
A1 varia da 1 a 12 (mesi dell'anno)
B1 la condizzione da te scelta
C2:C16 gennaio
D2:D16 febbraio
E2:E16 marzo

Questa formula va da 1 a 5 vale a dire da gennaio a maggio la devi solo continuare fino a 12 sempre se ho capito cosa ti serve :D
Ciao
sasy89
Utente Junior
 
Post: 14
Iscritto il: 27/09/12 18:14

Re: SOMMA.PIU.SE eseguito su piu colonne

Postdi wallace&gromit » 16/08/13 16:59

ciao, non penso che la soluzione di sasy sia quella giusta.
comunque, penso che tu spartacus non fossi distante dalla soluzione giusta:
prova ad inserire davanti alle condizioni per i mesi successivi una formula tipo SE(ingresso >1;1;0) per il primo mese da aggiungere, SE(ingresso >2;1;0) per il secondo, ecc. Questi vanno a moltiplicare le somme di quelle serie (ogni volta che otterrai 0 la somma di quel mese sarà azzerata). Spero di essermi spiegato.

In attesa di soluzioni migliori...
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: SOMMA.PIU.SE eseguito su piu colonne

Postdi Anthony47 » 16/08/13 23:04

Nell' ipotesi che il numero di mesi da sommare sia scritto in A2, potresti provare questa formula:
Codice: Seleziona tutto
=SOMMA((INDIRETTO($A$6&"!B1:B1000")=$A$94)*(SCARTO(INDIRETTO($A$6&"!H1");0;0;1000;$A$2)))
Da confermare con Contr-Maaiusc-Enter (formula a matrice), non il solo Enter.

Trattandosi di una formula a matrice non puoi indicare l' intera colonna come parametro; la formula proposta gestisce 1000 righe, se pensi possano essere insufficienti modifica "1000" in ambedue le posizioni.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: SOMMA.PIU.SE eseguito su piu colonne

Postdi Spartacus85 » 18/08/13 20:09

Anthony ho fatto come hai decritto, compreso la conferma della formula matriciale ma mi riporta come errore VALORE.

Per il momento ho tamponato con i SE annidati anche se la formula e un po pesante.

Grazie a tutti x aver risposto al topic
Spartacus85
Utente Junior
 
Post: 50
Iscritto il: 23/07/13 12:30

Re: SOMMA.PIU.SE eseguito su piu colonne

Postdi Anthony47 » 18/08/13 22:11

Hai copiato esattamente la formula suggerita o hai dovuta adattarla?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: SOMMA.PIU.SE eseguito su piu colonne

Postdi Spartacus85 » 23/08/13 09:44

Si Anthony la formula e la stessa, ho solo cambiato la cella dove ho scritto il foglio d'origine. Considera che uso le impostazioni inglesi quindi devo sostituire il ; con la ,.

Questo il codice usato che mi da come errore #VALORE:
Codice: Seleziona tutto
=SOMMA((INDIRETTO($C2&"!B1:B100")=$A$13)*(SCARTO(INDIRETTO($C2&"!H1"),0,0,100,$C$12)))
Spartacus85
Utente Junior
 
Post: 50
Iscritto il: 23/07/13 12:30

Re: SOMMA.PIU.SE eseguito su piu colonne

Postdi Anthony47 » 23/08/13 21:50

Controlla il foglio il cui nome e' impostato in C2, verificando che in H1:S100 (le colonne dei max 12 mesi) non ci sia altro che numeri. Se invece in riga H1:S1 sono presenti intestazioni in forma di testo, allora modifica la fomula in
Codice: Seleziona tutto
=SOMMA((INDIRETTO($C2&"!B2:B100")=$A$13)*(SCARTO(INDIRETTO($C2&"!H2"),0,0,99,$C$12)))

Se con questa verifica /modifica non risolvi allora seleziona la cella che contiene la formula; quindi produci uno screenshot in cui siano ben visibili la cella della formula, la barra della formula e le celle C2, A13 e C12 (per come fare, guarda qui: viewtopic.php?f=26&t=80395#p466013) e pubblica l' immagine

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: SOMMA.PIU.SE eseguito su piu colonne

Postdi Spartacus85 » 27/08/13 16:08

Pefetta funziona la formula...il motivo erano appunte le intestazioni. Pensa che non conoscendo questa formula avevo ottenuto lo stessorisltato con 12 se annidati (una roba illeggibile e brutta)
Anthony quindi il * lo utilizzo ogni volta che voglio fare un'operazione matriciale?
Spartacus85
Utente Junior
 
Post: 50
Iscritto il: 23/07/13 12:30


Torna a Applicazioni Office Windows


Topic correlati a "SOMMA.PIU.SE eseguito su piu colonne":


Chi c’è in linea

Visitano il forum: fabrizio2001, Marius44, patel e 6 ospiti