Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

operazioni escludendo valori non disponibili

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

operazioni escludendo valori non disponibili

Postdi marti89 » 23/06/13 14:55

ciao a tutti.devo fare la media di una colonna(nel mio caso K) di valori,alcuni dei quali sono #N/A...come faccio ad escluderli dal calcolo? ho già provato a usare averageif mettendo come condizione <>"#N/A" ma non funziona...perchè?
ho anche provato ad utilizzare una colonna di appoggio con if(k:2= "#N/A";0; k2), in modo da trasformare il valore #N/A presente nella cella in uno 0, ma non funziona (mi da comunque come risultato #N/A).
Grazie in anticipo per l'aiuto
marti89
Newbie
 
Post: 4
Iscritto il: 21/06/13 10:51

Sponsor
 

Re: operazioni escludendo valori non disponibili

Postdi Flash30005 » 23/06/13 15:31

Penso stia utilizzando un cerca.verticale quindi nel caso in cui non trova il valore nel range la formula fornisce #N/A
su una colonna di appoggio puoi non visualizzare nulla oppure uno 0 (zero)
con questa formula
Codice: Seleziona tutto
=SE.ERRORE(D2;"")

altrimenti nella stessa cella dove hai la formula originale (adattando il range alle tue esigenze)
Codice: Seleziona tutto
=SE(SE.ERRORE(CERCA.VERT("W";A$2:B$6;2;FALSO);0)=0;"";CERCA.VERT("W";A$2:B$6;2;FALSO))


ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: operazioni escludendo valori non disponibili

Postdi wallace&gromit » 23/06/13 17:30

puoi anche usare una formula matriciale (da confermare con Ctrl + Maiusc + Enter e non solo Enter) senza colonna d'appoggio:
Codice: Seleziona tutto
=MEDIA(SE(VAL.ERRORE(K2:K10);"";K2:K10))

il campo K2:K10 deve avere sempre la formula che ti da o un valore o #N/A, una cella vuota è conteggiata come "0".
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "operazioni escludendo valori non disponibili":


Chi c’è in linea

Visitano il forum: Nessuno e 23 ospiti