Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula equivalente ma più veloce.

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: Formula equivalente ma più veloce.

Postdi Statix » 09/06/13 16:14

Ciao ricky53,
un altro sforzo ,
guardi che sono diverse ore che ci provo,
ma proprio non riesco alcune si altre no,
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Formula equivalente ma più veloce.

Postdi ricky53 » 09/06/13 16:16

Ciao,
tra un po' devo uscire e ...

Hai provato quella che ti ho inviato?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Formula equivalente ma più veloce.

Postdi Statix » 09/06/13 16:16

si è ok e ti ringrazio
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula equivalente ma più veloce.

Postdi ricky53 » 09/06/13 16:28

Ciao,
ultima e poi devo scappare
Codice: Seleziona tutto
Cells(6 + I, "DZ").FormulaLocal = "=SE(CONTA.NUMERI(AB" & 6 + I & ":AD" & 6 + I & ")=1;$AB" & 6 + I & ";"""")"
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Formula equivalente ma più veloce.

Postdi Statix » 09/06/13 16:31

caspita hai messo proprio quella che c'ero riuscito
me ne manca ancora 1
pian piano imparerò anche questa sintassi
;) ;)
Codice: Seleziona tutto
Cells(6 + I, "DZ").FormulaLocal = "=Se(Conta.numeri(DU" & (6 + I) & ":DV" & (6 + I) & ")=1 ;$L" & 6 + I & ";"""")"
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula equivalente ma più veloce.

Postdi ricky53 » 09/06/13 16:38

Ciao,
consiglio: copia la tua formula e ad ogni "6" devi inserire "&" e il "+ I" e poi finisci con "&".
Devi fare solo attenzioni ai doppi apici che se devono essere scritti devi metterne uno di inizio ed un altro di fine oltre a quello/i che vuoi ci siano nella formula.

Complicato da scrivere ma facile da fare.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Formula equivalente ma più veloce.

Postdi Statix » 09/06/13 16:46

ok ma questa non mi va proprio
Codice: Seleziona tutto
Cells(6 + I, "DW").FormulaLocal = "=Se($DU" & (6 + I & ")= """""&";"""";Conta.se($D" & (7 + I) & ":H" & (6 + I + (L" & (6 + I) &")&";$D$2);(L" & (6 + I))"
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula equivalente ma più veloce.

Postdi Statix » 09/06/13 21:37

ci sono quasi
c'è un errore in fondo alla formula che non riesco a sistemare è quel L"&(6+I) che forse sbaglio,
mi sa che stasera non connetto. :-? :-? :-?

Codice: Seleziona tutto
 Cells(6 + I, "DW").FormulaLocal = "=Se($DU" & (6 + I) & " = """";"""";Conta.se($D" & (7 + I) & ":$H" &(6 + I + L" & (6 + I) & ";$D$2))"
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula equivalente ma più veloce.

Postdi Anthony47 » 09/06/13 22:27

Scusa, ma che formula vuoi inserire in DW6 (e sottostanti)?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula equivalente ma più veloce.

Postdi Statix » 09/06/13 22:34

Ciao Anthony47,
la formula è questa
Codice: Seleziona tutto
=SE($DU6="";"";CONTA.SE(INDIRETTO("D"& RIF.RIGA()+1 & ":" & "H" & RIF.RIGA()+$L6);D$2))
in colonna DW
inoltre ti volevo chiede per quanto riguarda la tua macro dove hai messo UR mi sembra che c'è qualcosa che non va,
se potevi ricontrollare, grazie.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula equivalente ma più veloce.

Postdi Anthony47 » 09/06/13 22:39

Vorrei quella semplice semplice, tipo =Se(A6>22;conta.se(F6:F33;CC6);""), perche' mi vuoi complicare la vita??
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula equivalente ma più veloce.

Postdi Anthony47 » 09/06/13 23:16

Oopps...
Non arrivando una risposta sono andato a rileggere quello che avevi scritto, che era esattamente quello che chiedevo...

Potresti fare cosi':
prima metti in una variabile il contenuto di L6, e poi lo usi nella formula; esempio
Codice: Seleziona tutto
myL6 = Range("L6").Value
'...
Cells(6 + I, "DW").FormulaLocal = "=se($DU" & (6 + I) & "="""";"""";Conta.se(D" & (6 + I + 1) & ":H" & (6 + I + myL6) & ";D$2))"

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula equivalente ma più veloce.

Postdi Anthony47 » 09/06/13 23:40

NO! (avevo letto erroneamente L$6); lascia stare quanto detto prima...
Forse questa:
Codice: Seleziona tutto
Cells(6 + I, "DW").FormulaLocal = _
    "=se($DU" & (6 + I) & "="""";"""";Conta.se(D" & (6 + I + 1) & ":H" & (6 + I + Cells(6 + I, "L").Value) & ";D$2))"
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula equivalente ma più veloce.

Postdi Statix » 09/06/13 23:51

Ciao Anthony47,
ho provato la formula ma non è precisa,
comunque ho un altro problema aggiungendo nella macro
altre formule perfettamente funzionanti,

le prime 5 formule vengono scritte anche fino in fondo(UR)
mentre le altre 5 la macro non me le scrive fino all'ultima riga,
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula equivalente ma più veloce.

Postdi Anthony47 » 09/06/13 23:57

Hai provato la seconda versione, vero?
In che cosa nion e' precisa? es "mi aspettavo che la formula fosse ....... , perche' ...., e invece mi ha messo ......"

Per quanto riguarda il problema aggiuntivo, forse dovresti allegare la macro che usi e spiegare quali sono le formule che non vengono inserite fino a UR.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula equivalente ma più veloce.

Postdi Statix » 10/06/13 00:06

Ok la seconda va bene,
credo che l'altro problema sia questa formula,e da modificare la L
Codice: Seleziona tutto
Cells(6 + I, "DU").FormulaLocal = "=SE($L" & (6 + I) & ">=myI4;"""";SE(CONTA.SE($D" & (6 + I) & ":$H" & (6 + I) & " ;$A$2)=1;$L" & (6 + I) & ";""""))"

la L non deve essere incrementata da I

Codice: Seleziona tutto
=SE($L6>=$I$4;"";SE(CONTA.SE(D6:H6;$A$2)=1;$L6;""))
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula equivalente ma più veloce.

Postdi Anthony47 » 10/06/13 00:11

Forse
Codice: Seleziona tutto
Cells(6 + I, "DU").FormulaLocal = "=SE($L" & (6 + I) & ">=" & myI4 & ";"""";SE(CONTA.SE($D" & (6 + I) & ":$H" & (6 + I) & " ;$A$2)=1;$L" & (6 + I) & ";""""))"
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula equivalente ma più veloce.

Postdi Statix » 10/06/13 00:19

non va ho lo stesso problema,hai postato la mia stessa formula
come detto prima i valori della L6 :L6000 devono rimanere inalterati se in L345 ho 5 e la condizione è falsa mi deve dare 5
Codice: Seleziona tutto
=SE(L6>=$I$4;"";SE(CONTA.SE(D6:H6;$A$2)=1;L6;""))
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Formula equivalente ma più veloce.

Postdi Anthony47 » 10/06/13 00:26

Ignora la proposta fatta prima.
Hai scritto che volevi =SE($L6>=$I$4;"";SE(CONTA.SE(D6:H6;$A$2)=1;$L6;"")); che significa "la L non deve essere incrementata da I"? vuol dire che vuoi la formula =SE($L$6>=$I$4;"";SE(CONTA.SE(D6:H6;$A$2)=1;$L$6;"")) ??

Non ho invece decodificato "il valore della L6 deve rimanere inalterato se ho 5 e la condizione è falsa mi deve dare 5": che vuoi dire?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula equivalente ma più veloce.

Postdi Statix » 10/06/13 00:31

allora in
L6 =8
L7=9
L8=22
e cosi per tutta la colonna ,quindi in colonna L:L non ho valori fissi,
ma rispettata la condizione della formula mi deve dare il valore di L
ho messo un altra condizione, puo servire in seguito

Codice: Seleziona tutto
=SE(O(L6>=$I$4;L6="");"";SE(CONTA.SE(D6:H6;$A$2)=1;L6;""))
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

PrecedenteProssimo

Torna a Applicazioni Office Windows


Topic correlati a "Formula equivalente ma più veloce.":


Chi c’è in linea

Visitano il forum: Anthony47 e 22 ospiti