Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] Somma di celle con prefisso alfabetico

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] Somma di celle con prefisso alfabetico

Postdi salvoann » 16/05/13 16:18

salve a tutti,
mi presento, primo post, sono Salvatore e leggo questo forum quando ne ho bisogno e lo trovo utilissimo. Ho sempre trovato soluzione tranne adesso: In pratica, in Excel 2010, devo sommare una serie di numeri e lettere-numeri, facendo in modo di sommare anche dove c'è la lettera T.
Esempio intervallo (F4:CB4) 1 3 6 T4 3 T2 , in E4 voglio che mi dia la somma 19 . Se è possibile vorrei che nell'intervallo ci siano anche celle vuote, in alternativa posso mettere tutti zero, se deve esserci per forza un valore.

Grazie mille
salvoann
Utente Junior
 
Post: 10
Iscritto il: 16/05/13 16:03

Sponsor
 

[excel] Somma di celle con prefisso alfabetico

Postdi CANAPONE » 16/05/13 16:59

Ciao,

una prima risposta:

Codice: Seleziona tutto
=SOMMA(INDICE(--SOSTITUISCI("T"&F4:CB4;"T";0);))


Funziona con numeri positivi


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [excel] Somma di celle con prefisso alfabetico

Postdi ricky53 » 16/05/13 17:17

Ciao,
prova con
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--SOSTITUISCI(SOSTITUISCI(F4:CB4;"";"0");"t";""))


La formula gestisce anche il caso in cui le celle siano vuote.

Prova e sono/siamo QUI



EDIT: non avevo visto l'intervento di Canapone ...
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [excel] Somma di celle con prefisso alfabetico

Postdi salvoann » 17/05/13 09:13

usato la formula di capanone (sono andato per gradi) e.... buona la prima !
Ricky non ho avuto modo di provare la tua, grazie comunque a tutti per le risposte superprofessionali e veloci..
salvoann
Utente Junior
 
Post: 10
Iscritto il: 16/05/13 16:03

Re: [excel] Somma di celle con prefisso alfabetico

Postdi CANAPONE » 17/05/13 09:22

Ciao,

grazie del cortese riscontro.


Non sono riuscito a scrivere un formula che aiutasse la digestione dei numeri negativi: ci stavo proprio pensando qualche minuto fa.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [excel] Somma di celle con prefisso alfabetico

Postdi ricky53 » 17/05/13 10:32

Ciao Canapone,
quanto ho suggerito io gestisce anche i valori negativi purchè siano stringhe
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [excel] Somma di celle con prefisso alfabetico

Postdi Anthony47 » 17/05/13 12:21

Questa e' meno sofisticata ma gestisce anche negativi, sia nella forma -5 che -t5 che t-5 che -5t:
Codice: Seleziona tutto
=SOMMA(SE(VAL.NUMERO(F4:CB4);F4:CB4;SE(VAL.ERRORE(VALORE(SOSTITUISCI(MAIUSC("T"&F4:CB4);"T";"")));0;VALORE(SOSTITUISCI(MAIUSC("T"&F4:CB4);"T";"")))))
Va confermata con Contr-Maiusc-Enter, non il solo Enter

Pero', da quanto ha scritto salvoann, mi pare che sto' problema non ci fosse.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[excel] Somma di celle con prefisso alfabetico":


Chi c’è in linea

Visitano il forum: fabrizio2001, Marius44, patel e 8 ospiti