Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel: nidificazione di funzioni

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel: nidificazione di funzioni

Postdi emalatesta » 01/05/13 12:12

Ciao a tutti, chi mi aiuta a risolvere il seguente problema:

ho una cella (L4) che assume un valore a seguito di un calcolo;
in un'altra cella (D29), a seconda del valore che assume L4, dovrà essere scritto un valore percentuale:
la cella L4 deve essere verificata per intervallo di valori, cioe:
se il suo valore è compreso tra 1001 e 2000 => in D9 deve essere scritto il valore 10%
se il suo valore è compreso tra 2001 e 3000 => in D9 deve essere scritto il valore 11%
se il suo valore è compreso tra 3001 e 4000 => in D9 deve essere scritto il valore 12%

.. e via dicendo fino ad esaminare la condizione in cui L4 assuma un valore di 40000

C'è qualcuno che può aiutarmi?
Enrico Malatesta
emalatesta
Utente Senior
 
Post: 182
Iscritto il: 27/08/01 01:00

Sponsor
 

Re: Excel: nidificazione di funzioni

Postdi peppo55 » 01/05/13 13:39

Ciao emalatesta

credo che puoi risolvere con la finzione cerca.vert.
In una zona del foglio ad esempio A13:C15 (da modificare alle tue esigenge) inserisci i valori

1001 2000 10%
2001 3000 11%
3001 4000 12%

In D9 inserisci la formula : =CERCA.VERT(L4;A13:C15;3;VERO)
peppo

Excel 2010
peppo55
Utente Senior
 
Post: 154
Iscritto il: 30/09/12 13:51

Re: Excel: nidificazione di funzioni

Postdi emalatesta » 01/05/13 14:11

Perfetto.In effetti è molto piùsemplice di come, scovando qual e la, mi sono complicato la vita riuscendo ad annidare n funzioni SE.

Grazie a te e agli amici che hanno letto il post (magari dedicando del tempo per identificare la soluzione).

Ciao!
Enrico Malatesta
emalatesta
Utente Senior
 
Post: 182
Iscritto il: 27/08/01 01:00

Re: Excel: nidificazione di funzioni

Postdi Anthony47 » 01/05/13 22:01

Per evitare sorprese, inserisci la tabella tassativamente in ordine crescente di colonna A, e magari inserisci anche una riga (la prima della tabella, per quanto appena detto) con i valori 0-1000-???
Invece di ??? inserisci cosa vuoi che sia scelto in caso che L4 assuma il valore compreso tra 0 e 1000.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel: nidificazione di funzioni":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti