Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - CERCA.VERT "dinamico"

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: Excel - CERCA.VERT "dinamico"

Postdi gaetano73 » 23/04/13 16:41

Faranno loro o meglio lui: il mio capo. Io devo consegnare solo il "prodotto" che funziona.
Lui provvederà a farlo "girare"...
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Sponsor
 

Re: Excel - CERCA.VERT "dinamico"

Postdi ricky53 » 23/04/13 16:50

E come lo farà girare se non trova i file che non puoi aprire ?
Saranno problemi SUOI !!!

Seriamente ponilo a LORO come problema.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Excel - CERCA.VERT "dinamico"

Postdi gaetano73 » 23/04/13 21:05

Forse mi sono espresso in maniera infelice.
Il file che io devo cosegnare deve semplicemente fare il suo dovere ovvero, eseguire i CERCA.VERT su altri file che stanno in determinati percorsi. Prima o poi questi percorsi cambieranno; ai nuovi non potrò neanche accedervi ed io dovrò produrre un nuovo file dove ci saranno CERCA.VERT che attingeranno i dati dai nuovi file posizionati in nuovi percorsi.
Ad esempio ora su mio file ci saranno istruzioni tipo
=CERCA.VERT($B7;'\\dati5\Febbraio 2013\[Dipendenti_01_02_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)
=CERCA.VERT($B7;'\\dati5\Febbraio 2013\[Dipendenti_02_02_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)
=CERCA.VERT($B7;'\\dati5\Febbraio 2013\[Dipendenti_03_02_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)
Domani ci saranno istruzioni del tipo
=CERCA.VERT($B7;'\\dati12\Aprile 2013\[Dipendenti_01_04_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)
=CERCA.VERT($B7;'\\dati12\Aprile 2013\[Dipendenti_02_04_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)
=CERCA.VERT($B7;'\\dati12\Aprile 2013\[Dipendenti_03_04_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)
Per evitare di cambiare a mano il contenuto di tutti i (centinaia di) CERCA.VERT volevo implementare qualcosa che me lo facesse in automatico.
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Re: Excel - CERCA.VERT "dinamico"

Postdi Anthony47 » 23/04/13 22:35

Adesso a che punto sei?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel - CERCA.VERT "dinamico"

Postdi gaetano73 » 23/04/13 23:15

Ho quasi finito... di modificarli a mano :cry:
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Re: Excel - CERCA.VERT "dinamico"

Postdi Anthony47 » 24/04/13 07:19

Quindi non sei riuscito a far funzionare il codice che inseriva nelle celle direttamente la formula Cerca.Vert?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel - CERCA.VERT "dinamico"

Postdi gaetano73 » 24/04/13 09:27

No. È il segno "=" che dà il problema...

Se la marco cerca di incollare
Codice: Seleziona tutto
=CERCA.VERT($B7;'\\dati5\Febbraio 2013\[Dipendenti_01_02_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)

mi da "Errore di run-time '1004' Errore definito dall'applicazione o dall'oggetto"
Se gli faccio incollare
Codice: Seleziona tutto
CERCA.VERT($B7;'\\dati5\Febbraio 2013\[Dipendenti_01_02_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)
quindi senza = all'inizio, la macro funziona nel senso che mi incolla la stringa ma, ovviamente, non fa il suo dovere perché senza = viene interpretata come una stringa di testo e non come una funzione...
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Re: Excel - CERCA.VERT "dinamico"

Postdi Anthony47 » 24/04/13 13:58

A me istruzioni di questo tipo funzionano correttamente:
Codice: Seleziona tutto
pippo = "=CERCA.VERT($B7;'\\dati5\Febbraio 2013\[Dipendenti_01_02_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)"
ActiveCell.FormulaLocal = pippo
Oppure direttamente
Codice: Seleziona tutto
ActiveCell.FormulaLocal = "=CERCA.VERT($B7;'\\dati5\Febbraio 2013\[Dipendenti_01_02_2013.xls]OreOrdinarie'!$D$5:$G$88;2;FALSO)"


Devo quindi immaginare che la stringa che ottieni e' diversa da quella che andrebbe usata nella formula con FormulaLocal; prova a ispezionare il contenuto della variabile contenuto_cella per accertarne il contenuto.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel - CERCA.VERT "dinamico"

Postdi gaetano73 » 24/04/13 20:19

Siiiiiiiiiiiiiiiiiiiiiiiiii. Risolto!
Ecco dove avevo sbagliato... mi ostinavo ad usare ActiveCell.FormulaR1C1 anziché ActiveCell.FormulaLocal!!!
Leggendo l'ultimo post di Anthony47 mi è saltato agli occhi l'errore. Per questa svista vi autorizzo ad offendermi :D
Grazie 1G!
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Re: Excel - CERCA.VERT "dinamico"

Postdi Anthony47 » 26/04/13 13:51

Per questa svista vi autorizzo ad offendermi
Scusa, oggi mi sento particolarmente pigro; puoi per favore provvedere da solo, pubblicando poi l' epiteto scelto?
:D :D
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel - CERCA.VERT "dinamico"

Postdi gaetano73 » 26/04/13 13:58

Certo!
Allora, io scriverei: "È con viva e vibrante soddisfazione che possiamo darti del... distrattone!"
:lol:
gaetano73
Utente Senior
 
Post: 247
Iscritto il: 03/09/02 18:36

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "Excel - CERCA.VERT "dinamico"":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti