Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Macro excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Macro excel

Postdi nicola_na78 » 08/04/13 16:56

Ciao a tutti, Vi chiedo se è possibile realizzare una macro che fa questo:
nella colonna A "data Valuta Corrente" che va dal rigo 2 al rigo 300 devo inserire manualmente delle date. è possibile tramite macro che la data appena scritta nel rigo 2 della colonna A venga automaticamente copiata nella colonna F sempre nello stesso rigo?? e così se ripeto l'operazione x le righe successive....

Ringrazio Tutti Buona serata
nicola_na78
Utente Senior
 
Post: 147
Iscritto il: 11/06/10 15:26

Sponsor
 

Re: Macro excel

Postdi Flash30005 » 08/04/13 18:08

Nel Vba del foglio interessato inserisci questo codice
Codice: Seleziona tutto
Private Sub Worksheet_Change(ByVal Target As Range)
Area = "A2:A300"
If Not Application.Intersect(Target, Range(Area)) Is Nothing Then
Application.EnableEvents = False
Cells(Target.Row, 1).Offset(0, 5).Value = Target
Application.EnableEvents = True
End If
End Sub

Formatta la colonna F come data

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Macro excel

Postdi nicola_na78 » 08/04/13 22:12

Grazie tante Flash30005, sei grande come sempre.
alla prossima buona serata ;)
nicola_na78
Utente Senior
 
Post: 147
Iscritto il: 11/06/10 15:26

Re: Macro excel

Postdi Anthony47 » 08/04/13 22:34

In alternativa alla macro puoi usare in F2 la formula
Codice: Seleziona tutto
=SE(A2<>"";A2;"")
Formatta come data, poi copia fino ad F300.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Macro excel

Postdi nicola_na78 » 09/04/13 13:20

Ciao Antony47 grazie anche a te per la risposta
nicola_na78
Utente Senior
 
Post: 147
Iscritto il: 11/06/10 15:26


Torna a Applicazioni Office Windows


Topic correlati a "Macro excel":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti