Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

modifica file excel 2002 conteggio straordinario

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 15/04/13 08:59

scusami mi sono dimenticato che dobbiamo aggiungere le domeniche lavorate e se si accavallano con i festivi e superfestivi mi deve dare sempre +1 e non +2
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Sponsor
 

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 15/04/13 12:55

Eh gia'...
Modifica la formula in
Codice: Seleziona tutto
=I3+SOMMA(SE((A10:A40<>"")*(C10:C40<>"")=1;--(((GIORNO.SETTIMANA(A10:A40;2)>6)+CONTA.SE(FESTIVI;A10:A40)+CONTA.SE(SUPERFESTIVI;A10:A40))>0);0))-CONTA.SE(B10:B40;"RIP")

Sempre Contr-Maiusc-Enter

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 15/04/13 13:36

una domanda..... se si accavalla un festivo un superfestivo e una domenica mi da sempre 1?
altrimenti non va bene!
grazie!
ciao.
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 15/04/13 21:54

Spero che nel frattempo tu abbia fatto un collaudo e che il risultato sia come ti serviva (in linea con la mia intenzione)...

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 16/04/13 08:51

lo sto facendo infatti c'è un problema da risolvere nell'ultima formula...dove dice CONTA.SE(B10:B40;"RIP") non dovrebbe conteggiarmi i rip che coincidono con le domeniche, festifi e superfestivi.
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 16/04/13 13:34

Il foglio mi sembra ad uso di una singola persona, se costui scrive Rip di Domenica io glielo conterei come da suo desiderio; che male c' e' a esaudire un desiderio, soprattutto se e' a costo zero per l' amministrazione?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 16/04/13 16:20

non ho capito se è una battuta
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 16/04/13 21:22

Non era una battuta: non capisco perche' uno scrive pigramente sul suo foglio presenze che fa Riposo di domenica e un altro deve controllare se lo svogliato ha sbagliato a suo stesso svantaggio...
Potrei cambiare idea se il foglio e' compilato da una seconda persona, per cui invece di pigrizia si parla di errore di compilazione a danni del dipendente.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 17/04/13 11:14

il programmino che hai visto è personale per ogni persona...ma c'è un ufficio che li fa per tutti con un programma diverso ma con le stesse regole....quindi serve per fare un confronto in caso di errori...
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 17/04/13 14:25

Non voglio approfondire :D
Modifica la formula in
Codice: Seleziona tutto
=I3+SOMMA(SE((A10:A40<>"")*(C10:C40<>"")=1;--(((GIORNO.SETTIMANA(A10:A40;2)>6)+CONTA.SE(FESTIVI;A10:A40)+CONTA.SE(SUPERFESTIVI;A10:A40))>0);0))-SOMMA((B10:B40="RIP")*((SE(A10:A40<>"";--(GIORNO.SETTIMANA(A10:A40;2)>6);1)+CONTA.SE(FESTIVI;A10:A40)+CONTA.SE(SUPERFESTIVI;A10:A40))=0))
Sempre Contr-Maiusc-Enter

Questa non impedisce all' utente pigro /svogliato di scrivere Rip ad esempio su una Domenica, ma quell' eventuale Rip viene ignorato in questo calcolo.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 22/04/13 12:26

ok grazie credo abbiamo finito con questo...
invece ritornando al primo programmino http://uploading.com/eb52bdee/SERVIZIO-2013-vuoto-XLS lo una un mio amico per lui va bene quel tipo di conteggio c'è una sola modifica da fare in "O10" dovrebbe conteggiarmi i C.O. dal primo all'ultimo del mese cosi come succede in "O11" per gli R.R.S. quindi forse puoi prendere spunto da qui e usare le colonne che sono state create per lo scopo che sono AZ-AY-BA
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 24/04/13 12:25

trittico69 ha scritto:ok grazie credo abbiamo finito con questo...
invece ritornando al primo programmino http://uploading.com/eb52bdee/SERVIZIO-2013-vuoto-XLS lo una un mio amico per lui va bene quel tipo di conteggio c'è una sola modifica da fare in "O10" dovrebbe conteggiarmi i C.O. dal primo all'ultimo del mese cosi come succede in "O11" per gli R.R.S. quindi forse puoi prendere spunto da qui e usare le colonne che sono state create per lo scopo che sono AZ-AY-BA

rileggendo bene e riguardando il programma credo che la formula da modificare sia in O3 invece che in O10 e le colonne create per lo scopo,come detto sopra, forse non vanno bene perchè integrano altro. quindi forse è meglio che fai tu.
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 24/04/13 14:01

Per ora posso solo dire che non mi ero dimenticato della richiesta, ma come sai "la complessita' del tuo foglio di calcolo" mi fa sempre rimandare...
Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 27/04/13 13:15

dovrebbe essere sufficiente una formula messa in O3 del foglio di febbraio che dica (conta quanto 4 ci sono in J14:J56+J14:J56"gen!"+J14:J56"mar!") facendo riferimento alla colonna AZ dove c'è già la fomula per specificare i giorni del mese precedente o successivo, il numero 4 è il codice che viene messo nella colonna J e stà ad indicare C.O.
e poi si dovrebbe fare l'inverso in O11 che conteggia gli R.R.S. dal primo all'ultimo del mese invece deve contare solo quelli nel propio foglio/mese e il codice che viene messo nella colonna J in questo caso è 2.
spero di essermi spigato in un modo benomale comprensibile.
ciao
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 29/04/13 00:35

Mi sono fatto coraggio... e ho scoperto che siamo tornati alla domanda originale: avendo dei fogli che elencano le presenze del mese contabile vorresti che alcuni conteggi siano fatti sul mese solare, pescando quindi anche nei mesi contabili "adiacenti".
Allora io tornerei a quanto avevo proposto, per gli straordinari, qui: viewtopic.php?f=26&t=98805#p568964
Adattando le formule ai dati da calcolare (i "C.O. di colonna M), quindi:
in AG1 di FEB
Codice: Seleziona tutto
=SOMMA(SE($A$14:$A$30<>"";SE(MESE($A$14:$A$30)<MESE($A$26);--(M$14:M$30="C.O.");0);0))
in AG2 di FEB
Codice: Seleziona tutto
=SOMMA(SE($A$32:$A$57<>"";SE(MESE($A$32:$A$57)>MESE($A$26);--(M$32:M$57="C.O.");0);0))
Ambedue le formule sono da confermare con Contr-Maiusc-Enter

Copia quindi queste formule in AG1 /AG2 degli altri mesi eccetto Gennaio e Dicembre.
Per i mesi di Gennaio e Dicembre valgono gli stessi ragionamenti fatti 4 settimane fa (il link che ti ho dato prima):
Rimane da risolvere Gennaio e Dicembre.
In gennaio il mese precedente e' Dicembre, quindi non possiamo usare nella formula di AG1 il confronto sul mese [SE(MESE($A$14:$A$30)<MESE($A$26)] ma si usera' l' anno [quindi usare SE(ANNO($A$14:$A$30)<ANNO($A$26)]
La formula in AG2 e' invece quella standard
In dicembre la formula in AG1 e' quella standard e quella in AG2 usera' il calcolo sull' anno [SE(ANNO($A$32:$A$57)>ANNO($A$26)]


In AG1 hai cosi' calcolato i C.O. che appartengono al mese precedente; in AG2 quelli che appartengono a quello successivo

Infine vai su O3 di FEB; ora hai la formula =CONTA.SE(M14:M58;"C.O.")
La modificherai in =CONTA.SE(M14:M58;"C.O.")-AG1-AG2+'GEN '!AG2+'MAR '!AG1

Cioe' =LaFormulaAttuale-AG1-AG2+'MesePrima'!AG2+'MeseDopo'!AG1

Per Gennaio invece di +'MesePrima'!AG2 dovrai attingere da AG2 di Dicembre dell' anno precedente; per dicembre invece di +'MeseDopo'!AG1 dovrai attingere da Gennaio dell' anno prossimo.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 30/04/13 12:40

a dicembre ho messo questa
=CONTA.SE(M14:M58;"C.O.")-AG1-AG2+'NOV '!AG2
e a gennaio
=CONTA.SE(M14:M58;"C.O.")-AG1-AG2+'FEB '!AG1

adesso

trittico69 ha scritto:e poi si dovrebbe fare l'inverso in O11 che conteggia gli R.R.S. dal primo all'ultimo del mese invece deve contare solo quelli nel proprio foglio/mese e il codice che viene messo nella colonna J in questo caso è 2.
spero di essermi spigato in un modo benomale comprensibile.
ciao
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 01/05/13 21:50

Quindi gli RSS vanno contati solo quelli segnati sul singolo foglio? Se e' cosi'. allora in O11 (o nella cella dove fai questo conteggio) basta usare la formula
Codice: Seleziona tutto
=CONTA.SE(M14:M57;"R.R.S.")


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 02/05/13 15:56

poi in un altra cella vanno conteggiato ogni domenica,festivo e superfestivo lavorato...quindi se le righe corrispondenti a questi ultimi e cioè C14:H56 diverso da vuoto.
poi provo e ti faccio sapere se va aggiunto altro o sottratto.
ciao!
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi trittico69 » 20/05/13 15:16

Anthony
non hai avuto tempo di farmi quest'ultima formula?
trittico69
Utente Senior
 
Post: 487
Iscritto il: 16/08/09 18:41

Re: modifica file excel 2002 conteggio straordinario

Postdi Anthony47 » 20/05/13 23:28

Visto che si tratta di formule relativamente "semplici" speravo che ne uscissi da solo...
Per le domeniche:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(C14:C56>0);--(GIORNO.SETTIMANA("0"&(A14:A56);2)=7);--(CONTA.SE(FESTIVI;A14:A56)=0);--(CONTA.SE(SUPERFESTIVI;A14:A56)=0))

Per i festivi
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(CONTA.SE(FESTIVI;A14:A56)>0))

Per i superfestivi
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(CONTA.SE(SUPERFESTIVI;A14:A56)>0))

Presuppone che negli elenchi dei festivi e superfestivi non ci siano celle vuote; eventualmente riempile con una data a caso, ad esempio 123 (2 mag 1900).

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

PrecedenteProssimo

Torna a Applicazioni Office Windows


Topic correlati a "modifica file excel 2002 conteggio straordinario":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti