Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

aiuto formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

aiuto formula

Postdi CIACILLO1 » 04/03/13 12:36

Ciao a tutti, ho bisogno del vostro aiuto vi spiego:
ho bisogno che la formula deve cercare sulla stessa riga A;B, una parte testo in A1 e in B2 un testo specifico; esempio:
A1 una parte della parola "posta"(che potrebbe essere inserita pt o posta ecc)e in B2 valore specifico "consegna", se ci sono tutte e due le condizioni il risultato sarà 1 caso contrario 0.
grazie a tutti per la collaborazione
CIACILLO1
Utente Junior
 
Post: 43
Iscritto il: 04/06/09 11:39

Sponsor
 

Re: aiuto formula

Postdi ricky53 » 04/03/13 13:37

Ciao,
le tue condizioni son un po' "GENERICHE" ... ci provo
Codice: Seleziona tutto
=SE(E(O(MAIUSC(A1)="PT"; MAIUSC(A1)="P.T."; MAIUSC(A1)="POSTA"); MAIUSC(B2)="CONSEGNA"); 1; 0)


Volendo puoi aggiungere altre condizioni prima o dopo
Codice: Seleziona tutto
 MAIUSC(A1)="POSTA"
ma sempre all'interno della condizione "O(...; ...; ...)"

Attenzione ai ";"
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: aiuto formula

Postdi CIACILLO1 » 04/03/13 13:47

Io ho provato con:=SE(A1="CONSEGNA";SE(VAL.ERRORE(TROVA("*PT*";B1));1;0)), ma non va... :cry:
CIACILLO1
Utente Junior
 
Post: 43
Iscritto il: 04/06/09 11:39

Re: aiuto formula

Postdi CANAPONE » 04/03/13 14:12

Ciao a tutti,

se ho capito basta

Codice: Seleziona tutto
=--E(A1="CONSEGNA";VAL.NUMERO(RICERCA("PT";B1)))


oppure (stessa formula)

Codice: Seleziona tutto
=(A1="CONSEGNA")*VAL.NUMERO(RICERCA("PT";B1))



Se A1 è uguale a "consegna" e la stringa in B1 contiene PT la formula restituisce 1.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: aiuto formula

Postdi CIACILLO1 » 04/03/13 14:28

Ciao Canapone così è ok, solo che mi restituisce il risultato vero o falso. io vorrei che mi desse 1 se vero 0 se falso.
CIACILLO1
Utente Junior
 
Post: 43
Iscritto il: 04/06/09 11:39

Re: aiuto formula

Postdi CIACILLO1 » 04/03/13 14:31

:lol: :lol: :lol: grazie canapone era la seconda formula pensavo fossero uguali.
grazie siete grandi. :P :P :P
CIACILLO1
Utente Junior
 
Post: 43
Iscritto il: 04/06/09 11:39

Re: aiuto formula

Postdi CANAPONE » 04/03/13 14:33

Ciao,

grazie del riscontro.

Alla prossima
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: aiuto formula

Postdi ricky53 » 04/03/13 14:48

Ciao,
bene per aver risolto.

Ma hai provato come ti avevo indicato io?
Se uno di noi ti fornisce una soluzione tu dovresti dire il risultato delle prova fatte con la soluzione proposta.

Attenzione tu avevi scritto "B2" ed io o lavorato con "B2" se la cella è "B1" devi cambiarla nella formula.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: aiuto formula

Postdi CIACILLO1 » 04/03/13 16:18

Scusa Ricky hai perfettamente ragione ho sbagliato ha digitare, ed ho provato ad inserire la tua formula ma nn andava proprio per questo mio errore.
grazie di tutto.
CIACILLO1
Utente Junior
 
Post: 43
Iscritto il: 04/06/09 11:39

Re: aiuto formula

Postdi ricky53 » 04/03/13 16:22

Ciao,
quindi ?
Il risultato delle prove ?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "aiuto formula":

Aiuto urgente!!!
Autore: templare77
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: alfrimpa, enrico43 e 4 ospiti

cron