Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

funzione per contare numeri

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

funzione per contare numeri

Postdi A123691 » 23/02/13 18:59

Salve,
ogni tanto mi faccio vivo per chiedere aiuto.
Ho cercato nel foruma ,ma non ho trovato...

Vorrei contare quali sono i 2(o3) numeri che compaiono più volte in (esempio) A1:Z10
sono numeri (Quantità)da 1 a 100.
Ho provato con conta.se(A1:z10:1) poi conta.se(A1:z10;2) ....3-4-5......100 che conta quante volte compare 1 o 2,3,4 ecc dopo ordino in modo decescente e trovo i primi2(o3).


...ho anche provato con una funzione matriciale trovata in rete
=INDICE(A1:Z10;CONFRONTA(MAX(CONTA.SE(A1:Z10;A1:Z10));CONTA.SE(A1:Z10;A1:Z10);0)) confermato con maisc+ctrl+invio che dovrebbe calcolarmi il valore che è più presente ma escono valori strani

Qualche suggerimento per velocizzare il risultato?

grazie
A123691
Utente Junior
 
Post: 53
Iscritto il: 27/11/07 22:34
Località: Lat.45° 04' Long. 6° 53'

Sponsor
 

Re: funzione per contare numeri

Postdi CANAPONE » 23/02/13 19:53

Ciao,

A1:Z10 sono celle tutte piene

A11:

Codice: Seleziona tutto
=MODA(A1:Z10)


A12:

Codice: Seleziona tutto
=MODA(SE(A1:Z10<>A11;A1:Z10))


da confermare con control+maiusc+invio: restituisce il secondo numero più frequente

A13:

Codice: Seleziona tutto
=MODA(SE(A1:Z10<>A11;SE(A1:Z10<>A12;A1:Z10)))


da confermare con control+maiusc+invio: restituisce il terzo numero più frequente.

Non sono sicuro se hai bisogno di questo.

Se hai bisogno invece di contare quante volte compare il numero più frequente

=conta.se(a1:z10;moda(a1:z10))

e così via.



Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: funzione per contare numeri

Postdi A123691 » 24/02/13 08:45

Grazie 1000 Canapone

era proprio quello che cercavo :) :)

..........alla prossima
A123691
Utente Junior
 
Post: 53
Iscritto il: 27/11/07 22:34
Località: Lat.45° 04' Long. 6° 53'


Torna a Applicazioni Office Windows


Topic correlati a "funzione per contare numeri":


Chi c’è in linea

Visitano il forum: Lucio Peruggini e 13 ospiti