Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL - CALCOLO IN BASE A SCAGLIONI

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL - CALCOLO IN BASE A SCAGLIONI

Postdi eleinad75 » 22/01/13 16:14

Salve a tutti,
ho creato una tabella in excel dove viene riportato

da a percentuale
0 18.140 1,700%
18.141 27.210 1,530%
27.211 100.000 1,275%


in una casella ho inserito la seguente formula

Codice: Seleziona tutto
=SE(A1<=Foglio1!B2;Foglio1!C2;SE(E(Foglio1!A3<=A1; A1<=Foglio1!B3);A1*Foglio1!C3;SE(E(Foglio1!A4<=A1; A1<=Foglio1!B4);A1*Foglio1!C4;SE(E(Foglio1!A5<=A1; A1<=Foglio1!B5);A1*Foglio1!C5;SE(E(Foglio1!A6<=A1; A1<=Foglio1!B6);A1*Foglio1!C6)))))


nella casella A1 è inserito il valore di 38.500
Io vorrei che con la formula mi venisse calcolata la percentuale corrispondente per ogni scaglione
ossia
18.140 x 1,70%
9.069 x 1,53%
11.291 x 1,275%
uguale 591

con la formual scritta sopra invece il risultato è 490 che risulta essere 38.500 per 1,275%.

Cosa ho sbagliato nella formula?

Grazie!
eleinad75
Utente Junior
 
Post: 54
Iscritto il: 22/02/06 10:13

Sponsor
 

Re: EXCEL - CALCOLO IN BASE A SCAGLIONI

Postdi CANAPONE » 22/01/13 20:15

Ciao,

sicuramente da controllare se va bene

Codice: Seleziona tutto
=MIN(A1;18140)*1,7% +(A1>18140)*(MIN(A1;27210)-18140)*1,53%+(A1>27210)*(A1-27210)*1,275%



Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL - CALCOLO IN BASE A SCAGLIONI

Postdi CANAPONE » 23/01/13 06:43

Ciao,

una precisazione. La formula applica 1.53% a tutto lo scaglione 18141-27210, intendo compresi gli estremi

18140*1.7+9070*1.53+112290*1.275

Per ottenere

18140*1.7+9069*1.53+112291*1.275

[code]=MIN(A1;18140)*1,7% +(A1>18140)*(MIN(A1;27210)-18141)*1,53%+(A1>27210)*(A1-27210+1)*1,275%[code]

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL - CALCOLO IN BASE A SCAGLIONI

Postdi Anthony47 » 23/01/13 13:52

Mi pare che la seconda formula di canapone (vedi sopra) restituisca il risultato corretto, pero' io suggerirei di portare in una tabella separata i dati variabili, in modo da semplificare la gestione di soglie e percentuali modificabili nel tempo.
Quindi creare una tabella separata che contenga le informazioni Da-A e %, come in figura (parte gialla)
Immagine
Uploaded with ImageShack.us

Poi accanto (parte arancione) calcoliamo, per ogni scaglione, la quota percentuale dovuta allo scaglione precedente. Impostato in K2 il valore "zero", usare in K3 e K4 rispettivamente le seguenti formule
Codice: Seleziona tutto
=J2*I2

=(I3-I2)*J3+K3

Copiare poi K4 verso il basso
Per comodita' assegniamo il nome TabDati a questa tabella (H1:K11, nell' esempio); in questo modo, inoltre, bastera' usare questo nome per far riferimento alla tabella anche se si trova in un foglio diverso.

A questo punto il risultato che serve si calcolera' con la formula
Codice: Seleziona tutto
=CERCA.VERT(A1;TabDati;4)+(A1-CERCA.VERT(A1;TabDati;1))*CERCA.VERT(A1;TabDati;3)

Quando vorrai adottare soglie e percentuali diverse, ti bastera' modificare i dati in tabella (parte gialla); se nella tabella imposti il valore di inizio degli scaglioni successivi al primo pari al valore di fine dello scaglione precedente, allora ti bastera' modificare le colonne "A" e "%"; puoi ottenere cio' usando in H3 la formula =I2 da copiare verso il basso.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: EXCEL - CALCOLO IN BASE A SCAGLIONI

Postdi eleinad75 » 24/01/13 10:25

Grazie!!

Appena ho un attimo le provo entrambe!!
Grazie
eleinad75
Utente Junior
 
Post: 54
Iscritto il: 22/02/06 10:13


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL - CALCOLO IN BASE A SCAGLIONI":


Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti