Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Incrociare e unire i dati di due fogli excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Incrociare e unire i dati di due fogli excel

Postdi bartzuke » 11/12/12 09:43

Ciao ragazzi
bentrovati vi chiedo ancora una volta aiuto.
Ho due file di excel

file 1 : codice articolo - descrizione - quantita' venduta - categoria statistica -
file 2 : codice articolo - descrizione - codice ean - stato articolo -

vorrei creare un terzo file incrociando i due file per codice articolo, quindi avere :

file 3 : codice articolo - descrizione - quantita' venduta - categoria statistica - codice ean - stato articolo.

grazie.
a presto
Bartzuke
bartzuke
Utente Junior
 
Post: 16
Iscritto il: 06/11/12 06:07

Sponsor
 

Re: Incrociare e unire i dati di due fogli excel

Postdi wallace&gromit » 11/12/12 10:20

ciao bartzuke,
semplicemente crei il file 3 copiando il file 1 e aggiungendo due colonne, nelle quali con un CERCA.VERT trovi le corrispondenze del codice articolo nel file 2
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Incrociare e unire i dati di due fogli excel

Postdi bartzuke » 11/12/12 10:36

Ciao non sono una cima con excel, potresti essere piu' chiaro.

grazie
Bartzuke.
bartzuke
Utente Junior
 
Post: 16
Iscritto il: 06/11/12 06:07

Re: Incrociare e unire i dati di due fogli excel

Postdi wallace&gromit » 11/12/12 11:08

supponendo che i file siano organizzati come da te descritto con in prima riga l'intestazione e i valori a partire dalla cella A2, nel file 3 (che hai ottenuto con un salva con nome dal file 2, quindi per ora è identico) aggiungi le colonne E (codice EAN) e F(stato articolo).
in E2 inserisci la formula:
Codice: Seleziona tutto
=CERCA.VERT($A2;'[file 2.xls]Foglio1'!$A$2:$D$10000;3;0)

in F2
Codice: Seleziona tutto
=CERCA.VERT($A2;'[file 2.xls]Foglio1'!$A$2:$D$10000;4;0)
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Incrociare e unire i dati di due fogli excel

Postdi bartzuke » 11/12/12 11:19

Grazie sei stato di grande aiuto

tutto ok

saluti
bartzuke
bartzuke
Utente Junior
 
Post: 16
Iscritto il: 06/11/12 06:07


Torna a Applicazioni Office Windows


Topic correlati a "Incrociare e unire i dati di due fogli excel":


Chi c’è in linea

Visitano il forum: patel, raimea e 9 ospiti