Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Non riesco a collegare piu' formule SE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Non riesco a collegare piu' formule SE

Postdi oscar 2000 » 08/12/12 20:14

Salve, durante la programmazione di un software per un gioco mi sono ritrovato a dover inserire questa formula
=SE(AC24="GIOCA CAVALLO 1/4";"ATTENZIONE!!!";"LIVELLO5")
Cosi' come impostata funzione benissimo, il problemo l'ho avuto quando ho cercato di implementarla in questo modo
=SE(AC24="GIOCA CAVALLO 1/4";"ATTENZIONE!!!";"LIVELLO5");SE(AC25="GIOCA CAVALLO 1/4";"ATTENZIONE!!!";"LIVELLO5")
praticamente nella cella di riferimento mi da' VALORE!
Oltre ad innumerevoli prove ho anche inserito la formula in questo modo
=SE(AC24="GIOCA CAVALLO 1/4";"ATTENZIONE!!!";"LIVELLO5")&SE(AC25="GIOCA CAVALLO 1/4";"ATTENZIONE!!!";"LIVELLO5")
ma nella cella di riferimento mi da' un doppio valore livello 5 livello 5 praticamente legge tutte e due le formule.
Ci vorrebbe un simbolo che mi escudesse una formula al posto di un altra al verificarsi di un determinato evento.
Ho cercato di adottare altri sistemi trovati in internet ma non ne sono venuto a capo, da tener presente inoltre che tale formula andra' implementata con altri SE.
Mi hanno consigliato questo forum elogiandolo a tal punto da asserire che qui' ci sono dei veri mostri, spero vivamente che mi possiate aiutare e vi ringrazio anticipatamente per l'eventuale risposta.
oscar 2000
Utente Junior
 
Post: 12
Iscritto il: 08/12/12 19:49

Sponsor
 

Re: Non riesco a collegare piu' formule SE

Postdi Flash30005 » 08/12/12 20:37

Ciao Oscar 2000 e benventuo nel Forum

La sintassi è errata
Puoi nidificare la condizione SE
ma non devi concatenare come hai fatto tu
la formula sarà
=Se(Condizione1;Se vero1;Se(Condizione2;Se vero2;Se(Condizione3;Se vero3;Se falso fa altro)))

Oppure
=Se(E(condizione1;condizione2;condizione3);Se tutte le condizioni sono vere;Se falso)
oppure
=Se(O(condizione1;condizione2;condizione3);Se almeno una condizione è vera;Se falso)

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Non riesco a collegare piu' formule SE

Postdi oscar 2000 » 08/12/12 23:27

Grazie flash per la tempestiva risposta domani la attuo.
oscar 2000
Utente Junior
 
Post: 12
Iscritto il: 08/12/12 19:49

Re: Non riesco a collegare piu' formule SE

Postdi oscar 2000 » 08/12/12 23:40

Non ho resistito ed ho provato subito l'ultima formula che mi sembrava piu' adatta e piu' semplice
=Se(O(condizione1;condizione2;condizione3);Se almeno una condizione è vera;Se falso)
ha funzionato benissimo a primo colpo, grazie dinuovo flash30005
oscar 2000
Utente Junior
 
Post: 12
Iscritto il: 08/12/12 19:49


Torna a Applicazioni Office Windows


Topic correlati a "Non riesco a collegare piu' formule SE":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti