Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel casella vuota

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel casella vuota

Postdi STEFANO TRENTINI » 29/11/12 11:06

Problema:
Quando in una casella non metto nessun dato ,nella tabella mi conteggia UNO.(mi dovrebbe conteggiare ZERO)
Come si corregge l'errore???
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Sponsor
 

Re: excel casella vuota

Postdi Flash30005 » 29/11/12 13:40

Ciao Stefano e benvenuto nel Forum

Chi o cosa ti mette 1 nella cella vuota?

Se è una formula creata da te devi inserire la condizione SE vuota....Es.:
cellax =tuaformula
inserirai in cellax
Codice: Seleziona tutto
=Se(cellay="";"";tuaformula)


Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel casella vuota

Postdi STEFANO TRENTINI » 29/11/12 16:46

Grazie per la pronta risposta , cerco di spiegarmi meglio anche perche non so come fare per allegare il foglio excel per mostrare il problema , in una cella ( E8 ) ho una formula =SE(K8<=2;1;0) , e mi porta dentro un numero 1 , a me serve che quando (B8) e' vuoto di dato la casella mi riporti lo zero non uno !
ringrazio anticipatamente
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi wallace&gromit » 29/11/12 17:20

STEFANO TRENTINI ha scritto:che quando (B8) e' vuoto
Se intendevi "E8" allora dovrebbe andare bene questa formula:
Codice: Seleziona tutto
=SE(E(K8<=2;K8<>"");1;0)
altrimenti non si capisce bene da dove sbuca "B8"
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: excel casella vuota

Postdi STEFANO TRENTINI » 29/11/12 18:13

Grazie ma non ci sono ! io ho una serie di celle che dovrebbero portare lo zero invece mi da uno anche quando la cella b8 e vuota !
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi wallace&gromit » 29/11/12 18:21

se è giusto fare sempre riferimento a b8 prova così
=SE(E(K8<=2;$B$8<>"");1;0)
ora hai scritto sufficienti messaggi per potere allegare un file (forse chiarisci meglio il caso)
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: excel casella vuota

Postdi STEFANO TRENTINI » 29/11/12 18:36

Grazie siamo sulla strada giusta .... questa casella e' a posto
Adesso pero ho sempre altre caselle che mi portano uno invece dello zero quando b8 e' vuoto
piu precisamente
H8 CON =SE(E(C8<>0;D8<>0)=VERO;0;1) MI DA 1 ANZI CHE 0
I8 CON =SE((RESTO(K8;2))=0;1;0) MI DA 1 ANZICHE 0
O8 CON =SE(E(C8<>D8)=VERO;0;1) MI DA 1 ANZICHE 0
TUTTE E TRE CON B8 VUOTO
Grazie anticipatamente !
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi wallace&gromit » 29/11/12 22:06

Ogni volta devi inserire il riferimento a B8:
=SE(E(C8<>0;D8<>0;B8<>"");1;0)
=SE(E(RESTO(K8;2)=0;B8<>"");1;0)
=SE(E(C8<>D8;B8<>"");1;0)

non è necessario specificare "=vero" il controllo lo fa excel
non sono sicuro di averti corretto tutto giusto (ho invertito alcuni 1 e 0 nelle tue diciture)
altrimenti potrebbe essere così:
=SE(E(C8<>0;D8<>0);0;se(B8<>"";1;0))
=SE(E(RESTO(K8;2)=0;B8<>"");1;0)
=SE(C8<>D8;0;se(B8<>"";1;0))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: excel casella vuota

Postdi Flash30005 » 29/11/12 23:16

Perdona, Stefano
ma lavorare con excel significa usare la logica
Come pensi di avere dei risultati legati ad una cella (B8) se questa non è menzionata in nessuna delle tue formule? 8)
STEFANO TRENTINI ha scritto:ho sempre altre caselle che mi portano uno invece dello zero quando b8 e' vuoto
piu precisamente
H8 CON =SE(E(C8<>0;D8<>0)=VERO;0;1) MI DA 1 ANZI CHE 0
I8 CON =SE((RESTO(K8;2))=0;1;0) MI DA 1 ANZICHE 0
O8 CON =SE(E(C8<>D8)=VERO;0;1) MI DA 1 ANZICHE 0
TUTTE E TRE CON B8 VUOTO



Ciao

p.s. leggi il post di W&G, qui sopra
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel casella vuota

Postdi STEFANO TRENTINI » 30/11/12 10:45

Ciao grazie a tutti .... ma le celle non rispondo bene .... uff
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi STEFANO TRENTINI » 30/11/12 11:57

chi mi puo' aiutare in pvt ??? graziee ..
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi Anthony47 » 30/11/12 12:10

Personalmente non sono ingrado di fornire aiuto in privato.
Se vuoi puoi allegare un file di esempio, usando la procedura indicata qui:
viewtopic.php?f=26&t=80395

Il file sara' accessibile a tutti gli utenti del forum, quindi inserisci solo quanto serve per farci capire bene il problema.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel casella vuota

Postdi STEFANO TRENTINI » 30/11/12 15:49

grazie ecco allego il file con l' esempio
come puoi vedere nella riga 2 anche se non ci sono risultati in certe caselle con formula portano 1 anziche 0
ringrazio anticipatamente ..

https://rapidshare.com/files/2753290772 ... UZIONE.xls
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi wallace&gromit » 30/11/12 16:50

Allora, iniziamo con la risposta alla domanda che avresti dovuto porre: se nelle colonne C e D non figurano 2 valori nelle colonne accanto non devono apparire risultati.
Questo lo risolvi anteponendo questa parte di formula a tutte quelle che hai già inserito in riga 6:
Codice: Seleziona tutto
=SE(CONTA.VALORI($C$6:$D$6)<2;"";
dovrai poi chiudere una parentesi a tutte le formule.
Però lasciami dire che le tue formule sono per lo meno bizzarre: non capisco il valore di "U": se nella partita sono state segnate fino al massimo 2 reti 1 altrimenti 0 indifferentemente da chi le ha segnate??? :mmmh:
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: excel casella vuota

Postdi STEFANO TRENTINI » 30/11/12 17:17

grazie mille ! per la collaborazione ma se io antepongo la formula alla mia formula nelle celle mi da errore
=SE(CONTA.VALORI($C$6:$D$6)<2;"";=se(K6<=2;1;0)
chedo scusa per la mia ignoranza ma e' da poco che sto facendo formule per excel
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi Flash30005 » 30/11/12 17:22

Il segno uguale non va messo all'interno della formula e inoltre devi aggiungere una perentesi finale (chiusura del primo SE)
quindi
Codice: Seleziona tutto
=SE(CONTA.VALORI($C$6:$D$6)<2;"";se(K6<=2;1;0))


Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel casella vuota

Postdi STEFANO TRENTINI » 30/11/12 17:54

Grazie finalmente ci siamo grazie mille per le dritte !!!!
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi STEFANO TRENTINI » 12/12/12 11:11

Salve ho ancora bisogno di aiuto ..... ringrazio anticipatamente .... Allora ho bisogno di trovare la formula per gestire la somma dei gol . mi spiego :
somma--uscite------ritardi-----frequenze---indice di
gol----------------------------------------------convenienza
-----------------------------------------------------------------
0---------- 4----------- 2------------ 2,00-------- 1,00
1---------- 1----------- 5------------ 8,00-------- 0,63
2---------- 2----------- 2------------ 4,00-------- 0,50
3---------- 0----------- 8------------ 0,00-------- 0,00
4---------- 1----------- 4------------ 8,00-------- 0,50
4+-------- 0----------- 8------------ 0,00-------- 0,00

i risultati
0-0
2-2---------------i risultati che inserisco su delle colonne mi devo modificare la tabella sopra
1-3
1-4
2-3
1-1
3-1
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Re: excel casella vuota

Postdi Flash30005 » 12/12/12 14:26

Con tutto l'impegno non riesco a correlare i dati
dovresti indicare dove inserisci i dati (riga e colonna)
o, meglio, inviare un screenshot

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel casella vuota

Postdi STEFANO TRENTINI » 12/12/12 16:00

https://rapidshare.com/files/3307072441/doc1.pdf
i risultati vanno nelle colonne b-c .
STEFANO TRENTINI
Utente Junior
 
Post: 49
Iscritto il: 29/11/12 10:29

Prossimo

Torna a Applicazioni Office Windows


Topic correlati a "excel casella vuota":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti