Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula Excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: Formula Excel

Postdi Lucio Peruggini » 04/12/12 01:35

Ciao a tutti
Avrei necessità di ottenere i dati come foglio allegato.

Esempio: Range AG6:BJ39

In questo range si evincono stringhe numeriche con valori ordinati (piccolo – grande); in totale dodici stringhe che riportano 30 numeri diversi.
Alla riga 42 sono riportati i medesimi valori sempre in ordine crescente e per ognuno di essi, nella riga sottostante, quante volte si trova in queste stringhe.
Questa formula deve essere riporta nella medesima posizione su dieci fogli e, poiché l’ultima stringa è dinamica ma non solo (controllarli uno per volta è piuttosto faticoso per gli occhi), da qui la necessità della richiesta.

1, 3, 4, sono presenti dieci volte
5 tre volte
6 una volta
8 undici volte
12 nove volte
14 sette volte e così per tutti gli altri.
https://dl.dropbox.com/u/18220462/FILE/ ... RDINA.xlsx

Come sempre, grazie per l’aiuto.
Ciao
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23

Sponsor
 

Re: Formula Excel

Postdi Flash30005 » 04/12/12 07:18

In AG43 inserisci la formula
Codice: Seleziona tutto
=CONTA.SE($AG6:$BJ39;AG42)

copia verso destra qb

ciao

P.s. a me risulta che il 3 è presente 12 volte e il 4 è presente 11 volte :roll:
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Formula Excel

Postdi Flash30005 » 04/12/12 08:19

Forse ti occorre avere anche la riga 42 che vedo compilata per metà e con dei numeri mancanti (come il 7)
allora devi procedere per passi...
Inserisci nella cella AG42 questa formula
Codice: Seleziona tutto
=CONTA.SE($AG6:$BJ39;AG43)

(Non ti preoccupare se ora fornisce 0)

In AG43 questa formula
Codice: Seleziona tutto
=PICCOLO($AG6:$BJ39;RIF.COLONNA()-32-CONTA.VALORI($AF42:AF42)+SOMMA($AF42:AF42))


N.B. la cella AF42 deve essere vuota

Ora puoi selezionare le due celle AG42 e AG43 e trascini verso destra fino alla colonna CR

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Formula Excel

Postdi Lucio Peruggini » 04/12/12 13:30

Flash30005 ha scritto:Forse ti occorre avere anche la riga 42 che vedo compilata per metà e con dei numeri mancanti (come il 7)
allora devi procedere per passi...
Inserisci nella cella AG42 questa formula
Codice: Seleziona tutto
=CONTA.SE($AG6:$BJ39;AG43)

(Non ti preoccupare se ora fornisce 0)

In AG43 questa formula
Codice: Seleziona tutto
=PICCOLO($AG6:$BJ39;RIF.COLONNA()-32-CONTA.VALORI($AF42:AF42)+SOMMA($AF42:AF42))


N.B. la cella AF42 deve essere vuota

Ora puoi selezionare le due celle AG42 e AG43 e trascini verso destra fino alla colonna CR

ciao



La riga 42 era un piccolo esempio di quella che realmente doveva diventare.
Ben fatto!!!

Grazie infinite Flash, a buon rendere.
Lucio P.
Versione Office - 2013
Lucio Peruggini
Utente Senior
 
Post: 890
Iscritto il: 24/01/11 16:23

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "Formula Excel":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti