Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel2007 cercare 3 numeri consecutivi

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel2007 cercare 3 numeri consecutivi

Postdi asterix55 » 19/11/12 18:44

vorrei trovare 3 numeri in una colonna di altrettanti numeri però questi numeri li vorrei trovare solo se sono consecutivi in ordine di uscita
es. cercare 25 12 7 nella colonna A ma solo se sono usciti in quell'ordine
sarà possibile sapere come fare? grazie
asterix55
Utente Junior
 
Post: 27
Iscritto il: 14/11/12 18:35

Sponsor
 

Re: excel2007 cercare 3 numeri consecutivi

Postdi Flash30005 » 19/11/12 19:50

Si, penso, ma bisogna avere i dati origine e una volta trovati cosa fare

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel2007 cercare 3 numeri consecutivi

Postdi asterix55 » 19/11/12 20:33

diciamo che li voglio cercare in colonna A e metti il numero successivo in b1
asterix55
Utente Junior
 
Post: 27
Iscritto il: 14/11/12 18:35

Re: excel2007 cercare 3 numeri consecutivi

Postdi Flash30005 » 19/11/12 20:53

ah ecco!
Adesso diciamo che ho capito tutto! :roll:
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel2007 cercare 3 numeri consecutivi

Postdi Anthony47 » 19/11/12 21:46

Non hai detto dove sono elencati i tre numeri che vuoi cercare.
Immaginiamo che siano in D2-D3-D4
Creati un intervallo che chiami "intervallo" che contiene certamente tutti i dati di origine (non puo' essere l' intera colonna, ma lo puoi fare lungo anche per le esigenze future; ad esempio A1:A1000).
Poi in B1 metti la formula
Codice: Seleziona tutto
=SCARTO(A1;GRANDE((intervallo=$D$2)*(SCARTO(intervallo;1;0)=D$3)*(SCARTO(intervallo;2;0)=D$4)*RIF.RIGA(intervallo);1)+2;0)

Da confermare con Contr-Maiusc-Enter, non il solo Enter

Fai sapere.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel2007 cercare 3 numeri consecutivi

Postdi asterix55 » 19/11/12 22:45

asterix55
Utente Junior
 
Post: 27
Iscritto il: 14/11/12 18:35

Re: excel2007 cercare 3 numeri consecutivi

Postdi Anthony47 » 19/11/12 23:13

Hai creato "intervallo"?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel2007 cercare 3 numeri consecutivi

Postdi asterix55 » 19/11/12 23:28

si ho fatto A1:A115
mi viene cosi però
https://rapidshare.com/files/1646402275/Immagine3.jpg
asterix55
Utente Junior
 
Post: 27
Iscritto il: 14/11/12 18:35

Re: excel2007 cercare 3 numeri consecutivi

Postdi Anthony47 » 19/11/12 23:36

No, devi "definire un intervallo".
In XL2010: selezioni l' intervallo, es A1:A1000; tab Formule, gruppo Nomi definiti, Definisci nome; scrivi il nome (intervallo), premi Ok.
Poi usi la formula che ti ho dato.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel2007 cercare 3 numeri consecutivi

Postdi asterix55 » 20/11/12 00:21

ok ci sono finalmente dopo prova e riprova ci sono riuscito
grazie Anthony
asterix55
Utente Junior
 
Post: 27
Iscritto il: 14/11/12 18:35

Re: excel2007 cercare 3 numeri consecutivi

Postdi asterix55 » 20/11/12 18:13

suppongo che se io volessi cercare un numero solo successivo la formula verrebbe tagliata , ho provato ma non sono riuscito .
asterix55
Utente Junior
 
Post: 27
Iscritto il: 14/11/12 18:35

Re: excel2007 cercare 3 numeri consecutivi

Postdi Anthony47 » 21/11/12 01:05

suppongo che se io volessi cercare un numero solo successivo la formula verrebbe tagliata , ho provato ma non sono riuscito
Nell' ipotesi che tu ora voglia cercare "2 numeri consecutivi" e prendere il terzo della sequenza, userai
Codice: Seleziona tutto
=SCARTO(A1;GRANDE((intervallo=$D$2)*(SCARTO(intervallo;1;0)=D$3)*RIF.RIGA(intervallo);1)+1;0)

Mi sono accorto pero' che le formule proposte restituiscono un risultato verosimile ma non veritiero qualora la sequenza non esista in elenco.
Immagino che questo sia un problema, che si puo' aggirare modificando la formula iniziale in
Codice: Seleziona tutto
=SE(SOMMA((intervallo=$D$2)*(SCARTO(intervallo;1;0)=D$3)*(SCARTO(intervallo;2;0)=D$4))>0;SCARTO(A1;GRANDE((intervallo=$D$2)*(SCARTO(intervallo;1;0)=D$3)*(SCARTO(intervallo;2;0)=D$4)*RIF.RIGA(intervallo);1)+2;0);"###")

E quella per la sequenza di 2 in
Codice: Seleziona tutto
=SE(SOMMA((intervallo=$D$2)*(SCARTO(intervallo;1;0)=D$3))>0;SCARTO(A1;GRANDE((intervallo=$D$2)*(SCARTO(intervallo;1;0)=D$3)*RIF.RIGA(intervallo);1)+1;0);"###")

Ciao

PS: Per favore indica la tua configurazione di lavoro: viewtopic.php?f=26&t=97449
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "excel2007 cercare 3 numeri consecutivi":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti