Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - formula

Postdi gcaprodo » 07/11/12 01:00

Sono nuova del forum, anzi di tutti i forum e sono anche agli inizi con excel.
Scusate la richiesta cretina, sicuramente per voi. Ho un foglio excel con una serie di prodotti con relative descrizioni, cod.prodotto;descrizione;prezzo acquisto e pezzo vendita; come posso trasferire questi dati ad altri fogli intestati a singoli clienti utilizzando il solo cod.prodotto senza dover copiare manualmente ogni volta tutto?

Grazie infinite :idea:
gcaprodo
Newbie
 
Post: 5
Iscritto il: 06/11/12 12:56

Sponsor
 

Re: Excel - formula

Postdi ricky53 » 07/11/12 01:11

Ciao,
benvenuta nel nostro forum.

Quanto chiedi puoi farlo utilizzando la funzione "CERCA.VERT".
Nella guida troverai come va utilizzata ed anche degli esempi di utilizzo.

Allora: ipotizziamo che i tuoi dati siano nel Foglio1 e siamo costituiti da 100 righe:
Colonna A cod.prodotto
Colonna B descrizione
Colonna C prezzo acquisto
Colonna D prezzo vendita

i dati iniziano dalla riga "2" perchè nella riga "1" ci sono le intestazioni di colonna

nel Foglio2
in "A2" scriverai il tuo codice prodotto
in "B2" la seguente formula
Codice: Seleziona tutto
=CERCA.VERT(A2;Foglio1!$A$2:$D$100; 2; 0)
ed otterrai la descrizione del prodotto
in "C2" provaci tu

Nel Foglio2 cambiando in "A2" il prodotto automaticamente si aggiorneranno i dati in B2, C2, ...
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Excel - formula

Postdi gcaprodo » 08/11/12 16:59

Grazie infinite ricky53 ma, quella formula l'avevo già provata, mi restituisce solo la descrizione il prezzo acquisto e prezzo vendita no. Tra l'altro la descrizione me la restituisce in "B2" e non in "C2" come dici tu.
Rimango in attesa
gcaprodo
Newbie
 
Post: 5
Iscritto il: 06/11/12 12:56

Re: Excel - formula

Postdi ricky53 » 08/11/12 17:46

Ciao,

allora non è esatto quanto hai scritto
Tra l'altro la descrizione me la restituisce in "B2" e non in "C2" come dici tu.



io ti avevo scritto
in "B2" la seguente formula
...
ed otterrai la descrizione del prodotto



in "C2" dovevi essere tu a scrivere un'altra formula
(vedi quanto ti avevo scritto
in "C2" provaci tu
... dopo aver letto la guida ... pigrona, senza offesa ovviamente.

E' scontato devi dovrai modificare la colonna della matrice (parametro "Indice" della funzione "CERCA.VERT" ... però senza aver letto la guida.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Excel - formula

Postdi Flash30005 » 08/11/12 18:45

Ciao Gcaprodo e benvenuta nel Forum

La funzioneconsigiata da Ricky (cerca.verticale) dovrebbe risolvere il tuo quesito (tranne che non ci siano altre specifiche particolari)
e la la funzione postata per il tuo caso
Codice: Seleziona tutto
=CERCA.VERT(A2;Foglio1!$A$2:$D$100; 2; 0)


Significa che Cerca verticalmente il valore in A2
Codice: Seleziona tutto
]=CERCA.VERT(A2....

Nel foglio1
Codice: Seleziona tutto
=CERCA.VERT(A2;Foglio1!

Nel range A2:D100 dalla colonna A alla colonna D (riga da 2 a 100)
Codice: Seleziona tutto
=CERCA.VERT(A2;Foglio1!$A$2:$D$100;

Nella colonna B (determinato dall'indice che è 2, il secondo della matrice A:D, A= indice 1, B = indice 2, C= indice 3 etc)
Codice: Seleziona tutto
=CERCA.VERT(A2;Foglio1!$A$2:$D$100; 2;


Ed infine la tipologia dei dati se ordinati ordine crescente (Vero = 1, Falso = 0)
ed ecco qui spiegata la funzione
Codice: Seleziona tutto
=CERCA.VERT(A2;Foglio1!$A$2:$D$100; 2; 0)


Ora se ti occorre il dato di quell'elenco della colonna C
non devi far altro che cambiare il valore dell'indice (leggi su)

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel - formula

Postdi ricky53 » 08/11/12 18:53

Ciao,
il buon Flash ha riportato tutto quanto avresti trovato nella guida.
Leggilo e ne uscirai fuori ...
Se poi non ... allora sostituisci, nella formula della funzione CERCA.VERT, il "2" che ti ha restituito la descrizione con "3" per avere il prezzo di acquisto e con "4" per aver il prezzo di vendita.

Di più ... ti scriviamo la formula ma poi quanti ti rimarrà?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Excel - formula

Postdi gcaprodo » 08/11/12 19:16

caro ricky non sono pigra, e che forse sono rimbambita. Avevo letto la tua frase "ed otterrai la descrizione del prodotto
in "C2" provaci tu" come se fosse consecutiva. Con le punteggiature sono un po' pignola. Scusa nuovamente.
Caro Flash grazie mille; tutto molto chiaro.
Proverotti imedialtosto.
gcaprodo
Newbie
 
Post: 5
Iscritto il: 06/11/12 12:56

Re: Excel - formula

Postdi gcaprodo » 08/11/12 19:21

caro ricky mi parli di guida e mi mandi in palla. Dove si trova questa guida?
Lo sai sono a digiuno di forum; già per aprire le discussioni mi impicco.
Purtroppo ho una certa .....
Pensa che sono stata "negli anni 60" una programmatrice. Programmi che oggi hanno un altra veste, e che purtroppo per il lavoro che ho fatto negli ultimi 30 anni, non ho potuto seguire nelle loro evoluzioni.
gcaprodo
Newbie
 
Post: 5
Iscritto il: 06/11/12 12:56

Re: Excel - formula

Postdi gcaprodo » 08/11/12 19:46

Tutto ok. Grazie ragazzi. Spero di non rompervi più.

Ciao Ciao
gcaprodo
Newbie
 
Post: 5
Iscritto il: 06/11/12 12:56

Re: Excel - formula

Postdi ricky53 » 08/11/12 20:34

Ciao,
che dici, io sono sempre faceto.
Con i "...", per esempio, evidenzio qualcosa che ... sta a te/voi ricavare.

Io ho iniziato nel 1972 quindi tu prima di me ... cosa deduco???
Sei una donna quindi non mi permetto ...
Una cosa la dico: mi fa piacere aver letto quello che hai scritto e ... quanto non hai scritto.

Adesso ho voluto eccedere con i "..."

Siamo qui per la tua prossima necessità.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Excel - formula

Postdi Flash30005 » 08/11/12 21:00

Non per prendere le parti di nessuno
ma, sinceramente, a volte, la guida è utile per chi già conosce la funzione o ha dimestichezza con vba e funzioni.

Mi capita, ogni tanto di non capire gli esempi (che talvolta sono anche errati: in excel 2003 ne trovai diversi)!

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-


Torna a Applicazioni Office Windows


Topic correlati a "Excel - formula":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti