Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel 2003: somma.se instr

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel 2003: somma.se instr

Postdi karug64 » 05/11/12 21:55

Salve a tutti.
Nella colonna A ho delle descrizioni composte da data + totale. Quindi
A10=01/10/2011 Totale
A15=10/10/2011 Totale
A20=01/11/2011 Totale
ecc
ecc
nella colonna C ho dei ... totali

Posso avere in D100 la somma di tutte le righe che "contengono" la parola "totale" ?

Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel 2003: somma.se instr

Postdi ricky53 » 06/11/12 00:11

Ciao,

Tu vuoi la somma dei valori contenuti in colonna "C" "SOLO" per quelle celle della colonna "A" che contengono la parola "Totale"?

la parola "Totale" è sempre l'ultima in ogni cella della colonna "A" ?

Puoi utilizzare una colonna di appoggio?
Ultima modifica di ricky53 su 06/11/12 00:21, modificato 1 volte in totale.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: excel 2003: somma.se instr

Postdi Flash30005 » 06/11/12 00:16

Credo di si ma la stringa "Totale" è insieme alla data (come da post)
pertanto penso si debba usare una colonna appoggio con una formula da copiare fino dove occorre,
una formula nella colonna B tipo
Codice: Seleziona tutto
=DESTRA(A1;6)

da copiare verso il basso

Poi con una formula "MATR.SOMMA.PRODOTTO" si possa fare solo la somma della colonna C dove in B (colonna aggiunta) esista la stringa "Totale"

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel 2003: somma.se instr

Postdi ricky53 » 06/11/12 00:25

Ciao,
leggi la proposta di Flash.

Qualora "Totale" non fosse l'ultima parola delle varie celle allora con una colonna di appoggio "(Es. "AA")
in "AA1" scriverai
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA("Totale"; A1; 1)); 0;TROVA("Totale"; A1; 1))
che copierai in basso fino a necessità
poi in "D1002 scrivi
Codice: Seleziona tutto
=SOMMA.SE(AA1:AA100; ">0"; C1:C100)


Nel mio esempio ho ipotizzato che i tuoi dati arrivino fino alla riga "100" cambiala se occorre.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: excel 2003: somma.se instr

Postdi Anthony47 » 06/11/12 12:52

Senza colonna di appoggio:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(C1:C1000;--NON(VAL.ERRORE(TROVA("Totale";A1:A1000))))

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2003: somma.se instr

Postdi karug64 » 06/11/12 20:16

Grazie a tutti. Come sempre precisi, puntuali e disponibili.
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "excel 2003: somma.se instr":


Chi c’è in linea

Visitano il forum: Marius44 e 12 ospiti