Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cerca.vert

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cerca.vert

Postdi gio969 » 31/10/12 15:11

ciao a tutti chiedo ancora aiuto!

posso chiedere a cerca verticale che se non trova niente nella cella target di prendere invece il valore nella cella a destra?
spiego meglio. questa è la funzione:
CERCA.VERT($AH24;CALCOLO!AM:AO;2;FALSO))
si sposta a dx di 2 ---->se trova vuota si sposta di 3 (questo è quello che vorrei)

grazie a tutti
gio969
Utente Junior
 
Post: 40
Iscritto il: 31/05/12 11:20

Sponsor
 

Re: cerca.vert

Postdi Flash30005 » 31/10/12 16:31

Se non sono molti gli "spostamenti" si potrebbe pensare a due o tre condizioni SE (condizioni nidificate)
Considerando che il Cerca.Vert fornisce un certo tipo di errore in caso di mancato obiettivo (Errore.Tipo uguale a 7 )
ad esempio (per colonne A;B e C)
Codice: Seleziona tutto
=SE(ERRORE.TIPO(CERCA.VERT(6;A1:B8;2;FALSO))=7;CERCA.VERT(6;B1:C8;2;FALSO);CERCA.VERT(6;A1:B8;2;FALSO))

se non trova il valore in A adotta il cerca.verti nel range B e C etc etc

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: cerca.vert

Postdi ricky53 » 31/10/12 16:34

Ciao,
prova con questa formula
Codice: Seleziona tutto
=SE(VAL.ERRORE(CERCA.VERT($AH24;calcolo!AM:AO;2;FALSO)); "Dato non presente"; SE(CERCA.VERT($AH24;calcolo!AM:AO;2;FALSO)=""; CERCA.VERT($AH24;calcolo!AM:AO; 3;FALSO); CERCA.VERT($AH24;calcolo!AM:AO;2;FALSO)))


E' un po' lunga perchè ho inserito anche il controllo sul "#N/D"

ATTENZIONE: io dal tuo
... ---->se trova vuota ...

ho dedotto che significasse condizione trovata ma cella "AN ..." senza valori !!!


. . . . . . . . . . . . . . . . . .
EDIT
Mi sono sovrapposto con Flash
Ciao da Ricky53
. . . . . . . . . . . . . . . . . .
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: cerca.vert

Postdi gio969 » 01/11/12 11:22

Flash30005 ha scritto:Se non sono molti gli "spostamenti" si potrebbe pensare a due o tre condizioni SE (condizioni nidificate)
Considerando che il Cerca.Vert fornisce un certo tipo di errore in caso di mancato obiettivo (Errore.Tipo uguale a 7 )
ad esempio (per colonne A;B e C)
Codice: Seleziona tutto
=SE(ERRORE.TIPO(CERCA.VERT(6;A1:B8;2;FALSO))=7;CERCA.VERT(6;B1:C8;2;FALSO);CERCA.VERT(6;A1:B8;2;FALSO))

se non trova il valore in A adotta il cerca.verti nel range B e C etc etc

ciao



grazie mille molto interessante:)
gio969
Utente Junior
 
Post: 40
Iscritto il: 31/05/12 11:20

Re: cerca.vert

Postdi gio969 » 01/11/12 11:24

ricky53 ha scritto:Ciao,
prova con questa formula
Codice: Seleziona tutto
=SE(VAL.ERRORE(CERCA.VERT($AH24;calcolo!AM:AO;2;FALSO)); "Dato non presente"; SE(CERCA.VERT($AH24;calcolo!AM:AO;2;FALSO)=""; CERCA.VERT($AH24;calcolo!AM:AO; 3;FALSO); CERCA.VERT($AH24;calcolo!AM:AO;2;FALSO)))


E' un po' lunga perchè ho inserito anche il controllo sul "#N/D"

ATTENZIONE: io dal tuo
... ---->se trova vuota ...

ho dedotto che significasse condizione trovata ma cella "AN ..." senza valori !!!


. . . . . . . . . . . . . . . . . .
EDIT
Mi sono sovrapposto con Flash
Ciao da Ricky53
. . . . . . . . . . . . . . . . . .


grazie mille anche la tua soluzione è molto interessante
gio969
Utente Junior
 
Post: 40
Iscritto il: 31/05/12 11:20


Torna a Applicazioni Office Windows


Topic correlati a "cerca.vert":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti