Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel, Variare riferimenti in una formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel, Variare riferimenti in una formula

Postdi skate2k5 » 18/10/12 18:46

In una cartella ho due fogli.
Nel secondo foglio riporto dei riferimenti, ma dovendoli trascinare per coprire 31 giorni vorrei non dover ricontrollare tutte le formule a mano!!!

Praticamente questa formula devo trascinarla per ottenere i 31 giorni del mese:

Codice: Seleziona tutto
=SOMMA.SE(ANAGRAFICA!$D$6:$D120;"UFF";ANAGRAFICA!F6:F120)


e deve diventare così
Codice: Seleziona tutto
=SOMMA.SE(ANAGRAFICA!$D$6:$D120;"UFF";ANAGRAFICA!N6:N120)

poi
Codice: Seleziona tutto
=SOMMA.SE(ANAGRAFICA!$D$6:$D120;"UFF";ANAGRAFICA!V6:V120)


quindi il valore da incrementare è solo F-->diventa--->N--->diventa--->V.....come posso automatizzare?

Grazie
skate2k5
Newbie
 
Post: 6
Iscritto il: 18/10/12 18:39

Sponsor
 

Re: Incrementare valore in una formula

Postdi Anthony47 » 18/10/12 19:02

Ciao skate2k5, benvenuto nel forum.
Nell' ipotesi che tu debba trascinare le formule "verso il basso" userai
Codice: Seleziona tutto
=SOMMA.SE(ANAGRAFICA!$D$6:$D120;"UFF";Scarto(ANAGRAFICA!F$6:F$120;0;(RIF.RIGA(A1)-1)*8))

Se invece intendi trascinare "vreso dx" userai Rif.Colonna invece che Rif.Riga.

Fai sapere...
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Incrementare valore in una formula

Postdi skate2k5 » 18/10/12 19:03

Ok, ci provo e riferisco.
Grazie
skate2k5
Newbie
 
Post: 6
Iscritto il: 18/10/12 18:39

Re: Incrementare valore in una formula

Postdi skate2k5 » 18/10/12 19:10

....mmmmm.... non funziona;
lo faccio su colonna perchè devo trascinare verso destra ma non nella cella adiacente, ma in una cella distante 5 colonne.
ma perchè il RIF.COLONNA dovrebbe essere A1?

Grazie
skate2k5
Newbie
 
Post: 6
Iscritto il: 18/10/12 18:39

Re: Incrementare valore in una formula

Postdi Anthony47 » 18/10/12 19:16

Vedi che avevi omesso qualche piccolo, insignificante particolare? Prova con
Codice: Seleziona tutto
=SOMMA.SE(ANAGRAFICA!$D$6:$D120;"UFF";Scarto(ANAGRAFICA!$F$6:$F$120;0;INT((RIF.COLONNA(A1)/5))*8))

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel, Variare riferimenti in una formula

Postdi skate2k5 » 18/10/12 20:05

Cavolo...insignificante????
Funziona alla grande, grazie.
Ora cerco di capirne il funzionamento.
Grazie ancora
skate2k5
Newbie
 
Post: 6
Iscritto il: 18/10/12 18:39


Torna a Applicazioni Office Windows


Topic correlati a "Excel, Variare riferimenti in una formula":


Chi c’è in linea

Visitano il forum: fabrizio2001, Marius44 e 6 ospiti