Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel- formula]

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel- formula]

Postdi robsol » 02/10/12 08:46

Ciao! So che puo' sembrare una domanda idiota, ma non riesco a saltarne fuori.

QUalcuno riuscirebbe a decifrarmi letteralmente cosa dice questa formula???

=SUMIF(INDIRECT("'"&C$4&"'!$C$5:$C$1000"),"="&$B58,INDIRECT("'"&C$4&"'!$AE$5:$AE$1000"))/SUMIF(INDIRECT("'"&C$4&"'!$CB$5:CB1000"),$B$55,INDIRECT("'"&C$4&"'!$AE$5:$AE$1000"))
robsol
Newbie
 
Post: 7
Iscritto il: 19/09/12 10:08

Sponsor
 

Re: [excel- formula]

Postdi wallace&gromit » 02/10/12 10:20

ciao robsol,
innanzitutto c'è un errore: la formula dovrebbe essere:
Codice: Seleziona tutto
=SUMIF(INDIRECT("'"&C$4&"'!$C$5:$C$1000"),$B58,INDIRECT("'"&C$4&"'!$AE$5:$AE$1000"))/SUMIF(INDIRECT("'"&C$4&"'!$CB$5:CB1000"),$B$55,INDIRECT("'"&C$4&"'!$AE$5:$AE$1000"))

almeno, tradotta in italiano è così:
Codice: Seleziona tutto
=SOMMA.SE(INDIRETTO("'"&C$4&"'!$C$5:$C$1000");$B58;INDIRETTO("'"&C$4&"'!$AE$5:$AE$1000"))/SOMMA.SE(INDIRETTO("'"&C$4&"'!$CB$5:CB1000");$B$55;INDIRETTO("'"&C$4&"'!$AE$5:$AE$1000"))

e fa questo:
va a cercare i dati sul foglio il cui nome deve essere scritto nella cella C4
cerca se nella colonna C ci sono valori uguali al valore della cella B58, però non prende quei valori ma quelli che si trovano nella stessa riga della colonna AE.
Divide la somma di questi valori con la somma dei valori ottenuti in modo analogo ma partendo dal valore della cella b55, cercando prima nella colonna CB e estraendoli ancora dalla colonna AE.

Non vedo che scopo ci sia dietro a tutto ciò, ma qualcosa vorrà ben significare...
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "[excel- formula]":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti