Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Macro tra lettere e numeri assegnatogli

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Macro tra lettere e numeri assegnatogli

Postdi FutureP90 » 21/09/12 17:04

Non riesco a creare una macro:
Io ho una lista di lettere (a,b,c,d,e,f) ai quali viene assegnato un numero da 1 a 20.
Ecco io dovrei mettere questa lista di lettere in ordine nella griglia a destra, mettendo le lettere in ordine, piu il numero assegnato è alto, piu devono stare in alto nella griglia (In questo caso d,a,c,e,f,b).
Immagine

In pratica cambiando il numero assegnato alle lettere si deve automaticamente cambiare la lista, mettendo in alto le lettere con assegnati i numeri piu alti in basso quelli bassi...

Penso sia complicato..spero qualcuno riesca ad aiutarmi :cry:
FutureP90
Utente Junior
 
Post: 14
Iscritto il: 17/02/12 13:48

Sponsor
 

Re: [Excel] Macro tra lettere e numeri assegnatogli

Postdi wallace&gromit » 21/09/12 17:39

ciao future,
non serve una macro, basta una formula tipo:
Codice: Seleziona tutto
=INDICE(D$3:D$8;CONFRONTA(GRANDE(C$3:C$8;E3);C$3:C$8;))
però devi eliminare le celle unite, nella colonna C lasci i valori, nella colonna D hai i riferimenti, nella colonna E invece di "primo" "secondo" ecc. scrivi 1, 2,3,ecc.

P.S. scommetto che Anthony o Canapone ti scrivono una formula lunga la metà della mia...
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [Excel] Macro tra lettere e numeri assegnatogli

Postdi FutureP90 » 21/09/12 23:55

Ho provato ad usare la formula, anche eliminando le celle unite, e mi da come risultato "#NAME?"
Ho provato anche la formula
=GRANDE(C3:C8;1)
Ma mi scrive sempre "#NAME?"....ho Excel in Inglese, cambia qualcosa?
Grazie mille per la risposta comunque :D
FutureP90
Utente Junior
 
Post: 14
Iscritto il: 17/02/12 13:48

Re: [Excel] Macro tra lettere e numeri assegnatogli

Postdi Flash30005 » 22/09/12 03:43

Considerando i numeri in colonna C e le lettere in colonna D
Inserisci nella riga 3 di qualsiasi colonna
questa formula
Codice: Seleziona tutto
=CERCA.VERT(GRANDE(C$3:C$8;RIF.RIGA()-2);C$3:D$8;2;FALSO)

Trascina verso il basso
In inglese (da testare)
Codice: Seleziona tutto
=VLOOKUP(LARGE(C$3:C$8;ROW()-2);C$3:D$8;2;FALSE)


ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [Excel] Macro tra lettere e numeri assegnatogli

Postdi FutureP90 » 22/09/12 12:02

Grazie! Questa funziona! Ma se mettendo due numeri uguali mi da un risultato sbagliato :lol: ma svolge bene la sua funzione
Codice: Seleziona tutto
=VLOOKUP(LARGE(C$3:C$8;ROW()-2);C$3:D$8;2;FALSE)


Probabilmente il problema della formula precedente era l'inglese (colpa mia che non l'ho specificato prima)
FutureP90
Utente Junior
 
Post: 14
Iscritto il: 17/02/12 13:48

Re: [Excel] Macro tra lettere e numeri assegnatogli

Postdi Flash30005 » 22/09/12 13:32

Allora fai così
inserisci questo link tra i preferiti
continua a seguirci
( per valori uguali leggi questo topic)
quando trovi delle formule in italiano interessanti traduci la funzione con i vocaboli trovati nel link ;)

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [Excel] Macro tra lettere e numeri assegnatogli

Postdi FutureP90 » 27/09/12 12:18

Grazie mille! :D Utilissimo!
FutureP90
Utente Junior
 
Post: 14
Iscritto il: 17/02/12 13:48


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Macro tra lettere e numeri assegnatogli":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti