Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Funzione "conta.vuote" in VBA

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Funzione "conta.vuote" in VBA

Postdi GreenDays » 31/08/12 11:39

ciao :)

vorrei utilizzare la funzione in oggetto tramite VBA: ho queste celle:

A2 B2+C2 D2 E2+F2+G2 H2

B2+C2 significa che sono unite
E2+F2+G2 significa che sono unite


mi piacerebbe che una macro valutasse se le celle colorate di rosso sono vuote o piene.
Nel caso in cui fossero tutte piene allora colora la cella A2 di giallo, diversamente di blu.

Come potrei procedere? :roll:

Grazie mille :)
Utilizzo Microsoft Excel 2003
GreenDays
Utente Junior
 
Post: 29
Iscritto il: 21/05/12 08:25

Sponsor
 

Re: Funzione "conta.vuote" in VBA

Postdi Flash30005 » 31/08/12 22:33

Non occorre una macro
devi solo colorare le cella a2 di Blu
poi nella formattazione condizionale della cella inserisci
la formula è... (inserisci questa formula)
Codice: Seleziona tutto
=SE(E($B$2<>"";D2<>"";E2<>"";H2<>"");1;0)

colori di giallo a condzione soddisfatta

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-


Torna a Applicazioni Office Windows


Topic correlati a "Funzione "conta.vuote" in VBA":


Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti